aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--dns/gdnsd/Makefile27
-rw-r--r--dns/gdnsd/distinfo4
-rw-r--r--dns/gdnsd/pkg-descr13
-rw-r--r--dns/gdnsd/pkg-plist98
6 files changed, 70 insertions, 74 deletions
diff --git a/GIDs b/GIDs
index 032f9d6341af..eb2616276f89 100644
--- a/GIDs
+++ b/GIDs
@@ -90,6 +90,7 @@ agk:*:172:
polipo:*:173:
flowtools:*:174:
twms:*:175:
+gdnsd:*:179:
rt:*:180:
nagios:*:181:
noc:*:182:
diff --git a/UIDs b/UIDs
index 236ddfa28acd..068be824ee85 100644
--- a/UIDs
+++ b/UIDs
@@ -98,6 +98,7 @@ agk:*:172:172::0:0:AquaGateKeeper:/nonexistent:/nonexistent
polipo:*:173:173::0:0:polipo web cache:/nonexistent:/usr/sbin/nologin
flowtools:*:174:174::0:0:Flow-tools collector pseudo-user:/nonexistent:/usr/sbin/nologin
twms:*:175:175::0:0:tWMS pseudo-user:/nonexistent:/usr/sbin/nologin
+gdnsd:*:179:179::0:0:gDNSd pseudo-user:/nonexistent:/usr/sbin/nologin
nagios:*:181:181::0:0:Nagios pseudo-user:/var/spool/nagios:/usr/sbin/nologin
noc:*:182:182::0:0:NOC pseudo-user:/usr/local/noc:/bin/sh
icinga:*:183:183::0:0:Icinga pseudo-user:/var/spool/icinga:/usr/sbin/nologin
diff --git a/dns/gdnsd/Makefile b/dns/gdnsd/Makefile
index b8164be5469e..d12cc0d94f39 100644
--- a/dns/gdnsd/Makefile
+++ b/dns/gdnsd/Makefile
@@ -1,14 +1,10 @@
-# New ports collection makefile for: gdnsd
-# Date created: Tue May 15, 2012
-# Whom: Stefan Caunter <stef@scaleengine.com>
-#
+# Created by: Stefan Caunter <stef@scaleengine.com>
# $FreeBSD$
-#
PORTNAME= gdnsd
-PORTVERSION= 1.6.8
+PORTVERSION= 1.9.0
CATEGORIES= dns
-MASTER_SITES= https://github.com/blblack/gdnsd/downloads/ \
+MASTER_SITES= http://downloads.gdnsd.net/ \
http://gdnsd.scaleengine.net/gdnsd/
MAINTAINER= ports@scaleengine.com
@@ -16,32 +12,31 @@ COMMENT= Authoritative-only GeoIP-aware DNS server
LICENSE= GPLv3
+LIB_DEPENDS= ev:${PORTSDIR}/devel/libev
+
OPTIONS_DEFINE= GEOIP
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_XZ= yes
MAN1= gdnsd_geoip_test.1
MAN3= gdnsd-plugin-api.3
MAN5= gdnsd.config.5 gdnsd.zonefile.5
MAN8= gdnsd.8 gdnsd-plugin-simplefo.8 gdnsd-plugin-multifo.8 \
gdnsd-plugin-metafo.8 gdnsd-plugin-geoip.8 \
- gdnsd-plugin-weighted.8
+ gdnsd-plugin-weighted.8 gdnsd-plugin-extmon.8
MANCOMPRESSED= no
USE_RC_SUBR= gdnsd
+USERS?= gdnsd
+GROUPS?= gdnsd
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MWITH_GEOIP}
+.if ${PORT_OPTIONS:MGEOIP}
RUN_DEPENDS+= ${LOCALBASE}/share/GeoIP/GeoIP.dat:${PORTSDIR}/net/GeoIP
.endif
-post-install:
- ${CP} ${WRKDIR}/${DISTNAME}/docs/config.example ${ETCDIR}/config-dist
- @if [ ! -f ${ETCDIR}/config ]; then \
- ${CP} -p ${WRKDIR}/${DISTNAME}/docs/config.example ${ETCDIR}/config ; \
- fi
- ${CP} ${WRKDIR}/${DISTNAME}/docs/example.com ${ETCDIR}/example.com
-
.include <bsd.port.mk>
diff --git a/dns/gdnsd/distinfo b/dns/gdnsd/distinfo
index 2c1583366c6d..afc4071c9835 100644
--- a/dns/gdnsd/distinfo
+++ b/dns/gdnsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdnsd-1.6.8.tar.gz) = fcc55db9bfa68bfab083648bcee7e997c394360ce4d5bc8459dc655ce520a65f
-SIZE (gdnsd-1.6.8.tar.gz) = 953675
+SHA256 (gdnsd-1.9.0.tar.xz) = 050e52eda89d819ed340ec8cf49210de35c112ee993116906e13c4d2be19d38d
+SIZE (gdnsd-1.9.0.tar.xz) = 620632
diff --git a/dns/gdnsd/pkg-descr b/dns/gdnsd/pkg-descr
index 948cbd4099af..c526ed29b6f1 100644
--- a/dns/gdnsd/pkg-descr
+++ b/dns/gdnsd/pkg-descr
@@ -1,12 +1,13 @@
gdnsd is an Authoritative-only DNS server.
The initial g stands for Geographic, as gdnsd offers a plugin system for
-geographic (or other sorts of) balancing, redirection, and service-state-conscious
-failover. If you don't care about that feature, it's still quite good at being
-a very fast, lean, and resilient authoritative-only server for static DNS data.
+geographic (or other sorts of) balancing, redirection, and
+service-state-conscious failover. If you don't care about that feature,
+it's still quite good at being a very fast, lean, and resilient
+authoritative-only server for static DNS data.
-gdnsd is written in C using libev and pthreads with a focus on highi performance,
-low latency service. It does not offer any form of caching or recursive service,
-and does not support DNSSEC.
+gdnsd is written in C using libev and pthreads with a focus on high
+performance, low latency service. It does not offer any form of caching or
+recursive service, and does not support DNSSEC.
WWW: https://github.com/blblack/gdnsd/
diff --git a/dns/gdnsd/pkg-plist b/dns/gdnsd/pkg-plist
index fa09417f1998..6bf7600b9fed 100644
--- a/dns/gdnsd/pkg-plist
+++ b/dns/gdnsd/pkg-plist
@@ -1,52 +1,21 @@
bin/gdnsd_geoip_test
-@unexec if cmp -s %D/%%ETCDIR%%/config-dist %D/%%ETCDIR%%/config; then rm -f %D/%%ETCDIR%%/config; fi
-%%ETCDIR%%/config-dist
-@exec if [ ! -f %D/%%ETCDIR%%/config ] ; then cp -p %D/%F %B/config; fi
-%%ETCDIR%%/example.com
-@dirrmtry %%ETCDIR%%
-include/gdnsd-compiler.h
-include/gdnsd-dmn.h
-include/gdnsd-dname.h
-include/gdnsd-ev.h
-include/gdnsd-log.h
-include/gdnsd-misc.h
-include/gdnsd-monio.h
-include/gdnsd-net.h
-include/gdnsd-plugapi.h
-include/gdnsd-plugin.h
-include/gdnsd-satom.h
-include/gdnsd-vscf.h
-%%DOCSDIR%%/gdnsd-plugin-multifo.pod
-%%DOCSDIR%%/gdnsd-plugin-geoip.pod
-%%DOCSDIR%%/gdnsd-plugin-metafo.txt
-%%DOCSDIR%%/gdnsd_geoip_test.pod
-%%DOCSDIR%%/gdnsd-plugin-simplefo.txt
-%%DOCSDIR%%/gdnsd.zonefile.pod
-%%DOCSDIR%%/COPYING
-%%DOCSDIR%%/gdnsd.config.pod
-%%DOCSDIR%%/gdnsd_manual.pod
-%%DOCSDIR%%/gdnsd.txt
-%%DOCSDIR%%/gdnsd-plugin-api.pod
-%%DOCSDIR%%/gdnsd-plugin-weighted.txt
-%%DOCSDIR%%/AUTHORS
-%%DOCSDIR%%/gdnsd-plugin-simplefo.pod
-%%DOCSDIR%%/README.md
-%%DOCSDIR%%/gdnsd_geoip_test.txt
-%%DOCSDIR%%/gdnsd-plugin-metafo.pod
-%%DOCSDIR%%/gdnsd-plugin-geoip.txt
-%%DOCSDIR%%/gdnsd-plugin-multifo.txt
-%%DOCSDIR%%/config.example
-%%DOCSDIR%%/gdnsd.zonefile.txt
-%%DOCSDIR%%/gdnsd_manual.txt
-%%DOCSDIR%%/gdnsd.config.txt
-%%DOCSDIR%%/example.com
-%%DOCSDIR%%/gdnsd-plugin-api.txt
-%%DOCSDIR%%/ChangeLog
-%%DOCSDIR%%/gdnsd-plugin-weighted.pod
-%%DOCSDIR%%/gdnsd.pod
-%%DOCSDIR%%/INSTALL
+include/gdnsd/compiler.h
+include/gdnsd/dmn.h
+include/gdnsd/dname.h
+include/gdnsd/log.h
+include/gdnsd/misc.h
+include/gdnsd/mon.h
+include/gdnsd/net.h
+include/gdnsd/paths.h
+include/gdnsd/plugapi.h
+include/gdnsd/plugin.h
+include/gdnsd/stats.h
+include/gdnsd/vscf.h
+@dirrm include/gdnsd
lib/gdnsd/libgdnsd.la
lib/gdnsd/libgdnsd.so
+lib/gdnsd/plugin_extmon.la
+lib/gdnsd/plugin_extmon.so
lib/gdnsd/plugin_geoip.la
lib/gdnsd/plugin_geoip.so
lib/gdnsd/plugin_http_status.la
@@ -67,11 +36,40 @@ lib/gdnsd/plugin_tcp_connect.la
lib/gdnsd/plugin_tcp_connect.so
lib/gdnsd/plugin_weighted.la
lib/gdnsd/plugin_weighted.so
-@dirrm %%DOCSDIR%%/
@dirrm lib/gdnsd
+libexec/gdnsd/gdnsd_extmon_helper
+@dirrm libexec/gdnsd
sbin/gdnsd
-@exec mkdir -p %D/var/gdnsd
-@dirrm var/gdnsd
-@exec mkdir -p %D/etc/gdnsd
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/NEWS
+%%DOCSDIR%%/README.md
+%%DOCSDIR%%/gdnsd-plugin-api.pod
+%%DOCSDIR%%/gdnsd-plugin-api.txt
+%%DOCSDIR%%/gdnsd-plugin-extmon.pod
+%%DOCSDIR%%/gdnsd-plugin-extmon.txt
+%%DOCSDIR%%/gdnsd-plugin-geoip.pod
+%%DOCSDIR%%/gdnsd-plugin-geoip.txt
+%%DOCSDIR%%/gdnsd-plugin-metafo.pod
+%%DOCSDIR%%/gdnsd-plugin-metafo.txt
+%%DOCSDIR%%/gdnsd-plugin-multifo.pod
+%%DOCSDIR%%/gdnsd-plugin-multifo.txt
+%%DOCSDIR%%/gdnsd-plugin-simplefo.pod
+%%DOCSDIR%%/gdnsd-plugin-simplefo.txt
+%%DOCSDIR%%/gdnsd-plugin-weighted.pod
+%%DOCSDIR%%/gdnsd-plugin-weighted.txt
+%%DOCSDIR%%/gdnsd.config.pod
+%%DOCSDIR%%/gdnsd.config.txt
+%%DOCSDIR%%/gdnsd.pod
+%%DOCSDIR%%/gdnsd.txt
+%%DOCSDIR%%/gdnsd.zonefile.pod
+%%DOCSDIR%%/gdnsd.zonefile.txt
+%%DOCSDIR%%/gdnsd_geoip_test.pod
+%%DOCSDIR%%/gdnsd_geoip_test.txt
+%%DOCSDIR%%/gdnsd_manual.pod
+%%DOCSDIR%%/gdnsd_manual.txt
+@dirrm %%DOCSDIR%%
+@exec mkdir -p %D/%%ETCDIR%%/gdnsd
@dirrmtry etc/gdnsd
@stopdaemon gdnsd