aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile30
-rw-r--r--benchmarks/rubygem-gitlab-derailed_benchmarks/distinfo3
-rw-r--r--benchmarks/rubygem-gitlab-derailed_benchmarks/pkg-descr3
-rw-r--r--devel/Makefile2
-rw-r--r--devel/rubygem-ruby-statistics/Makefile20
-rw-r--r--devel/rubygem-ruby-statistics/distinfo3
-rw-r--r--devel/rubygem-ruby-statistics/pkg-descr7
-rw-r--r--devel/rubygem-slack-messenger/Makefile19
-rw-r--r--devel/rubygem-slack-messenger/distinfo3
-rw-r--r--devel/rubygem-slack-messenger/pkg-descr3
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rubygem-gitlab-mail_room/Makefile21
-rw-r--r--mail/rubygem-gitlab-mail_room/distinfo3
-rw-r--r--mail/rubygem-gitlab-mail_room/pkg-descr9
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-devise-two-factor-rails60/Makefile27
-rw-r--r--security/rubygem-devise-two-factor-rails60/distinfo3
-rw-r--r--security/rubygem-devise-two-factor-rails60/files/patch-gemspec11
-rw-r--r--security/rubygem-devise-two-factor-rails60/pkg-descr3
20 files changed, 173 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 0e244739ac23..f437800d713a 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -74,6 +74,7 @@
SUBDIR += rubygem-benchmark-ips
SUBDIR += rubygem-benchmark-memory
SUBDIR += rubygem-derailed_benchmarks
+ SUBDIR += rubygem-gitlab-derailed_benchmarks
SUBDIR += rubygem-railsbench
SUBDIR += scimark2
SUBDIR += scimark2c
diff --git a/benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile b/benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile
new file mode 100644
index 000000000000..bf0ca058e5f7
--- /dev/null
+++ b/benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile
@@ -0,0 +1,30 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gitlab-derailed_benchmarks
+PORTVERSION= 1.6.1
+CATEGORIES= benchmarks rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Benchmarks for your whole Rails app
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-benchmark-ips>=2.0.0:benchmarks/rubygem-benchmark-ips \
+ rubygem-get_process_mem>=0:devel/rubygem-get_process_mem \
+ rubygem-heapy>=0:devel/rubygem-heapy \
+ rubygem-memory_profiler>=0:devel/rubygem-memory_profiler \
+ rubygem-rack>=1:www/rubygem-rack \
+ rubygem-rake>=10<14:devel/rubygem-rake \
+ rubygem-ruby-statistics>=2.1:devel/rubygem-ruby-statistics \
+ rubygem-thor>=0.19:devel/rubygem-thor
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PLIST_FILES= bin/derailed
+
+.include <bsd.port.mk>
diff --git a/benchmarks/rubygem-gitlab-derailed_benchmarks/distinfo b/benchmarks/rubygem-gitlab-derailed_benchmarks/distinfo
new file mode 100644
index 000000000000..970e8f9f4182
--- /dev/null
+++ b/benchmarks/rubygem-gitlab-derailed_benchmarks/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585261398
+SHA256 (rubygem/gitlab-derailed_benchmarks-1.6.1.gem) = a0a912b1aa00c78e983c8641f66057a6cadfb1d51f8a8e6e549fb1f2ce203451
+SIZE (rubygem/gitlab-derailed_benchmarks-1.6.1.gem) = 112640
diff --git a/benchmarks/rubygem-gitlab-derailed_benchmarks/pkg-descr b/benchmarks/rubygem-gitlab-derailed_benchmarks/pkg-descr
new file mode 100644
index 000000000000..c52598ac2484
--- /dev/null
+++ b/benchmarks/rubygem-gitlab-derailed_benchmarks/pkg-descr
@@ -0,0 +1,3 @@
+Go faster, off the Rails - Benchmarks for your whole Rails app.
+
+WWW: https://github.com/schneems/derailed_benchmarks
diff --git a/devel/Makefile b/devel/Makefile
index 7bd6d0735554..651c0707da9b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6283,6 +6283,7 @@
SUBDIR += rubygem-ruby-prof
SUBDIR += rubygem-ruby-progressbar
SUBDIR += rubygem-ruby-sdl-ffi
+ SUBDIR += rubygem-ruby-statistics
SUBDIR += rubygem-ruby2_keywords
SUBDIR += rubygem-ruby2ruby
SUBDIR += rubygem-ruby_dep
@@ -6329,6 +6330,7 @@
SUBDIR += rubygem-simple_form-rails50
SUBDIR += rubygem-simplecov
SUBDIR += rubygem-skiptrace
+ SUBDIR += rubygem-slack-messenger
SUBDIR += rubygem-slack-notifier
SUBDIR += rubygem-slack-notifier1
SUBDIR += rubygem-slim
diff --git a/devel/rubygem-ruby-statistics/Makefile b/devel/rubygem-ruby-statistics/Makefile
new file mode 100644
index 000000000000..c9c501c6720c
--- /dev/null
+++ b/devel/rubygem-ruby-statistics/Makefile
@@ -0,0 +1,20 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ruby-statistics
+PORTVERSION= 2.1.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Provide ruby with statistical capabilities
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruby-statistics/distinfo b/devel/rubygem-ruby-statistics/distinfo
new file mode 100644
index 000000000000..8664d7b2b755
--- /dev/null
+++ b/devel/rubygem-ruby-statistics/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585261377
+SHA256 (rubygem/ruby-statistics-2.1.2.gem) = d08e9036fff4126113a94e51ff7d691d3b0c80bfc3f2abd088b13217664bad76
+SIZE (rubygem/ruby-statistics-2.1.2.gem) = 23040
diff --git a/devel/rubygem-ruby-statistics/pkg-descr b/devel/rubygem-ruby-statistics/pkg-descr
new file mode 100644
index 000000000000..fb92986956ba
--- /dev/null
+++ b/devel/rubygem-ruby-statistics/pkg-descr
@@ -0,0 +1,7 @@
+This gem is intended to accomplish the same purpose as
+jStat js library: to provide ruby with statistical capabilities
+without the need of a statistical programming language like
+R or Octave. Some functions and capabilities are an implementation
+from other authors and are referenced properly in the class/method.
+
+WWW: https://github.com/estebanz01/ruby-statistics
diff --git a/devel/rubygem-slack-messenger/Makefile b/devel/rubygem-slack-messenger/Makefile
new file mode 100644
index 000000000000..5b7517b8a5ae
--- /dev/null
+++ b/devel/rubygem-slack-messenger/Makefile
@@ -0,0 +1,19 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= slack-messenger
+PORTVERSION= 2.3.3
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Slim ruby wrapper for posting to slack webhooks
+
+LICENSE= MIT
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-slack-messenger/distinfo b/devel/rubygem-slack-messenger/distinfo
new file mode 100644
index 000000000000..c05e701b8419
--- /dev/null
+++ b/devel/rubygem-slack-messenger/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585260657
+SHA256 (rubygem/slack-messenger-2.3.3.gem) = 8789fcfac152cfbec1139cff2802ca289ce2a9586e235190c841343b82734be8
+SIZE (rubygem/slack-messenger-2.3.3.gem) = 13312
diff --git a/devel/rubygem-slack-messenger/pkg-descr b/devel/rubygem-slack-messenger/pkg-descr
new file mode 100644
index 000000000000..a084c8694e93
--- /dev/null
+++ b/devel/rubygem-slack-messenger/pkg-descr
@@ -0,0 +1,3 @@
+A slim ruby wrapper for posting to slack webhooks
+
+WWW: http://github.com/stevenosloan/slack-messenger
diff --git a/mail/Makefile b/mail/Makefile
index 146e676049f7..72eb1ebde97d 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -586,6 +586,7 @@
SUBDIR += rubygem-email_reply_parser-discourse
SUBDIR += rubygem-email_reply_trimmer
SUBDIR += rubygem-exception_notification
+ SUBDIR += rubygem-gitlab-mail_room
SUBDIR += rubygem-mail
SUBDIR += rubygem-mail_room
SUBDIR += rubygem-mailboxer
diff --git a/mail/rubygem-gitlab-mail_room/Makefile b/mail/rubygem-gitlab-mail_room/Makefile
new file mode 100644
index 000000000000..568aeaa5dd6f
--- /dev/null
+++ b/mail/rubygem-gitlab-mail_room/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= gitlab-mail_room
+PORTVERSION= 0.0.3
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= This mail_room will proxy email (gmail) from IMAP to a delivery method
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PLIST_FILES= bin/mail_room
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-gitlab-mail_room/distinfo b/mail/rubygem-gitlab-mail_room/distinfo
new file mode 100644
index 000000000000..023ffde593fe
--- /dev/null
+++ b/mail/rubygem-gitlab-mail_room/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585259333
+SHA256 (rubygem/gitlab-mail_room-0.0.3.gem) = 70930bcd016d939ab82dd732194fbc176f47d2c9b8923c52e6f9fb0ed12d9f60
+SIZE (rubygem/gitlab-mail_room-0.0.3.gem) = 26624
diff --git a/mail/rubygem-gitlab-mail_room/pkg-descr b/mail/rubygem-gitlab-mail_room/pkg-descr
new file mode 100644
index 000000000000..2a4b1df3a500
--- /dev/null
+++ b/mail/rubygem-gitlab-mail_room/pkg-descr
@@ -0,0 +1,9 @@
+mail_room is a configuration based process that will idle on IMAP connections
+and execute a delivery method when a new message is received.
+Examples of delivery methods include:
+
+POST to a delivery URL (Postback)
+Queue a job to Sidekiq or Que for later processing (Sidekiq or Que)
+Log the message or open with LetterOpener (Logger or LetterOpener)
+
+WWW: https://github.com/tpitale/mail_room
diff --git a/security/Makefile b/security/Makefile
index a725b0bf63e9..5bfef19a6321 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1051,6 +1051,7 @@
SUBDIR += rubygem-bcrypt_pbkdf
SUBDIR += rubygem-devise-two-factor
SUBDIR += rubygem-devise-two-factor-rails5
+ SUBDIR += rubygem-devise-two-factor-rails60
SUBDIR += rubygem-devise-two-factor30-rails52
SUBDIR += rubygem-devise-two-factor30-rails60
SUBDIR += rubygem-devise_pam_authenticatable2
diff --git a/security/rubygem-devise-two-factor-rails60/Makefile b/security/rubygem-devise-two-factor-rails60/Makefile
new file mode 100644
index 000000000000..6a936561a541
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails60/Makefile
@@ -0,0 +1,27 @@
+# Created by: Torsten Zuhlsdorff <ports@toco-domains.de>
+# $FreeBSD$
+
+PORTNAME= devise-two-factor
+PORTVERSION= 3.1.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails60
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Barebones two-factor authentication with Devise
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-activesupport60>=0<6.1:devel/rubygem-activesupport60 \
+ rubygem-attr_encrypted>=1.3<4:security/rubygem-attr_encrypted \
+ rubygem-devise-rails60>=4.0<5:devel/rubygem-devise-rails60 \
+ rubygem-railties60>=0<6.1:www/rubygem-railties60 \
+ rubygem-rotp>=2.0:devel/rubygem-rotp
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-devise-two-factor-rails60/distinfo b/security/rubygem-devise-two-factor-rails60/distinfo
new file mode 100644
index 000000000000..fda54b9aae6f
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails60/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565282920
+SHA256 (rubygem/devise-two-factor-3.1.0.gem) = c4ae641aef51339b10e8f2e0ee56c6abbaa81caa9d653926c1b4fb9ce13df33f
+SIZE (rubygem/devise-two-factor-3.1.0.gem) = 29184
diff --git a/security/rubygem-devise-two-factor-rails60/files/patch-gemspec b/security/rubygem-devise-two-factor-rails60/files/patch-gemspec
new file mode 100644
index 000000000000..58cec1f49700
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails60/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- devise-two-factor.gemspec.orig 2017-10-06 09:46:06 UTC
++++ devise-two-factor.gemspec
+@@ -28,7 +28,7 @@ Gem::Specification.new do |s|
+ s.add_runtime_dependency(%q<activesupport>.freeze, ["< 5.1"])
+ s.add_runtime_dependency(%q<attr_encrypted>.freeze, ["!= 2", "< 4", ">= 1.3"])
+ s.add_runtime_dependency(%q<devise>.freeze, ["~> 4.0"])
+- s.add_runtime_dependency(%q<rotp>.freeze, ["~> 2.0"])
++ s.add_runtime_dependency(%q<rotp>.freeze, [">= 2.0"])
+ s.add_development_dependency(%q<activemodel>.freeze, [">= 0"])
+ s.add_development_dependency(%q<appraisal>.freeze, [">= 0"])
+ s.add_development_dependency(%q<bundler>.freeze, ["> 1.0"])
diff --git a/security/rubygem-devise-two-factor-rails60/pkg-descr b/security/rubygem-devise-two-factor-rails60/pkg-descr
new file mode 100644
index 000000000000..314c84f06bb5
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails60/pkg-descr
@@ -0,0 +1,3 @@
+Barebones two-factor authentication with Devise
+
+WWW: https://github.com/tinfoil/devise-two-factor