aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/autodist/Makefile32
-rw-r--r--devel/autodist/distinfo3
-rw-r--r--devel/autodist/pkg-descr9
-rw-r--r--devel/autodist/pkg-plist6
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8a1215103e71..953f450fe034 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -69,6 +69,7 @@
SUBDIR += autoconf259
SUBDIR += autoconf261
SUBDIR += autodia
+ SUBDIR += autodist
SUBDIR += autogen
SUBDIR += automake110
SUBDIR += automake14
diff --git a/devel/autodist/Makefile b/devel/autodist/Makefile
new file mode 100644
index 000000000000..4378cd424f64
--- /dev/null
+++ b/devel/autodist/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: autodist
+# Date created: 2007-02-21
+# Whom: Peter Johnson <johnson.peter@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autodist
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= http://silcnet.org/download/autodist/sources/ \
+ http://public.planetmirror.com/pub/silcnet/autodist/sources/ \
+ ftp://ftp.planetmirror.com/pub/silcnet/autodist/sources/
+
+MAINTAINER= johnson.peter@gmail.com
+COMMENT= Distribution creation system
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+USE_GMAKE= yes
+
+MAN1= autodist.1
+INFO= autodist
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^install-exec-hook:/,/^$$/s/^ .*//' \
+ ${WRKSRC}/apps/autodist/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/devel/autodist/distinfo b/devel/autodist/distinfo
new file mode 100644
index 000000000000..de837a636527
--- /dev/null
+++ b/devel/autodist/distinfo
@@ -0,0 +1,3 @@
+MD5 (autodist-1.3.tar.gz) = bf1508eee5ef1c651687d8b5fd0c195e
+SHA256 (autodist-1.3.tar.gz) = da1a9a0da039845b1baaaf783c0b28682e311be98a0fdf0f3bc65f48b94e5223
+SIZE (autodist-1.3.tar.gz) = 217718
diff --git a/devel/autodist/pkg-descr b/devel/autodist/pkg-descr
new file mode 100644
index 000000000000..b97bd5d34d3c
--- /dev/null
+++ b/devel/autodist/pkg-descr
@@ -0,0 +1,9 @@
+The Autodist is a source distribution management system that allows
+powerful mechanisms to define what is included in and excluded from a
+distribution, and what license the distribution is released under. It is
+also used to create the actual distribution source packages. Autodist
+allows distribution management in file, directory and file content
+level. Autodist is especially targeted for large software projects, and
+projects where multiple distributions are created from one source tree.
+
+WWW: http://silcnet.org/software/developers/autodist/
diff --git a/devel/autodist/pkg-plist b/devel/autodist/pkg-plist
new file mode 100644
index 000000000000..49d921b92689
--- /dev/null
+++ b/devel/autodist/pkg-plist
@@ -0,0 +1,6 @@
+bin/autodist
+bin/makedist
+%%DATADIR%%/autodist.conf
+%%DATADIR%%/default
+%%DATADIR%%/COPYING
+@dirrm %%DATADIR%%