aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/bdc/Makefile21
-rw-r--r--security/bioapitool/Makefile8
-rw-r--r--security/calife-devel/Makefile11
-rw-r--r--security/calife-devel/pkg-plist2
-rw-r--r--security/cryptopp/Makefile10
-rw-r--r--security/doorman/Makefile16
-rw-r--r--security/doscan/Makefile8
-rw-r--r--security/drweb-postfix/Makefile5
-rw-r--r--security/drweb-qmail/Makefile5
-rw-r--r--security/drweb-sendmail/Makefile5
-rw-r--r--security/drweb/Makefile5
-rw-r--r--security/fwtk/Makefile2
-rw-r--r--security/gnupg1/Makefile4
-rw-r--r--security/ipsec-tools/Makefile4
-rw-r--r--security/medusa/Makefile6
-rw-r--r--security/ncrypt/Makefile6
-rw-r--r--security/openbsm/Makefile4
-rw-r--r--security/openssh-portable/Makefile7
-rw-r--r--security/osiris/Makefile2
-rw-r--r--security/pam_abl/Makefile4
-rw-r--r--security/pam_bsdbioapi/Makefile4
-rw-r--r--security/pam_krb5/Makefile11
-rw-r--r--security/pam_mkhomedir/Makefile8
-rw-r--r--security/pecl-gnupg/Makefile8
-rw-r--r--security/proxytunnel/Makefile9
-rw-r--r--security/rainbowcrack/Makefile4
-rw-r--r--security/stunnel/Makefile2
-rw-r--r--security/tlswrap/Makefile10
-rw-r--r--security/tripwire/Makefile9
-rw-r--r--security/yersinia/Makefile8
-rw-r--r--shells/ch/Makefile2
-rw-r--r--shells/zsh/Makefile2
32 files changed, 35 insertions, 177 deletions
diff --git a/security/bdc/Makefile b/security/bdc/Makefile
index 6e791058e73b..0c5a701e5b76 100644
--- a/security/bdc/Makefile
+++ b/security/bdc/Makefile
@@ -15,16 +15,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.2-fbsd${BDREL}
MAINTAINER= apircalabu@bitdefender.com
COMMENT= BitDefender Console Antivirus for FreeBSD
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 600000
-LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
-.endif
-.if ${OSVERSION} >= 500000 && ${OSVERSION} < 502001
-IGNORE= requires FreeBSD-STABLE \(4.9 or later\), or FreeBSD-CURRENT \(5.2.1 or later\)
-.else
-BDREL= 5
-.endif
-
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
@@ -33,6 +23,17 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
ONLY_FOR_ARCHS= i386
RESTRICTED= License prohibits redistribution
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
+.endif
+.if ${OSVERSION} < 502001
+IGNORE= requires FreeBSD 5.2.1 or later
+.else
+BDREL= 5
+.endif
+
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
ECHO_MSG= /usr/bin/printf
IGNORE= :\n\
diff --git a/security/bioapitool/Makefile b/security/bioapitool/Makefile
index c65db356ffbc..db86e251fc9d 100644
--- a/security/bioapitool/Makefile
+++ b/security/bioapitool/Makefile
@@ -18,10 +18,4 @@ LIB_DEPENDS= bioapi100.0:${PORTSDIR}/security/bioapi
MAN1= bioapitool.1
PLIST_FILES= sbin/bioapitool
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= needs at least FreeBSD 5.0-RELEASE
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/calife-devel/Makefile b/security/calife-devel/Makefile
index 66f989a07993..408b34334892 100644
--- a/security/calife-devel/Makefile
+++ b/security/calife-devel/Makefile
@@ -22,14 +22,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
CONFIGURE_ARGS+= --with-pam
-PLIST_SUB+= WITH_PAM=""
-.else
-PLIST_SUB+= WITH_PAM="@comment "
-.endif
CONFLICTS?= calife-2.*
@@ -37,9 +30,7 @@ MAN1= calife.1
MAN5= calife.auth.5
post-install:
-.if ${OSVERSION} >= 500000
@${INSTALL_DATA} ${WRKSRC}/pam/freebsd5 ${PREFIX}/etc/pam.d/calife.sample
@${CAT} ${PKGMESSAGE}
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/calife-devel/pkg-plist b/security/calife-devel/pkg-plist
index a44819eaf382..641665130209 100644
--- a/security/calife-devel/pkg-plist
+++ b/security/calife-devel/pkg-plist
@@ -1,3 +1,3 @@
bin/calife
etc/calife.auth-dist
-%%WITH_PAM%%etc/pam.d/calife.sample
+etc/pam.d/calife.sample
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 0eea74d368cf..eca2279441f8 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -13,7 +13,6 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.mirrors.wiretapped.net/security/cryptography/libraries/cryptolib/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= cryptopp${PORTVERSION:S/.//g}
-EXTRACT_SUFX= .zip
MAINTAINER= delphij@FreeBSD.org
COMMENT= A free C++ class library of Cryptographic Primitives
@@ -24,14 +23,9 @@ EXTRACT_BEFORE_ARGS= -aq
USE_GMAKE= yes
MAKEFILE= GNUmakefile
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Internal compiler error on alpha 4.x
-.endif
-
pre-install:
${STRIP_CMD} ${WRKSRC}/cryptest
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cryptest ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/libcryptopp.a ${PREFIX}/lib
@@ -47,4 +41,4 @@ do-install:
${CP} ${WRKSRC}/License.txt ${PREFIX}/share/doc/cryptopp/License
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/doorman/Makefile b/security/doorman/Makefile
index cee9114a8b41..c21b0dfd95f1 100644
--- a/security/doorman/Makefile
+++ b/security/doorman/Makefile
@@ -19,14 +19,6 @@ COMMENT= A Port Knocking implementation, both daemon and client
BUILD_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-
-# doormand does not work with the FreeBSD 4.x version of libpcap.
-# Require the ports version.
-.if ${OSVERSION} < 500000
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-.endif
-
PKGMESSAGE= ${WRKDIR}/pkg-message
PATCH_STRIP= -p1
@@ -45,12 +37,6 @@ pre-patch:
@${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
${WRKSRC}/doormand.c
-post-configure:
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's,-lpcap,${LOCALBASE}/lib/libpcap.a,' \
- ${WRKSRC}/Makefile
-.endif
-
post-install:
${RM} -f ${PREFIX}/etc/doormand/ipf_add
${INSTALL_SCRIPT} ${FILESDIR}/ipf_add.atend ${PREFIX}/etc/doormand/ipf_add.atend
@@ -68,4 +54,4 @@ post-install:
done
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/doscan/Makefile b/security/doscan/Makefile
index ea89942c347a..79f344422a57 100644
--- a/security/doscan/Makefile
+++ b/security/doscan/Makefile
@@ -24,12 +24,6 @@ NOT_FOR_ARCHS= sparc64
PLIST_FILES= bin/doscan
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${PATCHDIR}/freebsd4.diff
-.endif
-
post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -38,4 +32,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/drweb-postfix/Makefile b/security/drweb-postfix/Makefile
index 539c62910c74..4073f995669a 100644
--- a/security/drweb-postfix/Makefile
+++ b/security/drweb-postfix/Makefile
@@ -25,10 +25,7 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd411
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:f411
-.elif ${OSVERSION} >= 601000
+.if ${OSVERSION} >= 601000
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd61
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:f61
.else
diff --git a/security/drweb-qmail/Makefile b/security/drweb-qmail/Makefile
index 1572f04fc1ec..c2b5cb1a4fc8 100644
--- a/security/drweb-qmail/Makefile
+++ b/security/drweb-qmail/Makefile
@@ -25,10 +25,7 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd411
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:f411
-.elif ${OSVERSION} >= 601000
+.if ${OSVERSION} >= 601000
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd61
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:f61
.else
diff --git a/security/drweb-sendmail/Makefile b/security/drweb-sendmail/Makefile
index c8e987e65edf..e1860e313065 100644
--- a/security/drweb-sendmail/Makefile
+++ b/security/drweb-sendmail/Makefile
@@ -25,10 +25,7 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd411
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:f411
-.elif ${OSVERSION} >= 601000
+.if ${OSVERSION} >= 601000
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd61
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:f61
.else
diff --git a/security/drweb/Makefile b/security/drweb/Makefile
index 655c7d4b5ecf..653653929754 100644
--- a/security/drweb/Makefile
+++ b/security/drweb/Makefile
@@ -26,10 +26,7 @@ USE_RC_SUBR= drwebd.sh
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd411
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:f411
-.elif ${OSVERSION} >= 601000
+.if ${OSVERSION} >= 601000
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd61
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:f61
.else
diff --git a/security/fwtk/Makefile b/security/fwtk/Makefile
index 617358e8683e..8f72c34c3738 100644
--- a/security/fwtk/Makefile
+++ b/security/fwtk/Makefile
@@ -40,11 +40,9 @@ LIBEXEC_BINS= authsrv ftp-gw http-gw netacl plug-gw rlogin-gw smap smapd \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
.if defined(WITH_SKEY)
IGNORE= does not build on 5.x and above with WITH_SKEY set because it requires S/Key libraries and headers
.endif
-.endif
.if !defined(WITHOUT_X11)
MAN8+= x-gw.8
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index 0be7a4e64422..00e35f5d7f74 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -102,10 +102,6 @@ post-install:
PKGMESSAGE= /nonexistent
.endif
-.if ${OSVERSION} < 500000
-CONFIGURE_ARGS+= --without-readline
-.endif
-
check:
(cd ${WRKSRC}; ${MAKE} check)
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 61e1bfe9d83d..35e223c01808 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -155,11 +155,7 @@ pre-configure:
@${ECHO_MSG} "===> -------------------------------------------------------------------------"
@${ECHO_MSG} "===> ATTENTION: You need a kernel patch to enable NAT-Traversal functionality!"
@${ECHO_MSG} "===> You can download the patch here:"
-. if ${OSVERSION} < 500000
- @${ECHO_MSG} "===> http://ipsec-tools.sf.net/freebsd_nat-t.diff"
-. else
@${ECHO_MSG} "===> http://ipsec-tools.sf.net/freebsd6-natt.diff"
-. endif
@${ECHO_MSG} "===> You might possibly have to do some steps manually if it fails to apply."
@${ECHO_MSG} "===> -------------------------------------------------------------------------"
@sleep 3
diff --git a/security/medusa/Makefile b/security/medusa/Makefile
index e00276b74fe0..a63c910e1ab0 100644
--- a/security/medusa/Makefile
+++ b/security/medusa/Makefile
@@ -30,12 +30,6 @@ MAN1= medusa.1
BROKEN= Does not build on ia64
.endif
-.if ${OSVERSION} < 500000
-LIB_DEPENDS+= pth.20:${PORTSDIR}/devel/pth
-CFLAGS+= -L${LOCALBASE}/lib/pth
-USE_GCC= 3.2+
-.endif
-
.if defined(WITH_SVN)
LIB_DEPENDS+= svn_client-1:${PORTSDIR}/devel/subversion
CFLAGS+= -I${LOCALBASE}/include/subversion-1 -I${LOCALBASE}/include/apr-1
diff --git a/security/ncrypt/Makefile b/security/ncrypt/Makefile
index 33f8b82b86b7..2ba752966e15 100644
--- a/security/ncrypt/Makefile
+++ b/security/ncrypt/Makefile
@@ -26,12 +26,6 @@ PLIST_FILES= bin/ncrypt bin/nrm
post-configure:
@${REINPLACE_CMD} -E 's,^(CC|CFLAGS) =,\1 \?=,g' \
${WRKSRC}/Makefile
-.if (${OSVERSION} < 500000)
- @${REINPLACE_CMD} -e 's,stdint.h,inttypes.h,g' \
- ${WRKSRC}/standard.h
- @${REINPLACE_CMD} -e 's,O_SYNC,O_FSYNC,g' \
- ${WRKSRC}/wipe_file.c
-.endif
.if (${OSVERSION} < 501000)
@${REINPLACE_CMD} -e 's,ifndef WIN32,if (!defined(__FreeBSD__)),g' \
${WRKSRC}/ncrypt.c
diff --git a/security/openbsm/Makefile b/security/openbsm/Makefile
index d1d46bfd8f37..bc44e0c0cef2 100644
--- a/security/openbsm/Makefile
+++ b/security/openbsm/Makefile
@@ -46,10 +46,6 @@ MAN8= auditfilterd.8
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BROKEN= does not package on 5.X
-.endif
-
.if ( ( ${OSVERSION} < 600000 && ${OSVERSION} > 503100 ) || \
${OSVERSION} >= 600000 )
MAN8+= audit.8 \
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 9b1253e5e338..aed790deef6f 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -82,14 +82,7 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
.if !defined(WITHOUT_LIBEDIT)
-.if ${OSVERSION} > 500000
CONFIGURE_ARGS+= --with-libedit
-.else
-.if !defined(WITH_OVERWRITE_BASE)
-LIB_DEPENDS+= edit.6:${PORTSDIR}/devel/libedit
-CONFIGURE_ARGS+= --with-libedit=${LOCALBASE}
-.endif
-.endif
.endif
.if !defined(WITH_SUID_SSH)
diff --git a/security/osiris/Makefile b/security/osiris/Makefile
index 5808bd399eea..4aa7e09467db 100644
--- a/security/osiris/Makefile
+++ b/security/osiris/Makefile
@@ -25,7 +25,7 @@ USE_RC_SUBR= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
+.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
diff --git a/security/pam_abl/Makefile b/security/pam_abl/Makefile
index 57b1052516e1..8a3f49e0c20c 100644
--- a/security/pam_abl/Makefile
+++ b/security/pam_abl/Makefile
@@ -48,10 +48,6 @@ SED_SCRIPT= -e 's|<db.h>|<${BDB_INCLUDE_DIR}/db.h>|' \
-e 's|%%ETCPREFIX%%|${ETCPREFIX}|' \
-e 's|%%PAMABLDB%%|${PAMABLDB}|'
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
post-patch:
.for file in Makefile pam_abl.h conf/pam_abl.conf conf/system-auth doc/index.html doc/pam_abl.html tools/Makefile
@${REINPLACE_CMD} ${SED_SCRIPT} ${WRKSRC}/${file}
diff --git a/security/pam_bsdbioapi/Makefile b/security/pam_bsdbioapi/Makefile
index c46bf4a90bfa..eb26c869c4d5 100644
--- a/security/pam_bsdbioapi/Makefile
+++ b/security/pam_bsdbioapi/Makefile
@@ -51,8 +51,4 @@ post-install:
${INSTALL} ${WRKSRC}/etc/birdb.conf ${PREFIX}/etc/birdb.conf.sample
@${CAT} ${PKGMESSAGE}
-.if ${OSVERSION} < 500000
-IGNORE= needs at least FreeBSD 5.0-RELEASE
-.endif
-
.include <bsd.port.post.mk>
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
index 6af133b03531..a108fc7a2068 100644
--- a/security/pam_krb5/Makefile
+++ b/security/pam_krb5/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
MAINTAINER= cy@FreeBSD.org
-COMMENT= A Pluggable Authentication Module for Kerberos 5
+COMMENT= A Pluggable Authentication Module for Kerberos 5
MAN5= pam_krb5.5 pam_krb5afs.5
MAN8= pam_krb5.8 pam_krb5afs.8
@@ -23,6 +23,8 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+IGNORE= FreeBSD 5.x already ships with its own version of pam_krb5
+
.if defined(PACKAGE_BUILDING)
KRB5_IMPL= mit
.endif
@@ -41,11 +43,6 @@ KRB5_DIR?= ${KRB5_HOME}
IGNORE= You must define KRB5_IMPL to be \"mit\" or \"heimdal\"
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-IGNORE= FreeBSD 5.x already ships with its own version of pam_krb5
-.endif
MANDIR= ${MANPREFIX}/man
PREFIX= /usr
MANPREFIX= /usr/share
@@ -60,4 +57,4 @@ CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}" \
post-install:
cd ${WRKSRC} && ${GMAKE} install-man
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pam_mkhomedir/Makefile b/security/pam_mkhomedir/Makefile
index b684b13dcdf0..eb111d0cc142 100644
--- a/security/pam_mkhomedir/Makefile
+++ b/security/pam_mkhomedir/Makefile
@@ -17,12 +17,6 @@ MANCOMPRESSED= yes
MAN8= pam_mkhomedir.8
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= Only for 5.0 and above
-.endif
-
.if defined(WITH_PROFILE)
PLIST_SUB+= PROFILE=""
MAKE_ARGS+= PROFILE=yes
@@ -54,4 +48,4 @@ pre-everything::
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pecl-gnupg/Makefile b/security/pecl-gnupg/Makefile
index 4e43259f9aef..8defcac197f5 100644
--- a/security/pecl-gnupg/Makefile
+++ b/security/pecl-gnupg/Makefile
@@ -26,14 +26,8 @@ CONFIGURE_ARGS= --with-gnupg=${LOCALBASE}/include/gpgme
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000 && ${PHP_VER} == 5
-USE_GCC= 3.2+
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|\$$GNUPG_DIR/lib|${LOCALBASE}/lib|" -e "s|-ldl||g" \
${WRKSRC}/config.m4
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/proxytunnel/Makefile b/security/proxytunnel/Makefile
index 58bb2c95e554..ce2a16f6ff68 100644
--- a/security/proxytunnel/Makefile
+++ b/security/proxytunnel/Makefile
@@ -27,15 +27,10 @@ PORTDOCS= CHANGES CREDITS README
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CFLAGS+= -DUSE_SSL -DHAVE_SETPROCTITLE -DSPT_TYPE=1 -DREV=${SVNREV}
+CFLAGS+= -DHAVE_GETOPT_LONG
SVNREV= 161
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-CFLAGS+= -DHAVE_GETOPT_LONG
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/${MAKEFILE}
@@ -49,4 +44,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/rainbowcrack/Makefile b/security/rainbowcrack/Makefile
index ecb0ec6a43c0..9e0b1020fb98 100644
--- a/security/rainbowcrack/Makefile
+++ b/security/rainbowcrack/Makefile
@@ -15,10 +15,6 @@ COMMENT= Hash cracker that precomputes plaintext - ciphertext pairs in advance
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not build on 4.x
-.endif
-
.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
BROKEN= does not compile on ia64 or sparc64
.endif
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index c4ddbda14fa6..dc5ad8e29b09 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -105,7 +105,6 @@ cert:
@${ECHO} ""
@(cd ${WRKSRC}/tools/; make install-data-local)
-.if ${OSVERSION} > 500000
.if !defined(WITH_STUNNEL_SSL_ENGINE)
EXTRA_PATCHES= ${FILESDIR}/ssl-noengine.patch
pre-patch:
@@ -124,6 +123,5 @@ pre-patch:
@${ECHO} "code. You have enabled it at your own risk."
@${ECHO} "*************************************************************************"
.endif
-.endif
.include <bsd.port.post.mk>
diff --git a/security/tlswrap/Makefile b/security/tlswrap/Makefile
index 77dfa9ac8317..d938ce724ef3 100644
--- a/security/tlswrap/Makefile
+++ b/security/tlswrap/Makefile
@@ -20,14 +20,6 @@ USE_OPENSSL= yes
PLIST_FILES= bin/tlswrap
PORTDOCS= README
-.include <bsd.port.pre.mk>
-
-post-configure:
-.if ( ${OSVERSION} < 500000 )
- @${REINPLACE_CMD} -E 's,#define socklen_t size_t,,g' \
- ${WRKSRC}/conf.h
-.endif
-
post-patch:
@${REINPLACE_CMD} -E 's,^(CC|CFLAGS|LDFLAGS).*=,\1?=,g' \
${WRKSRC}/Makefile.in
@@ -38,4 +30,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/tripwire/Makefile b/security/tripwire/Makefile
index c666517d69ab..0f4c89e39fc0 100644
--- a/security/tripwire/Makefile
+++ b/security/tripwire/Makefile
@@ -50,13 +50,6 @@ TRIPWIRE_CLOBBER?= NO
# previously installed config files.
CONFIGURE_ARGS= --prefix=${PREFIX} --program-transform-name='' --sysconfdir=${TWCFG}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BUILD_DEPENDS= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-.endif
-
PLIST_SUB+= TWCFG=${TWCFG} TWDB=${TWDB}
pre-configure:
@@ -98,4 +91,4 @@ create-database:
post-install: install-config-files create-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index d053c67a531e..095d5a70ab49 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -34,12 +34,6 @@ CONFIGURE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-.endif
-
#NOT_FOR_ARCHS= ia64 sparc64
MAN8= yersinia.8
PLIST_FILES= sbin/yersinia
@@ -52,4 +46,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/yersinia ${PREFIX}/sbin/
${INSTALL_MAN} ${WRKSRC}/yersinia.8 ${PREFIX}/man/man8/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/ch/Makefile b/shells/ch/Makefile
index 8e14ad2a5cb8..e5ea2fe498fc 100644
--- a/shells/ch/Makefile
+++ b/shells/ch/Makefile
@@ -24,13 +24,11 @@ SUB_FILES= ${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
.if ${ARCH} == amd64
LIB32_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
.else
LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
.endif
-.endif
do-install:
${MKDIR} ${DATADIR}
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 9c1ff53ab9b2..6105f606801b 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -118,7 +118,7 @@ CONFIGURE_ARGS+= --enable-dynamic
PLIST_SUB+= NO_STATIC=""
.endif
-.if ${OSVERSION} >= 500000 && defined(WITH_ZSH_MULTIBYTE)
+.if defined(WITH_ZSH_MULTIBYTE)
CONFIGURE_ARGS+= --enable-multibyte
.endif