aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/celestia/Makefile4
-rw-r--r--graphics/cinepaint/Makefile8
-rw-r--r--print/cjk-lyx/Makefile4
-rw-r--r--www/chpasswd/Makefile8
4 files changed, 22 insertions, 2 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index f6a8b6c20dee..c0fdc56a374e 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -52,6 +52,10 @@ CONFIGURE_ARGS+= --without-lua
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
BROKEN= "Does not compile on !i386 and !amd64"
.endif
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index d9208a88d262..14fa8075f5ab 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -40,6 +40,12 @@ PLIST_SUB+= OPENEXR:=""
PLIST_SUB+= OPENEXR:="@comment "
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's| -Wall||' \
@@ -49,4 +55,4 @@ post-patch:
's|-LINUX.+$$||' \
${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/print/cjk-lyx/Makefile b/print/cjk-lyx/Makefile
index 9a7ffe6b8680..2af011255e1c 100644
--- a/print/cjk-lyx/Makefile
+++ b/print/cjk-lyx/Makefile
@@ -58,6 +58,10 @@ RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
.endif
diff --git a/www/chpasswd/Makefile b/www/chpasswd/Makefile
index be9348a64116..223ede1b084d 100644
--- a/www/chpasswd/Makefile
+++ b/www/chpasswd/Makefile
@@ -21,10 +21,16 @@ CONFIGURE_ARGS= --prefix=${PREFIX}/etc/chpasswd \
--enable-language=English \
--enable-cgidir=${PREFIX}/www/cgi-bin
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-install:
@${MKDIR} ${PREFIX}/www/cgi-bin
post-install:
@${ECHO} 'Remember, passwd and log file must be owned by httpd user, or chmod 777'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>