aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/geographiclib/Makefile6
-rw-r--r--astro/geographiclib/distinfo6
-rw-r--r--astro/geographiclib/pkg-plist4
3 files changed, 10 insertions, 6 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index 3255d228e118..c5ce8845bb79 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= geographiclib
-PORTVERSION= 1.40
+PORTVERSION= 1.41
CATEGORIES= astro
MASTER_SITES= SF/geographiclib/distrib\
SF/geographiclib:geoids,gravity,magnetic
@@ -30,7 +30,7 @@ USE_LDCONFIG= yes
OPTIONS_DEFINE= DOXYGEN PERL
OPTIONS_DEFAULT= DOXYGEN PERL\
GEOID_EGM96_5 GRAVITY_EGM96 GRAVITY_WGS84\
- MAGNETIC_WMM2015 MAGNETIC_IGRF11
+ MAGNETIC_WMM2015 MAGNETIC_IGRF12
PERL_DESC= Build documentation with pod2man and pod2html
OPTIONS_GROUP= DATASETS
OPTIONS_SUB= yes
@@ -43,7 +43,7 @@ PERL_CONFIGURE_ENV_OFF= ac_cv_prog_POD2MAN= ac_cv_prog_POD2HTML=
GEOID_NAMES:= egm84-30 egm84-15 egm96-15 egm96-5\
egm2008-5 egm2008-2_5 egm2008-1
GRAVITY_NAMES:= egm84 egm96 egm2008 wgs84 grs80
-MAGNETIC_NAMES:= wmm2010 wmm2015 igrf11 emm2010
+MAGNETIC_NAMES:= wmm2010 wmm2015 igrf11 igrf12 emm2010
.for n in ${GEOID_NAMES}
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} geoid dataset
diff --git a/astro/geographiclib/distinfo b/astro/geographiclib/distinfo
index f97bbd8fb79b..3dc9860a13fe 100644
--- a/astro/geographiclib/distinfo
+++ b/astro/geographiclib/distinfo
@@ -1,5 +1,5 @@
-SHA256 (GeographicLib/GeographicLib-1.40.tar.gz) = 4e82cca92277cb89482a86400ae01ddd7d6ad4f9046f3052068981ec52ed2d8c
-SIZE (GeographicLib/GeographicLib-1.40.tar.gz) = 2035280
+SHA256 (GeographicLib/GeographicLib-1.41.tar.gz) = 9d5eb90d5d33b0cbbecf71937acbfbd556615e346822340abdcb427aaf0390db
+SIZE (GeographicLib/GeographicLib-1.41.tar.gz) = 2037253
SHA256 (GeographicLib/geoids-distrib/egm84-30.tar.bz2) = 18bc3e2b55c4f9f2f9ba8d14380dc47cc5c0d00dc2363b723d2305f30a91498e
SIZE (GeographicLib/geoids-distrib/egm84-30.tar.bz2) = 416481
SHA256 (GeographicLib/geoids-distrib/egm84-15.tar.bz2) = 579e3dad2f33b54f1fed16edb3ed9d4ae8cdad6ea064f7375af30d678eb2e51c
@@ -30,5 +30,7 @@ SHA256 (GeographicLib/magnetic-distrib/wmm2015.tar.bz2) = 4c3fddb09955bbb556a955
SIZE (GeographicLib/magnetic-distrib/wmm2015.tar.bz2) = 1425
SHA256 (GeographicLib/magnetic-distrib/igrf11.tar.bz2) = 1289557fe660052c8fb42eb62d3307e8efd95a4d05031a1befd92f1f433f6457
SIZE (GeographicLib/magnetic-distrib/igrf11.tar.bz2) = 6011
+SHA256 (GeographicLib/magnetic-distrib/igrf12.tar.bz2) = fbad03ea24d9aa87e2fbc0179ea7f8a4787f235a2ec360abe42cd312000cba3f
+SIZE (GeographicLib/magnetic-distrib/igrf12.tar.bz2) = 6640
SHA256 (GeographicLib/magnetic-distrib/emm2010.tar.bz2) = aa8782fddb505d8dc24e3dd26784712c1b1848227e23cdcb4e4f2d3ed49d9e14
SIZE (GeographicLib/magnetic-distrib/emm2010.tar.bz2) = 3627692
diff --git a/astro/geographiclib/pkg-plist b/astro/geographiclib/pkg-plist
index e02552709b17..e7e6badd3f8e 100644
--- a/astro/geographiclib/pkg-plist
+++ b/astro/geographiclib/pkg-plist
@@ -52,7 +52,7 @@ include/GeographicLib/Utility.hpp
lib/libGeographic.a
lib/libGeographic.so
lib/libGeographic.so.14
-lib/libGeographic.so.14.0.1
+lib/libGeographic.so.14.0.2
%%PYTHON_SITELIBDIR%%/geographiclib/__init__.py
%%PYTHON_SITELIBDIR%%/geographiclib/accumulator.py
%%PYTHON_SITELIBDIR%%/geographiclib/constants.py
@@ -185,6 +185,8 @@ share/cmake/GeographicLib/FindGeographicLib.cmake
%%MAGNETIC_EMM2010%%%%DATADIR%%/magnetic/emm2010.wmm.cof
%%MAGNETIC_IGRF11%%%%DATADIR%%/magnetic/igrf11.wmm
%%MAGNETIC_IGRF11%%%%DATADIR%%/magnetic/igrf11.wmm.cof
+%%MAGNETIC_IGRF12%%%%DATADIR%%/magnetic/igrf12.wmm
+%%MAGNETIC_IGRF12%%%%DATADIR%%/magnetic/igrf12.wmm.cof
%%MAGNETIC_WMM2010%%%%DATADIR%%/magnetic/wmm2010.wmm
%%MAGNETIC_WMM2010%%%%DATADIR%%/magnetic/wmm2010.wmm.cof
%%MAGNETIC_WMM2015%%%%DATADIR%%/magnetic/wmm2015.wmm