aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/smap/Makefile27
-rw-r--r--security/smap/distinfo3
-rw-r--r--security/smap/pkg-descr8
4 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c2de7775a2f2..75598e6b1cfb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -665,6 +665,7 @@
SUBDIR += sks
SUBDIR += slurpie
SUBDIR += slush
+ SUBDIR += smap
SUBDIR += smtpmap
SUBDIR += smtpscan
SUBDIR += smurflog
diff --git a/security/smap/Makefile b/security/smap/Makefile
new file mode 100644
index 000000000000..2d7872d37d3f
--- /dev/null
+++ b/security/smap/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: smap
+# Date created: May 25, 2007
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smap
+PORTVERSION= 0.5.0
+CATEGORIES= security net
+MASTER_SITES= http://www.wormulon.net/smap/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= SIP scanner and identifier
+
+PLIST_FILES= bin/smap share/smap/fingerprint.db
+PLIST_DIRS= share/map
+
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/smap ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/smap
+ ${INSTALL_DATA} ${WRKSRC}/fingerprint.db ${PREFIX}/share/smap
+
+.include <bsd.port.mk>
diff --git a/security/smap/distinfo b/security/smap/distinfo
new file mode 100644
index 000000000000..1d77b6d66964
--- /dev/null
+++ b/security/smap/distinfo
@@ -0,0 +1,3 @@
+MD5 (smap-0.5.0.tar.gz) = 2c00757f3406bc8505a3fdd741f7d1c0
+SHA256 (smap-0.5.0.tar.gz) = 540e7c0e30e08ab007cc22b9c1b065ddfe809b42f07c283f5396a33bd5fddf52
+SIZE (smap-0.5.0.tar.gz) = 33282
diff --git a/security/smap/pkg-descr b/security/smap/pkg-descr
new file mode 100644
index 000000000000..d049de27da74
--- /dev/null
+++ b/security/smap/pkg-descr
@@ -0,0 +1,8 @@
+smap is a simple scanner for SIP enabled devices
+
+smap sends off various SIP requests awaiting responses from SIP
+enabled DSL router, proxies and user agents. It could be considered
+a mashup of nmap and sipsak ;)
+
+WWW: http://www.wormulon.net/
+Author: Hendrik Scholz <hscholz@raisdorf.net>