aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-WikiFormat/Makefile27
-rw-r--r--textproc/p5-Text-WikiFormat/distinfo1
-rw-r--r--textproc/p5-Text-WikiFormat/pkg-descr5
-rw-r--r--textproc/p5-Text-WikiFormat/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 07f1143cd9ff..a9174dc7b80e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -304,6 +304,7 @@
SUBDIR += p5-Text-Tabs+Wrap
SUBDIR += p5-Text-Template
SUBDIR += p5-Text-Tmpl
+ SUBDIR += p5-Text-WikiFormat
SUBDIR += p5-Text-Wrapper
SUBDIR += p5-Tk-XMLViewer
SUBDIR += p5-Tree-Nary
diff --git a/textproc/p5-Text-WikiFormat/Makefile b/textproc/p5-Text-WikiFormat/Makefile
new file mode 100644
index 000000000000..baa414648dfa
--- /dev/null
+++ b/textproc/p5-Text-WikiFormat/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Text-WikiFormat
+# Date created: Sat Jan 17 18:15:01 UTC 2004
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-WikiFormat
+PORTVERSION= 0.71
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= zaa@ulstu.ru
+COMMENT= Module for translating Wiki formatted text into other formats
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::WikiFormat.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-WikiFormat/distinfo b/textproc/p5-Text-WikiFormat/distinfo
new file mode 100644
index 000000000000..9801945f102d
--- /dev/null
+++ b/textproc/p5-Text-WikiFormat/distinfo
@@ -0,0 +1 @@
+MD5 (Text-WikiFormat-0.71.tar.gz) = f20ecdd2fb9520b9ca77f0dab49b2e19
diff --git a/textproc/p5-Text-WikiFormat/pkg-descr b/textproc/p5-Text-WikiFormat/pkg-descr
new file mode 100644
index 000000000000..7e82fcb541d3
--- /dev/null
+++ b/textproc/p5-Text-WikiFormat/pkg-descr
@@ -0,0 +1,5 @@
+Text::WikiFormat converts text in a simple Wiki markup language to whatever
+your little heart desires, provided you can describe it accurately in a
+semi-regular tag language.
+
+WWW: http://search.cpan.org/dist/Text-WikiFormat/
diff --git a/textproc/p5-Text-WikiFormat/pkg-plist b/textproc/p5-Text-WikiFormat/pkg-plist
new file mode 100644
index 000000000000..754699e45aa7
--- /dev/null
+++ b/textproc/p5-Text-WikiFormat/pkg-plist
@@ -0,0 +1 @@
+%%SITE_PERL%%/Text/WikiFormat.pm