aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED6
-rw-r--r--Mk/Uses/python.mk6
-rw-r--r--UPDATING14
-rw-r--r--devel/Makefile11
-rw-r--r--devel/py-d2to1/Makefile2
-rw-r--r--devel/py-mock/Makefile2
-rw-r--r--devel/py-setuptools36/Makefile10
-rw-r--r--devel/py-twine/Makefile2
-rw-r--r--devel/py27-setuptools/Makefile (renamed from devel/py-setuptools/Makefile)2
-rw-r--r--devel/py27-setuptools/distinfo (renamed from devel/py-setuptools/distinfo)0
-rw-r--r--devel/py27-setuptools/files/easy-install.pth.dist (renamed from devel/py-setuptools/files/easy-install.pth.dist)0
-rw-r--r--devel/py27-setuptools/files/pkg-message.in (renamed from devel/py-setuptools/files/pkg-message.in)0
-rw-r--r--devel/py27-setuptools/pkg-descr (renamed from devel/py-setuptools/pkg-descr)0
-rw-r--r--devel/py33-setuptools/Makefile (renamed from devel/py-setuptools34/Makefile)6
-rw-r--r--devel/py34-setuptools/Makefile (renamed from devel/py-setuptools27/Makefile)6
-rw-r--r--devel/py35-setuptools/Makefile (renamed from devel/py-setuptools33/Makefile)6
-rw-r--r--devel/py36-setuptools/Makefile (renamed from devel/py-setuptools35/Makefile)6
-rw-r--r--net-mgmt/net-snmp/Makefile4
-rw-r--r--security/gpgme/Makefile4
-rw-r--r--security/py-acme/Makefile2
-rw-r--r--security/py-certbot/Makefile2
-rw-r--r--security/py-crits/Makefile2
-rw-r--r--sysutils/bsdploy/Makefile2
-rw-r--r--sysutils/py-ploy/Makefile2
-rw-r--r--sysutils/py-ploy_ansible/Makefile2
-rw-r--r--sysutils/py-ploy_ec2/Makefile2
-rw-r--r--sysutils/py-ploy_ezjail/Makefile2
-rw-r--r--www/uzbl/Makefile2
28 files changed, 53 insertions, 52 deletions
diff --git a/MOVED b/MOVED
index 81253acd7573..dfcf24027895 100644
--- a/MOVED
+++ b/MOVED
@@ -9133,3 +9133,9 @@ databases/py-sqlalchemy09|databases/py-sqlalchemy10|2017-03-12|Has expired: Upst
devel/avr-gcc-devel||2017-03-13|Has expired: There's no longer a point to have both, a -devel and a regular port of GCC for the AVR
net/py-pysimplesoap|net/py-soap2py|2017-03-13|Rename to match upstream naming
games/trigger-data|games/trigger-rally|2017-03-15|Merged into games/trigger-rally
+devel/py-setuptools|devel/py27-setuptools|2017-03-16|Renamed to better match other python ports
+devel/py-setuptools27|devel/py27-setuptools|2017-03-16|Renamed to better match other python ports
+devel/py-setuptools33|devel/py33-setuptools|2017-03-16|Renamed to better match other python ports
+devel/py-setuptools34|devel/py34-setuptools|2017-03-16|Renamed to better match other python ports
+devel/py-setuptools35|devel/py35-setuptools|2017-03-16|Renamed to better match other python ports
+devel/py-setuptools36|devel/py36-setuptools|2017-03-16|Renamed to better match other python ports
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index fe6799a8870c..f7f478169fd2 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -481,9 +481,9 @@ UNIQUE_FIND_SUFFIX_FILES= \
_CURRENTPORT:= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
.if defined(_PYTHON_FEATURE_DISTUTILS) && \
- ${_CURRENTPORT:S/${PYTHON_SUFFIX}$//} != ${PYTHON_PKGNAMEPREFIX}setuptools
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
+ ${_CURRENTPORT} != ${PYTHON_PKGNAMEPREFIX}setuptools
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
.endif
# distutils support
diff --git a/UPDATING b/UPDATING
index 8fb06831c96b..52d11de41a5a 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,20 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20170316:
+ AFFECTS: users of python setuptools
+ AUTHOR: antoine@FreeBSD.org
+
+ The python setuptools ports have been renamed to better match other python ports.
+ Ports users need to rename them so that portupgrade and portmaster do not
+ get confused. For example:
+
+ pkg set -n py27-setuptools27:py27-setuptools
+ pkg set -o devel/py-setuptools27:devel/py27-setuptools
+ or
+ pkg set -n py35-setuptools35:py35-setuptools
+ pkg set -o devel/py-setuptools35:devel/py35-setuptools
+
20170312:
AFFECTS: users of textproc/ack
AUTHOR: sunpoet@FreeBSD.org
diff --git a/devel/Makefile b/devel/Makefile
index 6d6a2cdfc707..106b63db0dfc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4675,13 +4675,7 @@
SUBDIR += py-semantic_version
SUBDIR += py-serpent
SUBDIR += py-setproctitle
- SUBDIR += py-setuptools
SUBDIR += py-setuptools-git
- SUBDIR += py-setuptools27
- SUBDIR += py-setuptools33
- SUBDIR += py-setuptools34
- SUBDIR += py-setuptools35
- SUBDIR += py-setuptools36
SUBDIR += py-setuptools_darcs
SUBDIR += py-setuptools_hg
SUBDIR += py-setuptools_scm
@@ -4902,6 +4896,7 @@
SUBDIR += py-zope.testing
SUBDIR += py-zope.traversing
SUBDIR += py-zope.viewlet
+ SUBDIR += py27-setuptools
SUBDIR += py3-Jinja2
SUBDIR += py3-babel
SUBDIR += py3-click
@@ -4941,6 +4936,10 @@
SUBDIR += py3-wcwidth
SUBDIR += py3-xdg
SUBDIR += py3-yaml
+ SUBDIR += py33-setuptools
+ SUBDIR += py34-setuptools
+ SUBDIR += py35-setuptools
+ SUBDIR += py36-setuptools
SUBDIR += py_static_check
SUBDIR += pybugz
SUBDIR += pychecker
diff --git a/devel/py-d2to1/Makefile b/devel/py-d2to1/Makefile
index febf1aaeed20..162bd7d0b732 100644
--- a/devel/py-d2to1/Makefile
+++ b/devel/py-d2to1/Makefile
@@ -11,7 +11,7 @@ COMMENT= Distutils2-like setup.cfg files with setuptools setup.py
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose
USES= python
diff --git a/devel/py-mock/Makefile b/devel/py-mock/Makefile
index 8c878b848df3..a82238a81504 100644
--- a/devel/py-mock/Makefile
+++ b/devel/py-mock/Makefile
@@ -14,7 +14,7 @@ COMMENT= Mock unit tests for Python
LICENSE= BSD2CLAUSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.3:devel/py-pbr \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.3:devel/py-pbr \
${PYTHON_PKGNAMEPREFIX}six>=1.4.0:devel/py-six
TESTS_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox
diff --git a/devel/py-setuptools36/Makefile b/devel/py-setuptools36/Makefile
deleted file mode 100644
index 4480cfff6fbc..000000000000
--- a/devel/py-setuptools36/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-# $FreeBSD$
-
-PKGNAMESUFFIX= ${PYTHON_SUFFIX}
-
-PYTHON_VERSION= python3.6
-
-MASTERDIR= ${.CURDIR}/../py-setuptools
-
-.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-twine/Makefile b/devel/py-twine/Makefile
index 4741b1aa3ad4..7c60ac0e589b 100644
--- a/devel/py-twine/Makefile
+++ b/devel/py-twine/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}clint>=0:devel/py-clint \
${PYTHON_PKGNAMEPREFIX}pkginfo>=0:sysutils/py-pkginfo \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests \
${PYTHON_PKGNAMEPREFIX}requests-toolbelt>=0:www/py-requests-toolbelt \
- ${PYTHON_PKGNAMEPREFIX}setuptools27>=0:devel/py-setuptools27
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
USES= python
USE_PYTHON= distutils autoplist
diff --git a/devel/py-setuptools/Makefile b/devel/py27-setuptools/Makefile
index 706c6b714b7c..5dc624749ca4 100644
--- a/devel/py-setuptools/Makefile
+++ b/devel/py27-setuptools/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python packages installer
LICENSE= PSFL
NO_ARCH= yes
-USES= python
+USES?= python:2.7
USE_PYTHON= autoplist concurrent distutils
PYDISTUTILS_SETUP= ${PYSETUP}
diff --git a/devel/py-setuptools/distinfo b/devel/py27-setuptools/distinfo
index 4980f347de8a..4980f347de8a 100644
--- a/devel/py-setuptools/distinfo
+++ b/devel/py27-setuptools/distinfo
diff --git a/devel/py-setuptools/files/easy-install.pth.dist b/devel/py27-setuptools/files/easy-install.pth.dist
index e7ab88be464d..e7ab88be464d 100644
--- a/devel/py-setuptools/files/easy-install.pth.dist
+++ b/devel/py27-setuptools/files/easy-install.pth.dist
diff --git a/devel/py-setuptools/files/pkg-message.in b/devel/py27-setuptools/files/pkg-message.in
index 1797c069d7a7..1797c069d7a7 100644
--- a/devel/py-setuptools/files/pkg-message.in
+++ b/devel/py27-setuptools/files/pkg-message.in
diff --git a/devel/py-setuptools/pkg-descr b/devel/py27-setuptools/pkg-descr
index d7b599c66f2e..d7b599c66f2e 100644
--- a/devel/py-setuptools/pkg-descr
+++ b/devel/py27-setuptools/pkg-descr
diff --git a/devel/py-setuptools34/Makefile b/devel/py33-setuptools/Makefile
index b737e9d7b662..bff856edc9e5 100644
--- a/devel/py-setuptools34/Makefile
+++ b/devel/py33-setuptools/Makefile
@@ -1,10 +1,8 @@
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-PKGNAMESUFFIX= ${PYTHON_SUFFIX}
+MASTERDIR= ${.CURDIR}/../py27-setuptools
-PYTHON_VERSION= python3.4
-
-MASTERDIR= ${.CURDIR}/../py-setuptools
+USES= python:3.3
.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-setuptools27/Makefile b/devel/py34-setuptools/Makefile
index e0d894b5bf23..a8edc55ed4ef 100644
--- a/devel/py-setuptools27/Makefile
+++ b/devel/py34-setuptools/Makefile
@@ -1,10 +1,8 @@
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-PKGNAMESUFFIX= ${PYTHON_SUFFIX}
+MASTERDIR= ${.CURDIR}/../py27-setuptools
-PYTHON_VERSION= python2.7
-
-MASTERDIR= ${.CURDIR}/../py-setuptools
+USES= python:3.4
.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-setuptools33/Makefile b/devel/py35-setuptools/Makefile
index 2e5d4daffb11..07db5584c919 100644
--- a/devel/py-setuptools33/Makefile
+++ b/devel/py35-setuptools/Makefile
@@ -1,10 +1,8 @@
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-PKGNAMESUFFIX= ${PYTHON_SUFFIX}
+MASTERDIR= ${.CURDIR}/../py27-setuptools
-PYTHON_VERSION= python3.3
-
-MASTERDIR= ${.CURDIR}/../py-setuptools
+USES= python:3.5
.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-setuptools35/Makefile b/devel/py36-setuptools/Makefile
index 48190e6ae82c..709fca6916d4 100644
--- a/devel/py-setuptools35/Makefile
+++ b/devel/py36-setuptools/Makefile
@@ -1,10 +1,8 @@
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-PKGNAMESUFFIX= ${PYTHON_SUFFIX}
+MASTERDIR= ${.CURDIR}/../py27-setuptools
-PYTHON_VERSION= python3.5
-
-MASTERDIR= ${.CURDIR}/../py-setuptools
+USES= python:3.6
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 777d644c092a..32022e8b9e55 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -73,8 +73,8 @@ TLS_CONFIGURE_ON= --with-security-modules=tsm --with-transports=TLSTCP,DTLSUDP
PYDISTUTILS_PKGNAME?= netsnmp-python
PYDISTUTILS_PKGVERSION?= 1.0a1
USES+= python
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
CONFIGURE_ARGS+=--with-python-modules
CONFIGURE_ENV+= PYTHONPROG="${PYTHON_CMD}"
MAKE_ENV+= PYDISTUTILS_INSTALLARGS="${PYDISTUTILS_INSTALLARGS}" STAGEDIR="${STAGEDIR}"
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 784ba291d65e..cc1db08e60d6 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -74,8 +74,8 @@ USE_QT5= buildtools_build core testlib
. if ${SLAVEPORT} == "python"
BUILD_DEPENDS+= swig3.0:devel/swig30 \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
USES+= python
USE_PYTHON= py3kplist
CONFIGURE_ENV+= SWIG=${LOCALBASE}/bin/swig3.0
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index 82643289484c..9d2109b0949c 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339 \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>=1.0:devel/py-setuptools${PYTHON_SUFFIX} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=1.0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
${PYTHON_PKGNAMEPREFIX}werkzeug>0:www/py-werkzeug
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}funcsigs>0:devel/py-funcsigs \
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index 1ed54e9f347d..bc860fe7eab5 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme==${PKGVERSION}:security/py-acme \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339 \
${PYTHON_PKGNAMEPREFIX}python2-pythondialog>=3.2.2r1:devel/py-python2-pythondialog \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>=1.0:devel/py-setuptools${PYTHON_SUFFIX} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=1.0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
${PYTHON_PKGNAMEPREFIX}zope.component>0:devel/py-zope.component \
${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface \
diff --git a/security/py-crits/Makefile b/security/py-crits/Makefile
index 253732dd6c5d..ade025792f34 100644
--- a/security/py-crits/Makefile
+++ b/security/py-crits/Makefile
@@ -33,7 +33,7 @@ RUN_DEPENDS+= 7z:archivers/p7zip \
${PYTHON_PKGNAMEPREFIX}pycurl>0:ftp/py-pycurl \
${PYTHON_PKGNAMEPREFIX}pydot>=0:graphics/py-pydot \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml \
diff --git a/sysutils/bsdploy/Makefile b/sysutils/bsdploy/Makefile
index b202a716f8f6..9c6c577ee1de 100644
--- a/sysutils/bsdploy/Makefile
+++ b/sysutils/bsdploy/Makefile
@@ -11,7 +11,7 @@ COMMENT= Container Management for FreeBSD Jails
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2 \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
${PYTHON_PKGNAMEPREFIX}pyliblzma>0:archivers/py-pyliblzma \
${PYTHON_PKGNAMEPREFIX}ploy>=1.2.0:sysutils/py-ploy \
${PYTHON_PKGNAMEPREFIX}ploy_ansible>=1.3.0:sysutils/py-ploy_ansible \
diff --git a/sysutils/py-ploy/Makefile b/sysutils/py-ploy/Makefile
index 2c0813a9cd2a..6add0ae56757 100644
--- a/sysutils/py-ploy/Makefile
+++ b/sysutils/py-ploy/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lazy>0:devel/py-lazy \
${PYTHON_PKGNAMEPREFIX}paramiko1>0:security/py-paramiko1 \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
USES= python
USE_PYTHON= autoplist distutils
diff --git a/sysutils/py-ploy_ansible/Makefile b/sysutils/py-ploy_ansible/Makefile
index ab4dbea53d21..1229e9c0804d 100644
--- a/sysutils/py-ploy_ansible/Makefile
+++ b/sysutils/py-ploy_ansible/Makefile
@@ -13,7 +13,7 @@ COMMENT= Plugin to integrate Ansible with ploy
LICENSE= GPLv3
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
${PYTHON_PKGNAMEPREFIX}ploy>=1.0.0:sysutils/py-ploy \
${PYTHON_PKGNAMEPREFIX}execnet>0:sysutils/py-execnet \
ansible1<2.0:sysutils/ansible1
diff --git a/sysutils/py-ploy_ec2/Makefile b/sysutils/py-ploy_ec2/Makefile
index 3af33f5f9f87..e452b15a8945 100644
--- a/sysutils/py-ploy_ec2/Makefile
+++ b/sysutils/py-ploy_ec2/Makefile
@@ -13,7 +13,7 @@ COMMENT= Plugin for ploy to provision Amazon EC2 instances
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
${PYTHON_PKGNAMEPREFIX}ploy>=1.0.0:sysutils/py-ploy \
${PYTHON_PKGNAMEPREFIX}boto>=2.0:devel/py-boto \
${PYTHON_PKGNAMEPREFIX}lazy>0:devel/py-lazy
diff --git a/sysutils/py-ploy_ezjail/Makefile b/sysutils/py-ploy_ezjail/Makefile
index a9e2c1137263..9c4931f1a0e7 100644
--- a/sysutils/py-ploy_ezjail/Makefile
+++ b/sysutils/py-ploy_ezjail/Makefile
@@ -13,7 +13,7 @@ COMMENT= Plugin for ploy to provision FreeBSD jails using ezjail
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
${PYTHON_PKGNAMEPREFIX}ploy>=1.2.0:sysutils/py-ploy \
${PYTHON_PKGNAMEPREFIX}lazy>0:devel/py-lazy
diff --git a/www/uzbl/Makefile b/www/uzbl/Makefile
index e17c90a88b2a..8f6976b10132 100644
--- a/www/uzbl/Makefile
+++ b/www/uzbl/Makefile
@@ -12,7 +12,7 @@ COMMENT= Web interface tools which adhere to the unix philosophy
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
LIB_DEPENDS= libwebkitgtk-1.0.so:www/webkit-gtk2 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \