aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/heimdal/Makefile57
-rw-r--r--security/heimdal/distinfo6
-rw-r--r--security/heimdal/pkg-descr6
3 files changed, 36 insertions, 33 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index d31994200adc..5ebf7cfa4596 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -5,56 +5,60 @@
# $FreeBSD$
#
-PORTNAME= heimdal
-PORTVERSION= 0.6.3
-PORTREVISION= 3
-CATEGORIES= security ipv6
+PORTNAME= heimdal
+PORTVERSION= 0.6.6
+CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
ftp://ftp.sunet.se/pub/unix/admin/mirror-pdc/pub/heimdal/src/ \
ftp://ftp.ayamura.org/pub/heimdal/
-DISTNAME= heimdal-${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= nectar@FreeBSD.ORG
-COMMENT= A re-implementation of Kerberos V
+MAINTAINER= nectar@FreeBSD.ORG
+COMMENT= A re-implementation of Kerberos V
-CONFLICTS= krb4-[0-9]* krb5-[0-9]*
+CONFLICTS= krb4-[0-9]* krb5-[0-9]*
-OPTIONS+= LDAP "Use OpenLDAP as the KDC backend" off
-OPTIONS+= CRACKLIB "Use CrackLib for password quality checking" off
-OPTIONS+= X11 "Build X11 utilies" off
+OPTIONS+= LDAP "Use OpenLDAP as the KDC backend" off
+OPTIONS+= CRACKLIB "Use CrackLib for password quality checking" off
+OPTIONS+= X11 "Build X11 utilies" off
-USE_REINPLACE= yes
-USE_OPENSSL= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
CONFIGURE_ARGS+= --enable-shared --without-krb4
+INFO= heimdal
+PLIST= ${WRKDIR}/PLIST
+
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
+.endif
+
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-openldap=${LOCALBASE}
.endif
+
.if defined(WITH_CRACKLIB)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
.endif
+
.if defined(WITH_X11)
-USE_XLIB= yes
+USE_XLIB= yes
CONFIGURE_ARGS+= --with-x
.else
CONFIGURE_ARGS+= --without-x
.endif
.if defined(HEIMDAL_HOME)
-PREFIX= ${HEIMDAL_HOME}
+PREFIX= ${HEIMDAL_HOME}
.else
-CONFLICTS+= wu-ftpd-[0-9]* wu-ftpd+ipv6-[0-9]*
+CONFLICTS+= wu-ftpd-[0-9]* wu-ftpd+ipv6-[0-9]*
.endif
-INFO= heimdal
-PLIST:= ${WRKDIR}/PLIST
-
post-patch:
@${REINPLACE_CMD} -e 's|$$ac_cv_header_fnmatch_h|yes|' \
${WRKSRC}/configure
@@ -62,10 +66,10 @@ post-patch:
post-build:
.if defined(WITH_CRACKLIB)
${SED} -e "s;%%LOCALBASE%%;${LOCALBASE};g" \
- ${FILESDIR}/kpasswdd-cracklib.c.in > ${WRKSRC}/kpasswdd-cracklib.c
+ ${FILESDIR}/kpasswdd-cracklib.c.in > ${WRKSRC}/kpasswdd-cracklib.c
(cd ${WRKSRC} && \
- ${CC} ${CFLAGS} -fPIC -shared -I${LOCALBASE}/include -I./include \
- -L${LOCALBASE}/lib -o ./kpasswdd-cracklib.so ./kpasswdd-cracklib.c -lcrack)
+ ${CC} ${CFLAGS} -fPIC -shared -I${LOCALBASE}/include -I./include \
+ -L${LOCALBASE}/lib -o ./kpasswdd-cracklib.so ./kpasswdd-cracklib.c -lcrack)
.endif
pre-install:
@@ -90,7 +94,4 @@ post-install:
${SED} 's;%%PREFIX%%;${PREFIX};g' ${FILESDIR}/kdc.sh > \
${PREFIX}/etc/rc.d/kdc.sh.sample
-.if ${ARCH} == "amd64"
-CFLAGS+= -fPIC
-.endif
.include <bsd.port.post.mk>
diff --git a/security/heimdal/distinfo b/security/heimdal/distinfo
index df28f37d378c..4c8996bc6581 100644
--- a/security/heimdal/distinfo
+++ b/security/heimdal/distinfo
@@ -1,3 +1,3 @@
-MD5 (heimdal-0.6.3.tar.gz) = 2265fd2d4573dd3a8da45ce62519e48b
-SHA256 (heimdal-0.6.3.tar.gz) = c781fe1d0c50b637695f230ed5eb46e26e65217c599a87208675639117fe0e12
-SIZE (heimdal-0.6.3.tar.gz) = 3333604
+MD5 (heimdal-0.6.6.tar.gz) = dca1e8b8dab2bbc0baa28afc8232d1e2
+SHA256 (heimdal-0.6.6.tar.gz) = 9a924c33e966de7c0e5900c1a7b97a048b56fddbcd57d7527b192c7b8da6414b
+SIZE (heimdal-0.6.6.tar.gz) = 3337240
diff --git a/security/heimdal/pkg-descr b/security/heimdal/pkg-descr
index ceae9aea99fc..eeea4a0d3784 100644
--- a/security/heimdal/pkg-descr
+++ b/security/heimdal/pkg-descr
@@ -1,3 +1,5 @@
-Heimdal is a re-implementation of Kerberos V.
+Heimdal is an implementation of Kerberos 5. It
+is freely available under a three clause BSD
+style license.
-WWW: http://www.pdc.kth.se/heimdal/
+WWW: http://www.pdc.kth.se/heimdal/