aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/centericq/Makefile21
-rw-r--r--net-im/centericq/distinfo3
-rw-r--r--net-im/centericq/files/patch-Xml.h4
-rw-r--r--net-im/centericq/files/patch-configure20
-rw-r--r--net-im/centericq/files/patch-src::icqdialogs.cc10
-rw-r--r--net-im/centericq/pkg-descr4
-rw-r--r--net-im/centericq/pkg-plist15
-rw-r--r--net/centericq/Makefile21
-rw-r--r--net/centericq/distinfo3
-rw-r--r--net/centericq/files/patch-Xml.h4
-rw-r--r--net/centericq/files/patch-configure20
-rw-r--r--net/centericq/files/patch-src::icqdialogs.cc10
-rw-r--r--net/centericq/pkg-descr4
-rw-r--r--net/centericq/pkg-plist15
14 files changed, 106 insertions, 48 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index fb4235a08d4b..fdb6aab501ce 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= centericq
-PORTVERSION= 4.9.10
-PORTREVISION= 1
+PORTVERSION= 4.9.11
CATEGORIES= net
MASTER_SITES= http://centericq.de/archive/source/releases/
@@ -38,22 +37,8 @@ LIB_DEPENDS+= fribidi.0:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+= --with-fribidi
.endif
-.if defined(WITH_MSN)
-CONFIGURE_ARGS+= --enable-msn
-EXTRA_PATCHES= ${.CURDIR}/files/msn-*
-pre-patch:
- @${ECHO_CMD} "========================================================="
- @${ECHO_CMD} "=====================Important !!!======================="
- @${ECHO_CMD} "========================================================="
- @${ECHO_CMD} "There may be some sticky legal issues with the new"
- @${ECHO_CMD} "version of this protocol. Users should be aware that they"
- @${ECHO_CMD} "might be in violation of the DMCA or other laws. If this"
- @${ECHO_CMD} "is unacceptable, hit Ctrl-C now and remove WITH_MSN from"
- @${ECHO_CMD} "your make flags. The FreeBSD group assumes no"
- @${ECHO_CMD} "responsibility or liability for any losses or damages"
- @${ECHO_CMD} "sustained by use or disuse of software in the ports tree."
- @${ECHO_CMD} "========================================================="
- @sleep 5
+.if !defined(WITH_MSN)
+CONFIGURE_ARGS+= --disable-msn
.endif
.if !defined(WITH_YAHOO)
diff --git a/net-im/centericq/distinfo b/net-im/centericq/distinfo
index cedecc5f210c..a9ee09891892 100644
--- a/net-im/centericq/distinfo
+++ b/net-im/centericq/distinfo
@@ -1 +1,2 @@
-MD5 (centericq-4.9.10.tar.gz) = b461d4e39fa304d177f2990f27573ee8
+MD5 (centericq-4.9.11.tar.gz) = 771786081471360d28b4baeaf294da76
+SIZE (centericq-4.9.11.tar.gz) = 1623174
diff --git a/net-im/centericq/files/patch-Xml.h b/net-im/centericq/files/patch-Xml.h
index 9a9aa8e52a9d..bdeb795a360d 100644
--- a/net-im/centericq/files/patch-Xml.h
+++ b/net-im/centericq/files/patch-Xml.h
@@ -1,5 +1,5 @@
---- libicq2000-0.1/libicq2000/Xml.h.orig Sun Jul 27 14:08:10 2003
-+++ libicq2000-0.1/libicq2000/Xml.h Sun Jul 27 14:08:26 2003
+--- libicq2000-0.1/src/Xml.h.orig Sun Jul 27 14:08:10 2003
++++ libicq2000-0.1/src/Xml.h Sun Jul 27 14:08:26 2003
@@ -24,6 +24,8 @@
#ifndef XML_H
#define XML_H
diff --git a/net-im/centericq/files/patch-configure b/net-im/centericq/files/patch-configure
new file mode 100644
index 000000000000..512e2c030db9
--- /dev/null
+++ b/net-im/centericq/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Mon Mar 22 21:27:18 2004
++++ configure Sun Mar 28 12:33:02 2004
+@@ -4907,7 +4907,7 @@
+ #include "confdefs.h"
+ #include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
++extern int *libintl_nl_domain_bindings;
+ extern
+ #ifdef __cplusplus
+ "C"
+@@ -4915,7 +4915,7 @@
+ const char *_nl_expand_alias ();
+ int main() {
+ bindtextdomain ("", "");
+-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
++return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings + *_nl_expand_alias (0)
+ ; return 0; }
+ EOF
+ if { (eval echo configure:4922: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
diff --git a/net-im/centericq/files/patch-src::icqdialogs.cc b/net-im/centericq/files/patch-src::icqdialogs.cc
new file mode 100644
index 000000000000..779877585b37
--- /dev/null
+++ b/net-im/centericq/files/patch-src::icqdialogs.cc
@@ -0,0 +1,10 @@
+--- src/icqdialogs.cc.orig Tue Mar 16 05:59:43 2004
++++ src/icqdialogs.cc Sat Mar 27 13:13:51 2004
+@@ -33,6 +33,7 @@
+ #include "ljhook.h"
+
+ #include <libicq2000/userinfoconstants.h>
++#include <libicq2000/constants.h>
+
+ const char *stragerange(ICQ2000::AgeRange r) {
+ switch(r) {
diff --git a/net-im/centericq/pkg-descr b/net-im/centericq/pkg-descr
index 54d14c937062..b52c41583c74 100644
--- a/net-im/centericq/pkg-descr
+++ b/net-im/centericq/pkg-descr
@@ -1,5 +1,5 @@
Centericq is a text mode menu- and window-driven IM interface that
-supports the ICQ2000, Yahoo!, AIM, and IRC protocols. It allows you
+supports the ICQ2000, Yahoo!, MSN, AIM, and IRC protocols. It allows you
to send, receive, and forward messages, URLs, SMSes, contacts, and email
express messages. It also lets you set your own and fetch others' away
messages, and define external handlers for incoming events. You can
@@ -11,6 +11,4 @@ inactivity, and have your own ignore, visible, and invisible lists.
It can also associate events with sounds, make log of events, and
allows arrangement of contacts into groups.
-Note: MSN protocol is not supported offcially.
-
WWW: http://konst.org.ua/centericq/
diff --git a/net-im/centericq/pkg-plist b/net-im/centericq/pkg-plist
index 4d700e1699bb..3311ec849095 100644
--- a/net-im/centericq/pkg-plist
+++ b/net-im/centericq/pkg-plist
@@ -1,6 +1,19 @@
bin/centericq
bin/cicqconv
bin/cicqsync
+include/libicq2000/libicq2000/Client.h
+include/libicq2000/libicq2000/constants.h
+include/libicq2000/libicq2000/ContactList.h
+include/libicq2000/libicq2000/ContactTree.h
+include/libicq2000/libicq2000/Contact.h
+include/libicq2000/libicq2000/events.h
+include/libicq2000/libicq2000/exceptions.h
+include/libicq2000/libicq2000/ref_ptr.h
+include/libicq2000/libicq2000/sigslot.h
+include/libicq2000/libicq2000/time_extra.h
+include/libicq2000/libicq2000/Translator.h
+include/libicq2000/libicq2000/userinfoconstants.h
+include/libicq2000/libicq2000/version.h
%%DATADIR%%/email.wav
%%DATADIR%%/msg.wav
%%DATADIR%%/online.wav
@@ -22,3 +35,5 @@ share/locale/ru/LC_MESSAGES/centericq.mo
share/locale/sv/LC_MESSAGES/centericq.mo
share/locale/uk/LC_MESSAGES/centericq.mo
share/locale/zh_TW.Big5/LC_MESSAGES/centericq.mo
+@dirrm include/libicq2000/libicq2000
+@dirrm include/libicq2000
diff --git a/net/centericq/Makefile b/net/centericq/Makefile
index fb4235a08d4b..fdb6aab501ce 100644
--- a/net/centericq/Makefile
+++ b/net/centericq/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= centericq
-PORTVERSION= 4.9.10
-PORTREVISION= 1
+PORTVERSION= 4.9.11
CATEGORIES= net
MASTER_SITES= http://centericq.de/archive/source/releases/
@@ -38,22 +37,8 @@ LIB_DEPENDS+= fribidi.0:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+= --with-fribidi
.endif
-.if defined(WITH_MSN)
-CONFIGURE_ARGS+= --enable-msn
-EXTRA_PATCHES= ${.CURDIR}/files/msn-*
-pre-patch:
- @${ECHO_CMD} "========================================================="
- @${ECHO_CMD} "=====================Important !!!======================="
- @${ECHO_CMD} "========================================================="
- @${ECHO_CMD} "There may be some sticky legal issues with the new"
- @${ECHO_CMD} "version of this protocol. Users should be aware that they"
- @${ECHO_CMD} "might be in violation of the DMCA or other laws. If this"
- @${ECHO_CMD} "is unacceptable, hit Ctrl-C now and remove WITH_MSN from"
- @${ECHO_CMD} "your make flags. The FreeBSD group assumes no"
- @${ECHO_CMD} "responsibility or liability for any losses or damages"
- @${ECHO_CMD} "sustained by use or disuse of software in the ports tree."
- @${ECHO_CMD} "========================================================="
- @sleep 5
+.if !defined(WITH_MSN)
+CONFIGURE_ARGS+= --disable-msn
.endif
.if !defined(WITH_YAHOO)
diff --git a/net/centericq/distinfo b/net/centericq/distinfo
index cedecc5f210c..a9ee09891892 100644
--- a/net/centericq/distinfo
+++ b/net/centericq/distinfo
@@ -1 +1,2 @@
-MD5 (centericq-4.9.10.tar.gz) = b461d4e39fa304d177f2990f27573ee8
+MD5 (centericq-4.9.11.tar.gz) = 771786081471360d28b4baeaf294da76
+SIZE (centericq-4.9.11.tar.gz) = 1623174
diff --git a/net/centericq/files/patch-Xml.h b/net/centericq/files/patch-Xml.h
index 9a9aa8e52a9d..bdeb795a360d 100644
--- a/net/centericq/files/patch-Xml.h
+++ b/net/centericq/files/patch-Xml.h
@@ -1,5 +1,5 @@
---- libicq2000-0.1/libicq2000/Xml.h.orig Sun Jul 27 14:08:10 2003
-+++ libicq2000-0.1/libicq2000/Xml.h Sun Jul 27 14:08:26 2003
+--- libicq2000-0.1/src/Xml.h.orig Sun Jul 27 14:08:10 2003
++++ libicq2000-0.1/src/Xml.h Sun Jul 27 14:08:26 2003
@@ -24,6 +24,8 @@
#ifndef XML_H
#define XML_H
diff --git a/net/centericq/files/patch-configure b/net/centericq/files/patch-configure
new file mode 100644
index 000000000000..512e2c030db9
--- /dev/null
+++ b/net/centericq/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Mon Mar 22 21:27:18 2004
++++ configure Sun Mar 28 12:33:02 2004
+@@ -4907,7 +4907,7 @@
+ #include "confdefs.h"
+ #include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
++extern int *libintl_nl_domain_bindings;
+ extern
+ #ifdef __cplusplus
+ "C"
+@@ -4915,7 +4915,7 @@
+ const char *_nl_expand_alias ();
+ int main() {
+ bindtextdomain ("", "");
+-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
++return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings + *_nl_expand_alias (0)
+ ; return 0; }
+ EOF
+ if { (eval echo configure:4922: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
diff --git a/net/centericq/files/patch-src::icqdialogs.cc b/net/centericq/files/patch-src::icqdialogs.cc
new file mode 100644
index 000000000000..779877585b37
--- /dev/null
+++ b/net/centericq/files/patch-src::icqdialogs.cc
@@ -0,0 +1,10 @@
+--- src/icqdialogs.cc.orig Tue Mar 16 05:59:43 2004
++++ src/icqdialogs.cc Sat Mar 27 13:13:51 2004
+@@ -33,6 +33,7 @@
+ #include "ljhook.h"
+
+ #include <libicq2000/userinfoconstants.h>
++#include <libicq2000/constants.h>
+
+ const char *stragerange(ICQ2000::AgeRange r) {
+ switch(r) {
diff --git a/net/centericq/pkg-descr b/net/centericq/pkg-descr
index 54d14c937062..b52c41583c74 100644
--- a/net/centericq/pkg-descr
+++ b/net/centericq/pkg-descr
@@ -1,5 +1,5 @@
Centericq is a text mode menu- and window-driven IM interface that
-supports the ICQ2000, Yahoo!, AIM, and IRC protocols. It allows you
+supports the ICQ2000, Yahoo!, MSN, AIM, and IRC protocols. It allows you
to send, receive, and forward messages, URLs, SMSes, contacts, and email
express messages. It also lets you set your own and fetch others' away
messages, and define external handlers for incoming events. You can
@@ -11,6 +11,4 @@ inactivity, and have your own ignore, visible, and invisible lists.
It can also associate events with sounds, make log of events, and
allows arrangement of contacts into groups.
-Note: MSN protocol is not supported offcially.
-
WWW: http://konst.org.ua/centericq/
diff --git a/net/centericq/pkg-plist b/net/centericq/pkg-plist
index 4d700e1699bb..3311ec849095 100644
--- a/net/centericq/pkg-plist
+++ b/net/centericq/pkg-plist
@@ -1,6 +1,19 @@
bin/centericq
bin/cicqconv
bin/cicqsync
+include/libicq2000/libicq2000/Client.h
+include/libicq2000/libicq2000/constants.h
+include/libicq2000/libicq2000/ContactList.h
+include/libicq2000/libicq2000/ContactTree.h
+include/libicq2000/libicq2000/Contact.h
+include/libicq2000/libicq2000/events.h
+include/libicq2000/libicq2000/exceptions.h
+include/libicq2000/libicq2000/ref_ptr.h
+include/libicq2000/libicq2000/sigslot.h
+include/libicq2000/libicq2000/time_extra.h
+include/libicq2000/libicq2000/Translator.h
+include/libicq2000/libicq2000/userinfoconstants.h
+include/libicq2000/libicq2000/version.h
%%DATADIR%%/email.wav
%%DATADIR%%/msg.wav
%%DATADIR%%/online.wav
@@ -22,3 +35,5 @@ share/locale/ru/LC_MESSAGES/centericq.mo
share/locale/sv/LC_MESSAGES/centericq.mo
share/locale/uk/LC_MESSAGES/centericq.mo
share/locale/zh_TW.Big5/LC_MESSAGES/centericq.mo
+@dirrm include/libicq2000/libicq2000
+@dirrm include/libicq2000