aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/compiz/Makefile2
-rw-r--r--x11-wm/compiz/files/compiz-manager.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index 32733ed61d2f..a864af054ce9 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -2,7 +2,7 @@
PORTNAME= compiz
PORTVERSION= 0.8.8
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= x11-wm
MASTER_SITES= https://BSDforge.com/projects/source/x11-wm/compiz/
diff --git a/x11-wm/compiz/files/compiz-manager.in b/x11-wm/compiz/files/compiz-manager.in
index 8ed0d4050139..3a4488e303df 100644
--- a/x11-wm/compiz/files/compiz-manager.in
+++ b/x11-wm/compiz/files/compiz-manager.in
@@ -235,7 +235,7 @@ check_nvidia()
# Check if the max texture size is large enough compared to the resolution
check_texture_size()
{
- TEXTURE_LIMIT=$(glxinfo -l | grep GL_MAX_TEXTURE_SIZE | sed 's/.*=[^0-9]//g')
+ TEXTURE_LIMIT=$(glxinfo -l | grep GL_MAX_TEXTURE_SIZE | head -n 1 | sed 's/.*=[^0-9]//g')
RESOLUTION=$(xdpyinfo | grep -i dimensions: | sed 's/[^0-9]*pixels.*(.*).*//' | sed 's/[^0-9x]*//')
VRES=$(echo $RESOLUTION | sed 's/.*x//')
HRES=$(echo $RESOLUTION | sed 's/x.*//')