aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.ocaml.mk24
-rw-r--r--archivers/ocaml-zip/Makefile1
-rw-r--r--devel/cil/Makefile6
-rw-r--r--devel/ocaml-camomile/Makefile5
-rw-r--r--devel/ocaml-equeue/pkg-plist20
-rw-r--r--devel/ruby-langscan/Makefile4
-rw-r--r--lang/mtasc/Makefile2
-rw-r--r--security/sks/pkg-plist1
-rw-r--r--textproc/bibtex2html/Makefile11
-rw-r--r--textproc/ocaml-pxp/Makefile2
-rw-r--r--www/eliom/pkg-plist6
-rw-r--r--www/geneweb/pkg-plist37
-rw-r--r--www/ocsigen/files/patch-Makefile8
-rw-r--r--www/ocsigen/pkg-plist11
14 files changed, 19 insertions, 119 deletions
diff --git a/Mk/bsd.ocaml.mk b/Mk/bsd.ocaml.mk
index 48a849456053..2a5fdbe7dc03 100644
--- a/Mk/bsd.ocaml.mk
+++ b/Mk/bsd.ocaml.mk
@@ -130,7 +130,6 @@ ocaml-findlib:
@${FIND} ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/${DIR}/ -type f -print | ${SED} -e \
's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
. endif
- @${ECHO_CMD} "@dirrmtry ${OCAML_SITELIBDIR}/${DIR}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${OCAMLFIND} remove ${DIR} 2>/dev/null" \
>> ${TMPPLIST}
. endfor
@@ -155,10 +154,8 @@ ocaml-ldconfig:
.if defined(USE_OCAML_WASH)
. if !target(ocaml-wash)
ocaml-wash:
- @${ECHO_CMD} "@dirrmtry ${OCAML_SITELIBDIR}" >> ${TMPPLIST}
# If ld.conf is empty
- @${ECHO_CMD} "@rmtry ${OCAML_LDCONF}" >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrmtry ${OCAML_LIBDIR}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec if [ ! -s %D/${OCAML_LDCONF} ]; then ${RM} -f %D/${OCAML_LDCONF}; fi || true" >> ${TMPPLIST}
. endif
.endif
@@ -177,25 +174,6 @@ ocaml-wash:
@${DO_NADA}
.endif
-#
-# XXX: temporary workaround for non-standard PREFIX
-#
-.if !target(add-plist-post)
-add-plist-post:
-. if (${PREFIX} != ${LOCALBASE} && \
- ${PREFIX} != ${LINUXBASE} && ${PREFIX} != "/usr")
- @${ECHO_CMD} "@dirrmtry ${PREFIX}" >> ${TMPPLIST}
-. else
- @${DO_NADA}
-. endif
-
-# If we are using PORTDOCS macro port cannot delete OCAML_DOCSDIR, so
-# we shoud try to accomodate it
-. if defined(PORTDOCS)
- @${ECHO_CMD} "@dirrmtry ${OCAML_DOCSDIR}" >> ${TMPPLIST}
-. endif
-.endif
-
.endif #!defined(OCAML_include)
.if defined(_POSTMKINCLUDED)
diff --git a/archivers/ocaml-zip/Makefile b/archivers/ocaml-zip/Makefile
index 3cf020afe084..6b3b60617850 100644
--- a/archivers/ocaml-zip/Makefile
+++ b/archivers/ocaml-zip/Makefile
@@ -32,6 +32,5 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/META ${STAGEDIR}${OCAMLFIND_DESTDIR}/${PORTNAME}
@${FIND} ${STAGEDIR}${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm ${OCAML_SITELIBDIR}/${PORTNAME}" >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/devel/cil/Makefile b/devel/cil/Makefile
index 84d118f915a8..accde6764d2e 100644
--- a/devel/cil/Makefile
+++ b/devel/cil/Makefile
@@ -87,9 +87,7 @@ do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${RM} -rf ${WRKSRC}/doc/cilcode.tmp
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-
-# Workaround bsd.ocaml.mk to fix packaging
-add-plist-post:
- @${DO_NADA}
+# Remove orphan dir created by bsd.ocaml.mk
+ -@${RMDIR} -p ${STAGEDIR}${OCAMLFIND_DESTDIR}
.include <bsd.port.mk>
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index 9aeb05368f24..016039643da7 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -26,12 +26,7 @@ EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
post-install:
@${FIND} ${STAGEDIR}${DATADIR} ! -type d | \
${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${DATADIR} -type d | ${SORT} -r | \
- ${SED} 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
@${FIND} ${STAGEDIR}${OCAMLFIND_DESTDIR}/${PORTNAME} ! -type d | \
${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${OCAMLFIND_DESTDIR}/${PORTNAME} -type d | \
- ${SORT} -r | ${SED} 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' \
- >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/devel/ocaml-equeue/pkg-plist b/devel/ocaml-equeue/pkg-plist
index 6608967eb4fa..0d5bbf034df6 100644
--- a/devel/ocaml-equeue/pkg-plist
+++ b/devel/ocaml-equeue/pkg-plist
@@ -30,8 +30,6 @@ lib/ocaml/site-lib/shell/shell_uq.cmi
lib/ocaml/site-lib/shell/shell_uq.mli
lib/ocaml/site-lib/shell/unix_exts.cmi
lib/ocaml/site-lib/shell/unix_exts.mli
-@dirrm lib/ocaml/site-lib/equeue
-@dirrm lib/ocaml/site-lib/shell
@unexec ocamlfind remove equeue 2>/dev/null || true
@unexec ocamlfind remove shell 2>/dev/null || true
%%TCL%%lib/ocaml/site-lib/equeue-tcl/META
@@ -42,7 +40,6 @@ lib/ocaml/site-lib/shell/unix_exts.mli
%%TCL%%lib/ocaml/site-lib/equeue-tcl/equeue_tcl.cmxa
%%TCL%%lib/ocaml/site-lib/equeue-tcl/uq_tcl.cmi
%%TCL%%lib/ocaml/site-lib/equeue-tcl/uq_tcl.mli
-%%TCL%%@dirrm lib/ocaml/site-lib/equeue-tcl
%%TCL%%@unexec ocamlfind remove equeue-tcl 2>/dev/null || true
%%PORTDOCS%%%%DOCSDIR%%/ABOUT-FINDLIB
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
@@ -137,20 +134,3 @@ lib/ocaml/site-lib/shell/unix_exts.mli
%%PORTDOCS%%%%EXAMPLESDIR%%/preliminary/pipe-through-eventdriven.ml
%%PORTDOCS%%%%EXAMPLESDIR%%/simple/Makefile
%%PORTDOCS%%%%EXAMPLESDIR%%/simple/a-and-b.ml
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/simple
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/preliminary
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/multi-threaded
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/filecopy_lablgtk
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/filecopy_labltk
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/filecopy
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/engines
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/users-guide/src
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/users-guide/ps
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/users-guide/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/users-guide
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/refman-shell/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/refman-shell
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/refman-equeue/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/refman-equeue
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/devel/ruby-langscan/Makefile b/devel/ruby-langscan/Makefile
index 4db5e178e91d..49c8fb113271 100644
--- a/devel/ruby-langscan/Makefile
+++ b/devel/ruby-langscan/Makefile
@@ -53,10 +53,6 @@ post-install:
${INSTALL_DATA} ${INSTALL_WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-# Workaround bsd.ocaml.mk to fix packaging
-add-plist-post:
- @${DO_NADA}
-
x-generate-plist:
${ECHO} %%RUBY_SITELIBDIR%%/langscan.rb > pkg-plist.new
${FIND} ${RUBY_SITEARCHLIBDIR}/${PORTNAME} -type f | ${SORT} | ${SED} -e 's,${RUBY_SITEARCHLIBDIR},%%RUBY_SITEARCHLIBDIR%%,' >> pkg-plist.new
diff --git a/lang/mtasc/Makefile b/lang/mtasc/Makefile
index d72eccde6915..259644d0883b 100644
--- a/lang/mtasc/Makefile
+++ b/lang/mtasc/Makefile
@@ -62,5 +62,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/mtasc/doc/*.txt ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/mtasc/doc/HelloWorld.as ${STAGEDIR}${EXAMPLESDIR}
+# Remove orphan dir created by bsd.ocaml.mk
+ -@${RMDIR} -p ${STAGEDIR}${OCAMLFIND_DESTDIR}
.include <bsd.port.mk>
diff --git a/security/sks/pkg-plist b/security/sks/pkg-plist
index 2c9263cdfd79..af34212ef091 100644
--- a/security/sks/pkg-plist
+++ b/security/sks/pkg-plist
@@ -6,4 +6,3 @@ man/man8/sks.8.gz
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/textproc/bibtex2html/Makefile b/textproc/bibtex2html/Makefile
index 76dba24445f7..0a48a0404c91 100644
--- a/textproc/bibtex2html/Makefile
+++ b/textproc/bibtex2html/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bibtex2html
PORTVERSION= 1.98
+PORTREVISION= 1
CATEGORIES= textproc print
MASTER_SITES= http://www.lri.fr/~filliatr/ftp/bibtex2html/
@@ -11,6 +12,7 @@ COMMENT= Tools for searching BibTeX and translating from BibTeX to HTML
BUILD_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml
+USES= perl5
GNU_CONFIGURE= yes
OPTIONS_DEFINE= PDFDOCS
@@ -21,12 +23,13 @@ PDFDOCS_USE= TEX=latex:build
PDFDOCS_BUILD_DEPENDS= hevea:${PORTSDIR}/textproc/hevea
PDFDOCS_INSTALL_TARGET= install install-doc
-PORTDOCS= *
-
PLIST_FILES= bin/aux2bib bin/bib2bib bin/bibtex2html \
man/man1/bibtex2html.1.gz man/man1/bib2bib.1.gz man/man1/aux2bib.1.gz
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPDFDOCS}
+PORTDOCS= *
+.endif
.include <bsd.port.mk>
diff --git a/textproc/ocaml-pxp/Makefile b/textproc/ocaml-pxp/Makefile
index 285d644c0183..09d71157c94d 100644
--- a/textproc/ocaml-pxp/Makefile
+++ b/textproc/ocaml-pxp/Makefile
@@ -38,7 +38,5 @@ post-extract:
post-install:
@${FIND} ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib/pxp* -type f | \
${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib/ -type d -name 'pxp*' | ${SORT} -r | \
- ${SED} 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/www/eliom/pkg-plist b/www/eliom/pkg-plist
index 51f0f21ac971..7b82be0f4bda 100644
--- a/www/eliom/pkg-plist
+++ b/www/eliom/pkg-plist
@@ -16,9 +16,3 @@ share/eliom/destillery/basic/PROJECT_NAME.conf.in
share/eliom/destillery/basic/PROJECT_NAME.eliom
share/eliom/destillery/basic/README
share/eliom/destillery/basic/static!css!PROJECT_NAME.css
-@dirrm share/eliom/destillery/basic
-@dirrm share/eliom/destillery
-@dirrm share/eliom
-@dirrm %%OCAML_SITELIBDIR%%/eliom/syntax
-@dirrm %%OCAML_SITELIBDIR%%/eliom/server
-@dirrm %%OCAML_SITELIBDIR%%/eliom/client
diff --git a/www/geneweb/pkg-plist b/www/geneweb/pkg-plist
index bec43b1ec7c1..8465442bd8d3 100644
--- a/www/geneweb/pkg-plist
+++ b/www/geneweb/pkg-plist
@@ -655,39 +655,4 @@ man/man1/gwu.1.gz
%%DATADIR%%/lang/start.txt
%%DATADIR%%/lang/start_utf8.txt
%%DATADIR%%/lang/version.txt
-@dirrm %%DATADIR%%/distribution/gw/etc/perso_module
-@dirrm %%DATADIR%%/distribution/gw/etc/templ502
-@dirrm %%DATADIR%%/distribution/gw/etc/templa
-@dirrm %%DATADIR%%/distribution/gw/etc/templb
-@dirrm %%DATADIR%%/distribution/gw/etc/templc
-@dirrm %%DATADIR%%/distribution/gw/etc/templd
-@dirrm %%DATADIR%%/distribution/gw/etc/templf
-@dirrm %%DATADIR%%/distribution/gw/etc/templh
-@dirrm %%DATADIR%%/distribution/gw/etc/templm
-@dirrm %%DATADIR%%/distribution/gw/etc/templx
-@dirrm %%DATADIR%%/distribution/gw/etc
-@dirrm %%DATADIR%%/distribution/gw/gwtp_tmp/lang
-@dirrm %%DATADIR%%/distribution/gw/gwtp_tmp
-@dirrm %%DATADIR%%/distribution/gw/images/flags
-@dirrm %%DATADIR%%/distribution/gw/images
-@dirrm %%DATADIR%%/distribution/gw/lang
-@dirrmtry %%DATADIR%%/distribution/gw/old
-@dirrm %%DATADIR%%/distribution/gw/setup/lang
-@dirrm %%DATADIR%%/distribution/gw/setup
-@dirrm %%DATADIR%%/distribution/gw
-@dirrm %%DATADIR%%/distribution
-@dirrm %%DATADIR%%/etc/perso_module
-@dirrm %%DATADIR%%/etc/templ502
-@dirrm %%DATADIR%%/etc/templa
-@dirrm %%DATADIR%%/etc/templb
-@dirrm %%DATADIR%%/etc/templc
-@dirrm %%DATADIR%%/etc/templd
-@dirrm %%DATADIR%%/etc/templf
-@dirrm %%DATADIR%%/etc/templh
-@dirrm %%DATADIR%%/etc/templm
-@dirrm %%DATADIR%%/etc/templx
-@dirrm %%DATADIR%%/etc
-@dirrm %%DATADIR%%/images/flags
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/lang
-@dirrm %%DATADIR%%
+@dir %%DATADIR%%/distribution/gw/old
diff --git a/www/ocsigen/files/patch-Makefile b/www/ocsigen/files/patch-Makefile
index 55d838d5dce7..9e543e8bc775 100644
--- a/www/ocsigen/files/patch-Makefile
+++ b/www/ocsigen/files/patch-Makefile
@@ -54,12 +54,12 @@
- $(INSTALL) -d -m ${INSTALL_MOD_755} ${INSTALL_USER_GROUP} $(TEMPROOT)$(STATICPAGESDIR)
- $(INSTALL) -d -m ${INSTALL_MOD_750} ${INSTALL_USER_GROUP} $(TEMPROOT)$(DATADIR)
- $(INSTALL) -m ${INSTALL_MOD_644} ${INSTALL_USER_GROUP} \
-+ $(BSD_INSTALL_DATA) -d $(TEMPROOT)$(STATICPAGESDIR)
-+ $(BSD_INSTALL_DATA) -d $(TEMPROOT)$(DATADIR)
++ mkdir -p $(TEMPROOT)$(STATICPAGESDIR)
++ mkdir -p $(TEMPROOT)$(DATADIR)
+ $(BSD_INSTALL_DATA) \
local/var/www/*.html $(TEMPROOT)$(STATICPAGESDIR)
- $(INSTALL) -d -m ${INSTALL_MOD_755} ${INSTALL_USER_GROUP} \
-+ $(BSD_INSTALL_DATA) -d \
++ mkdir -p \
$(TEMPROOT)$(STATICPAGESDIR)/ocsigenstuff
- $(INSTALL) -m ${INSTALL_MOD_644} ${INSTALL_USER_GROUP} \
+ $(BSD_INSTALL_DATA) \
@@ -67,7 +67,7 @@
$(TEMPROOT)$(STATICPAGESDIR)/ocsigenstuff
- $(INSTALL) -d -m ${INSTALL_MOD_755} $(TEMPROOT)$(MANDIR)
- $(INSTALL) -m ${INSTALL_MOD_644} src/files/${PROJECTNAME}.1 $(TEMPROOT)$(MANDIR)
-+ $(BSD_INSTALL_MAN) -d $(TEMPROOT)$(MANDIR)
++ mkdir -p $(TEMPROOT)$(MANDIR)
+ $(BSD_INSTALL_MAN) src/files/${PROJECTNAME}.1 $(TEMPROOT)$(MANDIR)
uninstall:
diff --git a/www/ocsigen/pkg-plist b/www/ocsigen/pkg-plist
index a839b797249a..03817637ba63 100644
--- a/www/ocsigen/pkg-plist
+++ b/www/ocsigen/pkg-plist
@@ -1,8 +1,6 @@
bin/ocsigenserver
bin/ocsigenserver.opt
-@unexec if cmp -s %D/etc/ocsigenserver.conf.sample %D/etc/ocsigenserver.conf; then rm -f %D/etc/ocsigenserver.conf; fi
-etc/ocsigenserver.conf.sample
-@exec if [ ! -f %D/etc/ocsigenserver.conf ] ; then cp -p %D/%F %B/ocsigenserver.conf; fi
+@sample etc/ocsigenserver.conf.sample
etc/mime.types
man/man1/ocsigenserver.1.gz
share/ocsigen/www/index.html
@@ -30,9 +28,4 @@ share/ocsigen/www/ocsigenstuff/txt.png
share/ocsigen/www/ocsigenstuff/unknown.png
share/ocsigen/www/ocsigenstuff/video.png
share/ocsigen/www/ocsigenstuff/style.css
-@dirrm %%OCAML_SITELIBDIR%%/ocsigenserver/extensions
-@dirrm share/ocsigen/www/ocsigenstuff
-@dirrm share/ocsigen/www
-@dirrm share/ocsigen
-@dirrmtry var/ocsigen
-@dirrmtry var
+@dir var/ocsigen