aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--java/Makefile1
-rw-r--r--java/classpath/Makefile37
-rw-r--r--java/classpath/distinfo2
-rw-r--r--java/classpath/files/patch-ltmain.sh15
-rw-r--r--java/classpath/pkg-descr5
5 files changed, 60 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index 72933a975d80..bf8e57a3b129 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -9,6 +9,7 @@
SUBDIR += bsh
SUBDIR += bugseeker
SUBDIR += bugseeker-demo
+ SUBDIR += classpath
SUBDIR += collections
SUBDIR += cos
SUBDIR += cryptix-jce
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
new file mode 100644
index 000000000000..53ac3169ba91
--- /dev/null
+++ b/java/classpath/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: classpath
+# Date created: Sep 1, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= classpath
+PORTVERSION= 0.10
+CATEGORIES= java
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A GNU project to create free core class libraries
+
+USE_GNOME= gtk20 libartlgpl2 pkgconfig
+USE_JAVA= yes
+USE_JIKES= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INFO= hacking vmintegration
+PLIST_FILES= lib/security/classpath.security
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.for dir in ${PREFIX}/share/classpath ${PREFIX}/lib/classpath
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/java/classpath/distinfo b/java/classpath/distinfo
new file mode 100644
index 000000000000..6d7db92e42b2
--- /dev/null
+++ b/java/classpath/distinfo
@@ -0,0 +1,2 @@
+MD5 (classpath-0.10.tar.gz) = a59a5040f9c1237dbf27bfc668919943
+SIZE (classpath-0.10.tar.gz) = 6801054
diff --git a/java/classpath/files/patch-ltmain.sh b/java/classpath/files/patch-ltmain.sh
new file mode 100644
index 000000000000..ade64300a950
--- /dev/null
+++ b/java/classpath/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Wed Sep 1 15:46:52 2004
++++ ltmain.sh Wed Sep 1 15:47:02 2004
+@@ -5550,10 +5550,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/java/classpath/pkg-descr b/java/classpath/pkg-descr
new file mode 100644
index 000000000000..35a48e40b9f2
--- /dev/null
+++ b/java/classpath/pkg-descr
@@ -0,0 +1,5 @@
+GNU Classpath, Essential Libraries for Java, is a GNU project to create free
+core class libraries for use with virtual machines and compilers for the java
+programming language.
+
+WWW: http://www.classpath.org/