aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/pdf2djvu/Makefile4
-rw-r--r--converters/pdf2djvu/files/patch-pdf-backend.cc20
-rw-r--r--deskutils/calibre/Makefile2
-rw-r--r--editors/calligra/Makefile2
-rw-r--r--editors/koffice-kde3/Makefile2
-rw-r--r--editors/koffice-kde4/Makefile2
-rw-r--r--editors/texmaker/Makefile3
-rw-r--r--editors/texworks/Makefile2
-rw-r--r--graphics/apvlv/Makefile3
-rw-r--r--graphics/epdfview/Makefile4
-rw-r--r--graphics/inkscape/Makefile4
-rw-r--r--graphics/kdegraphics3/Makefile2
-rw-r--r--graphics/kdegraphics4/Makefile1
-rw-r--r--graphics/osg-devel/Makefile3
-rw-r--r--graphics/osg/Makefile4
-rw-r--r--graphics/pdf2svg/Makefile2
-rw-r--r--graphics/popplerkit/Makefile1
-rw-r--r--graphics/py-poppler/Makefile4
-rw-r--r--graphics/tumbler/Makefile3
-rw-r--r--graphics/zathura/Makefile3
-rw-r--r--print/pdfcube/Makefile2
21 files changed, 50 insertions, 23 deletions
diff --git a/converters/pdf2djvu/Makefile b/converters/pdf2djvu/Makefile
index ce7707060b76..bd2318f50294 100644
--- a/converters/pdf2djvu/Makefile
+++ b/converters/pdf2djvu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pdf2djvu
PORTVERSION= 0.5.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= converters
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFFIX}
@@ -16,7 +16,7 @@ MAINTAINER= darcsis@gmail.com
COMMENT= Pdf2djvu creates DjVu files from PDF files
BUILD_DEPENDS= ${LOCALBASE}/include/pstreams/pstream.h:${PORTSDIR}/devel/pstreams
-LIB_DEPENDS= poppler.5:${PORTSDIR}/graphics/poppler
+LIB_DEPENDS= poppler.6:${PORTSDIR}/graphics/poppler
LIB_DEPENDS+= djvulibre.22:${PORTSDIR}/graphics/djvulibre-nox11
GNU_CONFIGURE= yes
diff --git a/converters/pdf2djvu/files/patch-pdf-backend.cc b/converters/pdf2djvu/files/patch-pdf-backend.cc
new file mode 100644
index 000000000000..9a3ffee1abc2
--- /dev/null
+++ b/converters/pdf2djvu/files/patch-pdf-backend.cc
@@ -0,0 +1,20 @@
+--- pdf-backend.cc.orig 2010-10-31 16:26:02.000000000 +0100
++++ pdf-backend.cc 2010-10-31 16:27:10.000000000 +0100
+@@ -99,7 +99,7 @@
+ return html_color(rgb);
+ }
+
+-static void cmyk_to_rgb(double cmyk[], double rgb[])
++static void cmyk_to_rgb(const double cmyk[], double rgb[])
+ {
+ static pdf::gfx::DeviceCmykColorSpace cmyk_space;
+ pdf::gfx::Color cmyk_cc;
+@@ -124,7 +124,7 @@
+ border_colors.push_back("");
+ return true;
+ }
+- double *values = color->getValues();
++ const double *values = color->getValues();
+ switch (color->getSpace())
+ {
+ case pdf::ant::Color::colorTransparent:
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index c4a75a51e455..82d46be4f0b1 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -7,7 +7,7 @@
PORTNAME= calibre
PORTVERSION= 0.7.23
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 40bc209b6aab..74d13a542de2 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -7,7 +7,7 @@
PORTNAME= koffice
PORTVERSION= ${KOFFICE2_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}-${PORTVERSION}/
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index 1a1623d1441a..f14a5523f602 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= koffice
PORTVERSION= 1.6.3
-PORTREVISION= 13
+PORTREVISION= 14
PORTEPOCH= 2
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 40bc209b6aab..74d13a542de2 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= koffice
PORTVERSION= ${KOFFICE2_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}-${PORTVERSION}/
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 1674e4073f9f..be3817ce598a 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -8,6 +8,7 @@
PORTNAME= texmaker
PORTVERSION= 2.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= editors
MASTER_SITES= http://www.xm1math.net/texmaker/
@@ -15,7 +16,7 @@ MASTER_SITES= http://www.xm1math.net/texmaker/
MAINTAINER= makc@FreeBSD.org
COMMENT= LaTeX Development Environment
-LIB_DEPENDS= poppler.5:${PORTSDIR}/graphics/poppler \
+LIB_DEPENDS= poppler.6:${PORTSDIR}/graphics/poppler \
poppler-qt4.3:${PORTSDIR}/graphics/poppler-qt4
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
dvips:${PORTSDIR}/print/dvipsk-tetex \
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 045726d4c036..c3872da172a4 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -7,7 +7,7 @@
PORTNAME= texworks
PORTVERSION= 0.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
diff --git a/graphics/apvlv/Makefile b/graphics/apvlv/Makefile
index 3f5b3c5ad34e..618fa8080db2 100644
--- a/graphics/apvlv/Makefile
+++ b/graphics/apvlv/Makefile
@@ -7,13 +7,14 @@
PORTNAME= apvlv
PORTVERSION= 0.0.9.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
MAINTAINER= jupengfei@gmail.com
COMMENT= Apvlv is a PDF Viewer Under Linux and its behaviour like Vim
-LIB_DEPENDS= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
index 23adcc24fbdd..9b045241e052 100644
--- a/graphics/epdfview/Makefile
+++ b/graphics/epdfview/Makefile
@@ -7,7 +7,7 @@
PORTNAME= epdfview
PORTVERSION= 0.1.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics print gnome
MASTER_SITES= http://trac.emma-soft.com/epdfview/chrome/site/releases/ \
http://mirror.slitaz.org/sources/packages/e/
@@ -16,7 +16,7 @@ MAINTAINER= sylvio@FreeBSD.org
COMMENT= A lightweight PDF document viewer
BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
-LIB_DEPENDS= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 626ea458818c..5550b764cff9 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -7,7 +7,7 @@
PORTNAME= inkscape
PORTVERSION= 0.47
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics gnome
MASTER_SITES= SF
@@ -51,7 +51,7 @@ CONFIGURE_ARGS+= --without-gnome-vfs
.endif
.if defined(WITH_POPPLER)
-LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
CONFIGURE_ARGS+= --enable-poppler-cairo
.else
CONFIGURE_ARGS+= --enable-poppler-cairo=no
diff --git a/graphics/kdegraphics3/Makefile b/graphics/kdegraphics3/Makefile
index e39fbd35b011..844f0efe3413 100644
--- a/graphics/kdegraphics3/Makefile
+++ b/graphics/kdegraphics3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdegraphics
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index fa3060a31bd4..bf9ab0307129 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kdegraphics
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index aedbd8de606d..78f079ef1dda 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= osg
PORTVERSION= 2.9.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/developer_releases/ \
http://mirror.amdmi3.ru/distfiles/
@@ -196,7 +197,7 @@ PLIST_SUB+= SVG="@comment "
.if defined(WITH_PDF)
FORCE_PC_REQUIRE+=POPPLER
-LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
PLIST_SUB+= PDF=""
.else
FORCE_PC_IGNORE+=POPPLER
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index 7d9967633a0b..8ebc7ec3ecaa 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= osg
PORTVERSION= 2.8.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-${PORTVERSION}/source/ \
http://mirror.amdmi3.ru/distfiles/
@@ -178,7 +178,7 @@ PLIST_SUB+= SVG="@comment "
.if defined(WITH_PDF)
FORCE_PC_REQUIRE+=POPPLER
-LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
PLIST_SUB+= PDF=""
.else
FORCE_PC_IGNORE+=POPPLER
diff --git a/graphics/pdf2svg/Makefile b/graphics/pdf2svg/Makefile
index 106220570e89..8a61049db62a 100644
--- a/graphics/pdf2svg/Makefile
+++ b/graphics/pdf2svg/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pdf2svg
PORTVERSION= 0.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://www.cityinthesky.co.uk/files/
diff --git a/graphics/popplerkit/Makefile b/graphics/popplerkit/Makefile
index 74a1ff9a6de8..4fa92e9571c2 100644
--- a/graphics/popplerkit/Makefile
+++ b/graphics/popplerkit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= popplerkit
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= graphics gnustep
MASTER_SITES= http://download.gna.org/etoile/
DISTNAME= etoile-0.4.1
diff --git a/graphics/py-poppler/Makefile b/graphics/py-poppler/Makefile
index 10996f847f09..098bfe6d6c8b 100644
--- a/graphics/py-poppler/Makefile
+++ b/graphics/py-poppler/Makefile
@@ -7,7 +7,7 @@
PORTNAME= poppler
PORTVERSION= 0.10.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics python
MASTER_SITES= https://launchpad.net/poppler-python/trunk/development/+download/ \
http://launchpadlibrarian.net/30270080/ \
@@ -18,7 +18,7 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= romain@FreeBSD.org
COMMENT= Python bindings for the Poppler PDF rendering library
-LIB_DEPENDS= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
USE_PYTHON= yes
GNU_CONFIGURE= yes
diff --git a/graphics/tumbler/Makefile b/graphics/tumbler/Makefile
index c70c85bdece3..f736245a3942 100644
--- a/graphics/tumbler/Makefile
+++ b/graphics/tumbler/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tumbler
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= graphics xfce
MASTER_SITES= XFCE
MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/0.1
@@ -86,7 +87,7 @@ PLIST_SUB+= FREETYPE="@comment "
.if defined(WITH_POPPLER)
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/poppler-glib.pc:${PORTSDIR}/graphics/poppler-gtk \
poppler-gtk>=0.12.0:${PORTSDIR}/graphics/poppler-gtk
-LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
PLIST_SUB+= POPPLER=""
WITH_PLUGINS= true
.elif defined(WITHOUT_POPPLER)
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index 3518c0338d92..4d275fc31a1b 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -7,13 +7,14 @@
PORTNAME= zathura
PORTVERSION= 0.0.8.1
+PORTREVISION= 1
CATEGORIES= graphics print
MASTER_SITES= http://pwmt.org/attachments/download/10/
MAINTAINER= acieroid@awesom.eu
COMMENT= Customizable lightweight pdf viewer
-LIB_DEPENDS= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk \
+LIB_DEPENDS= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk \
cairo.2:${PORTSDIR}/graphics/cairo
USE_GNOME= glib20 gtk20
diff --git a/print/pdfcube/Makefile b/print/pdfcube/Makefile
index 114613224d09..7bf2f3ea9852 100644
--- a/print/pdfcube/Makefile
+++ b/print/pdfcube/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pdfcube
PORTVERSION= 0.0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= http://code.100allora.it/releases/pdfcube/