aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/ipdbtools/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/sysutils/ipdbtools/Makefile b/sysutils/ipdbtools/Makefile
index 425b52e74efd..350ccc339b44 100644
--- a/sysutils/ipdbtools/Makefile
+++ b/sysutils/ipdbtools/Makefile
@@ -14,11 +14,11 @@ LICENSE= BSD2CLAUSE
BROKEN_aarch64= fails to compile: error: invalid conversion between vector type and integer type
BROKEN_armv6= fails to compile: error: invalid conversion between vector type and integer type
BROKEN_armv7= fails to compile: error: invalid conversion between vector type and integer type
-BROKEN_powerpc64= fails to compile: error: unrecognized command line option -mssse3
-BROKEN_sparc64= fails to compile: error: unrecognized command line option -mssse3
USES= tar:bzip2 compiler:c11
+CFLAGS_amd64= -mssse3
+
PLIST_FILES= bin/ipup \
bin/ipdb \
bin/ipdb-update.sh \
@@ -27,4 +27,9 @@ PLIST_FILES= bin/ipup \
man/man1/ipdb.1.gz \
man/man1/ipdb-update.sh.1.gz
+post-patch:
+ @${REINPLACE_CMD} -e 's|-g0 -Ofast -mssse3|${CFLAGS}|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/tmmintrin\.h/d' ${WRKSRC}/store.c
+
.include <bsd.port.mk>