aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/perl5.mk3
-rw-r--r--databases/p5-RedisDB-Parser/pkg-plist1
-rw-r--r--devel/p5-App-CLI-Extension/pkg-plist1
-rw-r--r--devel/p5-Call-Context/Makefile3
-rw-r--r--devel/p5-Data-Page-NoTotalEntries/pkg-plist1
-rw-r--r--devel/p5-Devel-KYTProf/pkg-plist1
-rw-r--r--devel/p5-JIRA-REST/Makefile3
-rw-r--r--devel/p5-Log-Defer/pkg-plist1
-rw-r--r--devel/p5-Module-Collect/pkg-plist1
-rw-r--r--devel/p5-Mojolicious-Plugin-NYTProf/Makefile3
-rw-r--r--devel/p5-MouseX-AttributeHelpers/pkg-plist1
-rw-r--r--devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in16
-rw-r--r--devel/p5-PerlIO-via-Timeout/pkg-plist1
-rw-r--r--devel/p5-SVN-Hooks/pkg-plist1
-rw-r--r--devel/p5-Symbol-Get/Makefile3
-rw-r--r--devel/p5-Sys-Syscall/pkg-plist1
-rw-r--r--devel/p5-Test-Mini-Unit/pkg-plist1
-rw-r--r--devel/p5-Test-Mini/pkg-plist1
-rw-r--r--devel/p5-Test-MockObject/pkg-plist1
-rw-r--r--devel/p5-X-Tiny/Makefile3
-rw-r--r--finance/p5-Business-Stripe/pkg-plist1
-rw-r--r--graphics/p5-Data-Google-Visualization-DataSource/pkg-plist1
-rw-r--r--math/p5-Math-ProvablePrime/Makefile3
-rw-r--r--net-mgmt/p5-Net-ILO/files/patch-Makefile.PL17
-rw-r--r--net/p5-XML-RPC-Fast/pkg-plist1
-rw-r--r--security/p5-Bytes-Random-Secure-Tiny/Makefile3
-rw-r--r--security/p5-Crypt-Perl/Makefile3
-rw-r--r--security/p5-Protocol-ACME/pkg-plist1
-rw-r--r--textproc/p5-Data-FormValidator/pkg-plist1
-rw-r--r--textproc/p5-HTML-FormatText-WithLinks-AndTables/pkg-plist1
-rw-r--r--textproc/p5-Pod-Readme/pkg-plist1
-rw-r--r--textproc/p5-Text-CSV-Encoded/pkg-plist1
-rw-r--r--www/p5-Amon2-Plugin-LogDispatch/pkg-plist1
-rw-r--r--www/p5-Dancer-Plugin-FlashMessage/Makefile3
-rw-r--r--www/p5-Dancer2-Plugin-Deferred/pkg-plist2
-rw-r--r--www/p5-HTML5-DOM/pkg-plist1
-rw-r--r--www/p5-HTTP-Router/pkg-plist1
-rw-r--r--www/p5-Mojolicious-Plugin-Database/pkg-plist1
-rw-r--r--www/p5-WWW-SourceForge/pkg-plist1
39 files changed, 4 insertions, 87 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index b4ba2d53bb0d..eee14b7befb4 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -305,6 +305,9 @@ fix-perl-things:
# read with perldoc, remove the README.3 files that may be generated.
@[ -d "${STAGEDIR}${SITE_MAN3}" ] && \
${FIND} ${STAGEDIR}${SITE_MAN3} -name '*::README.3' -delete || :
+# Starting at ExtUtils::MakeMaker 7.31_06 and Perl 5.27.1, the base README.pod is
+# no longer installed. So remove any that can be there.
+ @${FIND} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL} -name README.pod -delete || :
. if !target(do-test) && (!empty(USE_PERL5:Mmodbuild*) || !empty(USE_PERL5:Mconfigure))
TEST_TARGET?= test
diff --git a/databases/p5-RedisDB-Parser/pkg-plist b/databases/p5-RedisDB-Parser/pkg-plist
index 64169d75a0b0..d3db3c4656b9 100644
--- a/databases/p5-RedisDB-Parser/pkg-plist
+++ b/databases/p5-RedisDB-Parser/pkg-plist
@@ -7,4 +7,3 @@
%%SITE_ARCH%%/RedisDB/Parser/Error.pm
%%SITE_ARCH%%/RedisDB/Parser/PP.pm
%%SITE_ARCH%%/RedisDB/Parser/XS.pm
-%%SITE_ARCH%%/RedisDB/README.pod
diff --git a/devel/p5-App-CLI-Extension/pkg-plist b/devel/p5-App-CLI-Extension/pkg-plist
index f34a121cbaad..fb76366e91d7 100644
--- a/devel/p5-App-CLI-Extension/pkg-plist
+++ b/devel/p5-App-CLI-Extension/pkg-plist
@@ -6,7 +6,6 @@
%%SITE_PERL%%/App/CLI/Extension/Component/RunCommand.pm
%%SITE_PERL%%/App/CLI/Extension/Component/Stash.pm
%%SITE_PERL%%/App/CLI/Extension/Exception.pm
-%%SITE_PERL%%/App/CLI/README.pod
%%PERL5_MAN3%%/App::CLI::Extension.3.gz
%%PERL5_MAN3%%/App::CLI::Extension::Component::Config.3.gz
%%PERL5_MAN3%%/App::CLI::Extension::Component::ErrorHandler.3.gz
diff --git a/devel/p5-Call-Context/Makefile b/devel/p5-Call-Context/Makefile
index 45bbe70b7290..436c47ea4cd9 100644
--- a/devel/p5-Call-Context/Makefile
+++ b/devel/p5-Call-Context/Makefile
@@ -20,7 +20,4 @@ USE_PERL5= configure
PLIST_FILES= ${SITE_PERL_REL}/Call/Context.pm \
${SITE_MAN3_REL}/Call::Context.3.gz
-pre-install:
- ${RM} ${WRKSRC}/blib/lib/Call/README.pod
-
.include <bsd.port.mk>
diff --git a/devel/p5-Data-Page-NoTotalEntries/pkg-plist b/devel/p5-Data-Page-NoTotalEntries/pkg-plist
index 39cbfc130aac..a88b0864c17e 100644
--- a/devel/p5-Data-Page-NoTotalEntries/pkg-plist
+++ b/devel/p5-Data-Page-NoTotalEntries/pkg-plist
@@ -1,3 +1,2 @@
%%SITE_PERL%%/Data/Page/NoTotalEntries.pm
-%%SITE_PERL%%/Data/Page/README.pod
%%PERL5_MAN3%%/Data::Page::NoTotalEntries.3.gz
diff --git a/devel/p5-Devel-KYTProf/pkg-plist b/devel/p5-Devel-KYTProf/pkg-plist
index a31f4e8223a4..482db7c1c39c 100644
--- a/devel/p5-Devel-KYTProf/pkg-plist
+++ b/devel/p5-Devel-KYTProf/pkg-plist
@@ -1,6 +1,5 @@
%%SITE_PERL%%/Devel/KYTProf.pm
%%SITE_PERL%%/Devel/KYTProf/Logger/LTSV.pm
%%SITE_PERL%%/Devel/KYTProf/Logger/LTSV.pod
-%%SITE_PERL%%/Devel/README.pod
%%PERL5_MAN3%%/Devel::KYTProf.3.gz
%%PERL5_MAN3%%/Devel::KYTProf::Logger::LTSV.3.gz
diff --git a/devel/p5-JIRA-REST/Makefile b/devel/p5-JIRA-REST/Makefile
index 92ae05254b6b..a2d57482c9ff 100644
--- a/devel/p5-JIRA-REST/Makefile
+++ b/devel/p5-JIRA-REST/Makefile
@@ -26,8 +26,7 @@ USES= perl5
USE_PERL5= configure
NO_ARCH= yes
-PLIST_FILES= %%SITE_PERL%%/JIRA/README.pod \
- %%SITE_PERL%%/JIRA/REST.pm \
+PLIST_FILES= %%SITE_PERL%%/JIRA/REST.pm \
%%PERL5_MAN3%%/JIRA::REST.3.gz
.include <bsd.port.mk>
diff --git a/devel/p5-Log-Defer/pkg-plist b/devel/p5-Log-Defer/pkg-plist
index ef1091ddfda8..7c14c4a3f2f4 100644
--- a/devel/p5-Log-Defer/pkg-plist
+++ b/devel/p5-Log-Defer/pkg-plist
@@ -1,3 +1,2 @@
%%PERL5_MAN3%%/Log::Defer.3.gz
%%SITE_PERL%%/Log/Defer.pm
-%%SITE_PERL%%/Log/README.pod
diff --git a/devel/p5-Module-Collect/pkg-plist b/devel/p5-Module-Collect/pkg-plist
index 9d54cd9aa905..bc54ef7b2bb6 100644
--- a/devel/p5-Module-Collect/pkg-plist
+++ b/devel/p5-Module-Collect/pkg-plist
@@ -1,5 +1,4 @@
%%SITE_PERL%%/Module/Collect/Package.pm
%%SITE_PERL%%/Module/Collect.pm
-%%SITE_PERL%%/Module/README.pod
%%PERL5_MAN3%%/Module::Collect.3.gz
%%PERL5_MAN3%%/Module::Collect::Package.3.gz
diff --git a/devel/p5-Mojolicious-Plugin-NYTProf/Makefile b/devel/p5-Mojolicious-Plugin-NYTProf/Makefile
index 1d37bd5b3ecc..6a50c7664e81 100644
--- a/devel/p5-Mojolicious-Plugin-NYTProf/Makefile
+++ b/devel/p5-Mojolicious-Plugin-NYTProf/Makefile
@@ -24,7 +24,4 @@ USES= perl5
USE_PERL5= configure
NO_ARCH= yes
-post-patch:
- @${RM} ${WRKSRC}/README.pod
-
.include <bsd.port.mk>
diff --git a/devel/p5-MouseX-AttributeHelpers/pkg-plist b/devel/p5-MouseX-AttributeHelpers/pkg-plist
index e6a0a91dc66d..2ff0ecff8bf8 100644
--- a/devel/p5-MouseX-AttributeHelpers/pkg-plist
+++ b/devel/p5-MouseX-AttributeHelpers/pkg-plist
@@ -9,7 +9,6 @@
%%SITE_PERL%%/MouseX/AttributeHelpers/Counter.pm
%%SITE_PERL%%/MouseX/AttributeHelpers/Number.pm
%%SITE_PERL%%/MouseX/AttributeHelpers/String.pm
-%%SITE_PERL%%/MouseX/README.pod
%%PERL5_MAN3%%/MouseX::AttributeHelpers.3.gz
%%PERL5_MAN3%%/MouseX::AttributeHelpers::Base.3.gz
%%PERL5_MAN3%%/MouseX::AttributeHelpers::Bool.3.gz
diff --git a/devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in b/devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in
deleted file mode 100644
index 443861cf9f7b..000000000000
--- a/devel/p5-POE-Component-Hailo/files/patch-Makefile.PL.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.PL.new 2011-07-29 07:05:19.000000000 -0700
-+++ Makefile.PL 2011-07-29 07:06:44.000000000 -0700
-@@ -48,5 +48,12 @@
-
- WriteMakefile(%WriteMakefileArgs);
-
-+package MY;
-
--
-+sub init_PM {
-+ my $self = shift;
-+ $self->SUPER::init_PM(@_);
-+ # Do not install the README and README.pod
-+ delete $self->{PM}{"README.pod"};
-+ delete $self->{PM}{"README"};
-+}
diff --git a/devel/p5-PerlIO-via-Timeout/pkg-plist b/devel/p5-PerlIO-via-Timeout/pkg-plist
index e0db28d715dc..d5330bd54194 100644
--- a/devel/p5-PerlIO-via-Timeout/pkg-plist
+++ b/devel/p5-PerlIO-via-Timeout/pkg-plist
@@ -1,3 +1,2 @@
-%%SITE_PERL%%/PerlIO/via/README.pod
%%SITE_PERL%%/PerlIO/via/Timeout.pm
%%PERL5_MAN3%%/PerlIO::via::Timeout.3.gz
diff --git a/devel/p5-SVN-Hooks/pkg-plist b/devel/p5-SVN-Hooks/pkg-plist
index 2999e05902bb..65fb768a47dc 100644
--- a/devel/p5-SVN-Hooks/pkg-plist
+++ b/devel/p5-SVN-Hooks/pkg-plist
@@ -13,7 +13,6 @@
%%SITE_PERL%%/SVN/Hooks/Mailer.pm
%%SITE_PERL%%/SVN/Hooks/Notify.pm
%%SITE_PERL%%/SVN/Hooks/UpdateConfFile.pm
-%%SITE_PERL%%/SVN/README.pod
%%PERL5_MAN3%%/SVN::Hooks.3.gz
%%PERL5_MAN3%%/SVN::Hooks::AllowLogChange.3.gz
%%PERL5_MAN3%%/SVN::Hooks::AllowPropChange.3.gz
diff --git a/devel/p5-Symbol-Get/Makefile b/devel/p5-Symbol-Get/Makefile
index fcb85d7f5169..dfb0b5a4b86d 100644
--- a/devel/p5-Symbol-Get/Makefile
+++ b/devel/p5-Symbol-Get/Makefile
@@ -18,7 +18,4 @@ USE_PERL5= configure
PLIST_FILES= ${SITE_PERL_REL}/Symbol/Get.pm \
${SITE_MAN3_REL}/Symbol::Get.3.gz
-pre-install:
- ${RM} ${WRKSRC}/blib/lib/Symbol/README.pod
-
.include <bsd.port.mk>
diff --git a/devel/p5-Sys-Syscall/pkg-plist b/devel/p5-Sys-Syscall/pkg-plist
index 9cdade245cf9..0a9abf6ac574 100644
--- a/devel/p5-Sys-Syscall/pkg-plist
+++ b/devel/p5-Sys-Syscall/pkg-plist
@@ -1,3 +1,2 @@
%%PERL5_MAN3%%/Sys::Syscall.3.gz
-%%SITE_PERL%%/Sys/README.pod
%%SITE_PERL%%/Sys/Syscall.pm
diff --git a/devel/p5-Test-Mini-Unit/pkg-plist b/devel/p5-Test-Mini-Unit/pkg-plist
index 029a778f2643..a58b8d002a27 100644
--- a/devel/p5-Test-Mini-Unit/pkg-plist
+++ b/devel/p5-Test-Mini-Unit/pkg-plist
@@ -1,4 +1,3 @@
-%%SITE_PERL%%/Test/Mini/README.pod
%%SITE_PERL%%/Test/Mini/Unit.pm
%%SITE_PERL%%/Test/Mini/Unit.pod
%%SITE_PERL%%/Test/Mini/Unit/SharedBehavior.pm
diff --git a/devel/p5-Test-Mini/pkg-plist b/devel/p5-Test-Mini/pkg-plist
index 46d49242eb3b..097fb189d6c4 100644
--- a/devel/p5-Test-Mini/pkg-plist
+++ b/devel/p5-Test-Mini/pkg-plist
@@ -10,7 +10,6 @@
%%SITE_PERL%%/Test/Mini/Runner.pod
%%SITE_PERL%%/Test/Mini/TestCase.pm
%%SITE_PERL%%/Test/Mini/TestCase.pod
-%%SITE_PERL%%/Test/README.pod
%%PERL5_MAN3%%/Test::Mini.3.gz
%%PERL5_MAN3%%/Test::Mini::Assertions.3.gz
%%PERL5_MAN3%%/Test::Mini::Logger.3.gz
diff --git a/devel/p5-Test-MockObject/pkg-plist b/devel/p5-Test-MockObject/pkg-plist
index f01566c376ee..984e4ab1fb2c 100644
--- a/devel/p5-Test-MockObject/pkg-plist
+++ b/devel/p5-Test-MockObject/pkg-plist
@@ -2,4 +2,3 @@
%%PERL5_MAN3%%/Test::MockObject::Extends.3.gz
%%SITE_PERL%%/Test/MockObject.pm
%%SITE_PERL%%/Test/MockObject/Extends.pm
-%%SITE_PERL%%/Test/README.pod
diff --git a/devel/p5-X-Tiny/Makefile b/devel/p5-X-Tiny/Makefile
index fdde58fa88f7..efc83a99ac95 100644
--- a/devel/p5-X-Tiny/Makefile
+++ b/devel/p5-X-Tiny/Makefile
@@ -20,7 +20,4 @@ PLIST_FILES= ${SITE_PERL_REL}/X/Tiny.pm \
${SITE_MAN3_REL}/X::Tiny.3.gz \
${SITE_MAN3_REL}/X::Tiny::Base.3.gz
-pre-install:
- ${RM} ${WRKSRC}/blib/lib/X/README.pod
-
.include <bsd.port.mk>
diff --git a/finance/p5-Business-Stripe/pkg-plist b/finance/p5-Business-Stripe/pkg-plist
index 5952d95d3718..0f22ec45272b 100644
--- a/finance/p5-Business-Stripe/pkg-plist
+++ b/finance/p5-Business-Stripe/pkg-plist
@@ -1,3 +1,2 @@
-%%SITE_PERL%%/Business/README.pod
%%SITE_PERL%%/Business/Stripe.pm
%%PERL5_MAN3%%/Business::Stripe.3.gz
diff --git a/graphics/p5-Data-Google-Visualization-DataSource/pkg-plist b/graphics/p5-Data-Google-Visualization-DataSource/pkg-plist
index fadd468d24a0..48b6f561e8da 100644
--- a/graphics/p5-Data-Google-Visualization-DataSource/pkg-plist
+++ b/graphics/p5-Data-Google-Visualization-DataSource/pkg-plist
@@ -1,3 +1,2 @@
%%SITE_PERL%%/Data/Google/Visualization/DataSource.pm
-%%SITE_PERL%%/Data/Google/Visualization/README.pod
%%PERL5_MAN3%%/Data::Google::Visualization::DataSource.3.gz
diff --git a/math/p5-Math-ProvablePrime/Makefile b/math/p5-Math-ProvablePrime/Makefile
index 67b4523bc888..17e5ceee3fa1 100644
--- a/math/p5-Math-ProvablePrime/Makefile
+++ b/math/p5-Math-ProvablePrime/Makefile
@@ -19,7 +19,4 @@ PLIST_FILES= ${SITE_PERL_REL}/Math/ProvablePrime.pm \
${SITE_PERL_REL}/Math/ProvablePrime/Rand.pm \
${SITE_MAN3_REL}/Math::ProvablePrime.3.gz
-pre-install:
- ${RM} ${WRKSRC}/blib/lib/Math/README.pod
-
.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Net-ILO/files/patch-Makefile.PL b/net-mgmt/p5-Net-ILO/files/patch-Makefile.PL
deleted file mode 100644
index abab84bff774..000000000000
--- a/net-mgmt/p5-Net-ILO/files/patch-Makefile.PL
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.PL.orig 2012-04-06 04:48:50.000000000 -0400
-+++ Makefile.PL 2012-04-06 04:51:58.000000000 -0400
-@@ -16,3 +16,14 @@
- dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
- clean => { FILES => 'Net-ILO-*' },
- );
-+
-+package MY;
-+
-+sub init_PM {
-+ my $self = shift;
-+
-+ $self->SUPER::init_PM(@_);
-+
-+ # Do not install README.pod
-+ delete $self->{PM}{"README.pod"};
-+}
diff --git a/net/p5-XML-RPC-Fast/pkg-plist b/net/p5-XML-RPC-Fast/pkg-plist
index d6fb8cb6c6c3..a9e6e6a5c12b 100644
--- a/net/p5-XML-RPC-Fast/pkg-plist
+++ b/net/p5-XML-RPC-Fast/pkg-plist
@@ -6,7 +6,6 @@
%%SITE_PERL%%/XML/RPC/UA/AnyEvent.pm
%%SITE_PERL%%/XML/RPC/UA/AnyEventSync.pm
%%SITE_PERL%%/XML/RPC/Fast.pm
-%%SITE_PERL%%/XML/RPC/README.pod
%%PERL5_MAN3%%/XML::RPC::Enc.3.gz
%%PERL5_MAN3%%/XML::RPC::Enc::LibXML.3.gz
%%PERL5_MAN3%%/XML::RPC::Fast.3.gz
diff --git a/security/p5-Bytes-Random-Secure-Tiny/Makefile b/security/p5-Bytes-Random-Secure-Tiny/Makefile
index 8907b15a5769..1a7c81a03146 100644
--- a/security/p5-Bytes-Random-Secure-Tiny/Makefile
+++ b/security/p5-Bytes-Random-Secure-Tiny/Makefile
@@ -18,7 +18,4 @@ PLIST_FILES= ${SITE_PERL_REL}/Bytes/Random/Secure/Tiny.pm \
${SITE_PERL_REL}/Bytes/Random/Secure/Tiny.pod \
${SITE_MAN3_REL}/Bytes::Random::Secure::Tiny.3.gz
-pre-install:
- ${RM} ${WRKSRC}/blib/lib/Bytes/Random/Secure/README.pod
-
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Perl/Makefile b/security/p5-Crypt-Perl/Makefile
index 3f05d4778c55..60b9a08e191b 100644
--- a/security/p5-Crypt-Perl/Makefile
+++ b/security/p5-Crypt-Perl/Makefile
@@ -30,7 +30,4 @@ BUILD_DEPENDS= p5-Test-Class>=0.4:devel/p5-Test-Class \
USES= perl5
USE_PERL5= configure
-pre-install:
- ${RM} ${WRKSRC}/blib/lib/Crypt/README.pod
-
.include <bsd.port.mk>
diff --git a/security/p5-Protocol-ACME/pkg-plist b/security/p5-Protocol-ACME/pkg-plist
index d76849de261f..447bcd5a32a9 100644
--- a/security/p5-Protocol-ACME/pkg-plist
+++ b/security/p5-Protocol-ACME/pkg-plist
@@ -8,7 +8,6 @@
%%SITE_PERL%%/Protocol/ACME/Logger.pm
%%SITE_PERL%%/Protocol/ACME/OpenSSL.pm
%%SITE_PERL%%/Protocol/ACME/Utils.pm
-%%SITE_PERL%%/Protocol/README.pod
%%PERL5_MAN3%%/Protocol::ACME.3.gz
%%PERL5_MAN3%%/Protocol::ACME::Challenge.3.gz
%%PERL5_MAN3%%/Protocol::ACME::Challenge::LocalFile.3.gz
diff --git a/textproc/p5-Data-FormValidator/pkg-plist b/textproc/p5-Data-FormValidator/pkg-plist
index 1c7268d34d55..b441dc472318 100644
--- a/textproc/p5-Data-FormValidator/pkg-plist
+++ b/textproc/p5-Data-FormValidator/pkg-plist
@@ -5,7 +5,6 @@
%%SITE_PERL%%/Data/FormValidator/ConstraintsFactory.pm
%%SITE_PERL%%/Data/FormValidator/Filters.pm
%%SITE_PERL%%/Data/FormValidator/Results.pm
-%%SITE_PERL%%/Data/README.pod
%%PERL5_MAN3%%/Data::FormValidator.3.gz
%%PERL5_MAN3%%/Data::FormValidator::Constraints.3.gz
%%PERL5_MAN3%%/Data::FormValidator::Constraints::Dates.3.gz
diff --git a/textproc/p5-HTML-FormatText-WithLinks-AndTables/pkg-plist b/textproc/p5-HTML-FormatText-WithLinks-AndTables/pkg-plist
index 1a5289f9109d..8735477db9e3 100644
--- a/textproc/p5-HTML-FormatText-WithLinks-AndTables/pkg-plist
+++ b/textproc/p5-HTML-FormatText-WithLinks-AndTables/pkg-plist
@@ -1,3 +1,2 @@
%%SITE_PERL%%/HTML/FormatText/WithLinks/AndTables.pm
-%%SITE_PERL%%/HTML/FormatText/WithLinks/README.pod
%%PERL5_MAN3%%/HTML::FormatText::WithLinks::AndTables.3.gz
diff --git a/textproc/p5-Pod-Readme/pkg-plist b/textproc/p5-Pod-Readme/pkg-plist
index 7d5215a09fb3..3c327d8ff06f 100644
--- a/textproc/p5-Pod-Readme/pkg-plist
+++ b/textproc/p5-Pod-Readme/pkg-plist
@@ -1,5 +1,4 @@
bin/pod2readme
-%%SITE_PERL%%/Pod/README.pod
%%SITE_PERL%%/Pod/Readme.pm
%%SITE_PERL%%/Pod/Readme/Filter.pm
%%SITE_PERL%%/Pod/Readme/Plugin.pm
diff --git a/textproc/p5-Text-CSV-Encoded/pkg-plist b/textproc/p5-Text-CSV-Encoded/pkg-plist
index 90f94d308f28..21f56c54b354 100644
--- a/textproc/p5-Text-CSV-Encoded/pkg-plist
+++ b/textproc/p5-Text-CSV-Encoded/pkg-plist
@@ -2,7 +2,6 @@
%%SITE_PERL%%/Text/CSV/Encoded/Coder/Base.pm
%%SITE_PERL%%/Text/CSV/Encoded/Coder/Encode.pm
%%SITE_PERL%%/Text/CSV/Encoded/Coder/EncodeGuess.pm
-%%SITE_PERL%%/Text/CSV/README.pod
%%PERL5_MAN3%%/Text::CSV::Encoded.3.gz
%%PERL5_MAN3%%/Text::CSV::Encoded::Coder::Base.3.gz
%%PERL5_MAN3%%/Text::CSV::Encoded::Coder::Encode.3.gz
diff --git a/www/p5-Amon2-Plugin-LogDispatch/pkg-plist b/www/p5-Amon2-Plugin-LogDispatch/pkg-plist
index 5c0913d63dec..4b4ebfe1fa39 100644
--- a/www/p5-Amon2-Plugin-LogDispatch/pkg-plist
+++ b/www/p5-Amon2-Plugin-LogDispatch/pkg-plist
@@ -1,3 +1,2 @@
%%SITE_PERL%%/Amon2/Plugin/LogDispatch.pm
-%%SITE_PERL%%/Amon2/Plugin/README.pod
%%PERL5_MAN3%%/Amon2::Plugin::LogDispatch.3.gz
diff --git a/www/p5-Dancer-Plugin-FlashMessage/Makefile b/www/p5-Dancer-Plugin-FlashMessage/Makefile
index a4662d977cd4..3d293588835b 100644
--- a/www/p5-Dancer-Plugin-FlashMessage/Makefile
+++ b/www/p5-Dancer-Plugin-FlashMessage/Makefile
@@ -19,7 +19,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-post-patch:
- @${RM} ${WRKSRC}/README.pod
-
.include <bsd.port.mk>
diff --git a/www/p5-Dancer2-Plugin-Deferred/pkg-plist b/www/p5-Dancer2-Plugin-Deferred/pkg-plist
index 0dfdc3374924..d7935ae1bd46 100644
--- a/www/p5-Dancer2-Plugin-Deferred/pkg-plist
+++ b/www/p5-Dancer2-Plugin-Deferred/pkg-plist
@@ -1,4 +1,2 @@
%%SITE_PERL%%/Dancer2/Plugin/Deferred.pm
-@comment Don't package these:
-@comment %%SITE_PERL%%/Dancer2/Plugin/README.pod
%%PERL5_MAN3%%/Dancer2::Plugin::Deferred.3.gz
diff --git a/www/p5-HTML5-DOM/pkg-plist b/www/p5-HTML5-DOM/pkg-plist
index 389031f88ee1..f800c8a41b6d 100644
--- a/www/p5-HTML5-DOM/pkg-plist
+++ b/www/p5-HTML5-DOM/pkg-plist
@@ -14,7 +14,6 @@
%%SITE_ARCH%%/HTML5/DOM/Text.pm
%%SITE_ARCH%%/HTML5/DOM/TokenList.pm
%%SITE_ARCH%%/HTML5/DOM/Tree.pm
-%%SITE_ARCH%%/HTML5/README.pod
%%SITE_ARCH%%/HTML5/leaks.pl
%%SITE_ARCH%%/auto/HTML5/DOM/DOM.so
%%PERL5_MAN3%%/HTML5::DOM.3.gz
diff --git a/www/p5-HTTP-Router/pkg-plist b/www/p5-HTTP-Router/pkg-plist
index 87d38b8ff7ea..cfa08a2f42d0 100644
--- a/www/p5-HTTP-Router/pkg-plist
+++ b/www/p5-HTTP-Router/pkg-plist
@@ -1,4 +1,3 @@
-%%SITE_PERL%%/HTTP/README.pod
%%SITE_PERL%%/HTTP/Router/Route.pm
%%SITE_PERL%%/HTTP/Router/Debug.pm
%%SITE_PERL%%/HTTP/Router/Declare.pm
diff --git a/www/p5-Mojolicious-Plugin-Database/pkg-plist b/www/p5-Mojolicious-Plugin-Database/pkg-plist
index cb9aeb241c27..ac97246cfa5a 100644
--- a/www/p5-Mojolicious-Plugin-Database/pkg-plist
+++ b/www/p5-Mojolicious-Plugin-Database/pkg-plist
@@ -1,3 +1,2 @@
%%SITE_PERL%%/Mojolicious/Plugin/Database.pm
-%%SITE_PERL%%/Mojolicious/Plugin/README.pod
%%PERL5_MAN3%%/Mojolicious::Plugin::Database.3.gz
diff --git a/www/p5-WWW-SourceForge/pkg-plist b/www/p5-WWW-SourceForge/pkg-plist
index d1c722ce3ec5..3f14659f1c25 100644
--- a/www/p5-WWW-SourceForge/pkg-plist
+++ b/www/p5-WWW-SourceForge/pkg-plist
@@ -1,4 +1,3 @@
-%%SITE_PERL%%/WWW/README.pod
%%SITE_PERL%%/WWW/SourceForge.pm
%%SITE_PERL%%/WWW/SourceForge/API.pm
%%SITE_PERL%%/WWW/SourceForge/Project.pm