aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-omniauth-oauth2-generic/Makefile24
-rw-r--r--security/rubygem-omniauth-oauth2-generic/distinfo3
-rw-r--r--security/rubygem-omniauth-oauth2-generic/pkg-descr18
4 files changed, 46 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7498c2226aee..3f565514fbd4 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1028,6 +1028,7 @@
SUBDIR += rubygem-omniauth-cas3
SUBDIR += rubygem-omniauth-gitlab
SUBDIR += rubygem-omniauth-multipassword
+ SUBDIR += rubygem-omniauth-oauth2-generic
SUBDIR += rubygem-omniauth-saml
SUBDIR += rubygem-omniauth-shibboleth
SUBDIR += rubygem-openssl-ccm
diff --git a/security/rubygem-omniauth-oauth2-generic/Makefile b/security/rubygem-omniauth-oauth2-generic/Makefile
new file mode 100644
index 000000000000..3f55d6ff7973
--- /dev/null
+++ b/security/rubygem-omniauth-oauth2-generic/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= omniauth-oauth2-generic
+PORTVERSION= 0.2.2
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Generic, Configurable OmniAuth Strategy for OAuth2 providers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.0:net/rubygem-omniauth-oauth2
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/bin/console ${STAGEDIR}${PREFIX}/bin/setup
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-oauth2-generic/distinfo b/security/rubygem-omniauth-oauth2-generic/distinfo
new file mode 100644
index 000000000000..244d14603498
--- /dev/null
+++ b/security/rubygem-omniauth-oauth2-generic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490206997
+SHA256 (rubygem/omniauth-oauth2-generic-0.2.2.gem) = e30814f6c472e04f3d9e4a3ddc03bc9a46f53f9333f8d443bf3ad43c6ebcdbd4
+SIZE (rubygem/omniauth-oauth2-generic-0.2.2.gem) = 9216
diff --git a/security/rubygem-omniauth-oauth2-generic/pkg-descr b/security/rubygem-omniauth-oauth2-generic/pkg-descr
new file mode 100644
index 000000000000..2b5a17430679
--- /dev/null
+++ b/security/rubygem-omniauth-oauth2-generic/pkg-descr
@@ -0,0 +1,18 @@
+omniauth-oauth2-generic provides an OmniAuth strategy for authenticating with an
+OAuth2 service using the authorization grant flow.
+
+Most OmniAuth gems are written either as abstractions (omniauth-oauth2) or for a
+specific provider (omniauth-github), but this one is designed to be configurable
+enough to work with any basic OAuth2 provider. The primary differences between
+OAuth2 provider strategies in OmniAuth are:
+- The server's domain
+- The URL paths used to authorize, request tokens and get user info
+- The structure of the returned user information
+
+These are all configurable options in this gem. There my be certain
+requirements/features of some providers not covered by this gem's options, but
+it was designed primarily so that if you are implementing your own OAuth2
+provider for your service, you don't need to write an OmniAuth strategy as long
+as it is compatible with the basic options provided by this gem.
+
+WWW: https://gitlab.com/satorix/omniauth-oauth2-generic