aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/py-twofish/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/py-twofish/Makefile b/security/py-twofish/Makefile
index 687147d5b3f1..5806eb04d350 100644
--- a/security/py-twofish/Makefile
+++ b/security/py-twofish/Makefile
@@ -20,6 +20,12 @@ COMMENT= Twofish cryptographic module for Python
USE_PYTHON= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-install:
${INSTALL_DATA} ${WRKSRC}/_twofish.so ${PYTHON_SITELIBDIR}
${INSTALL_SCRIPT} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}
@@ -28,4 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>