aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/irchat-pj-emacs21/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/irc/irchat-pj-emacs21/Makefile b/irc/irchat-pj-emacs21/Makefile
index 068803297e86..1728e1b26cba 100644
--- a/irc/irchat-pj-emacs21/Makefile
+++ b/irc/irchat-pj-emacs21/Makefile
@@ -1,15 +1,12 @@
-# New ports collection makefile for: irchat-pj (for emacs20)
-# Date Created: 2 May 2001
-# Whom: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
-#
+# Created by: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
# $FreeBSD$
-#
PORTNAME= irchat-pj
PORTVERSION= 2.5.6
PORTREVISION= 6
CATEGORIES= irc elisp
-MASTER_SITES= http://his.luky.org/ftp/mirrors/irchat-pj/2.5/
+#MASTER_SITES= http://gouketsu.net/irchat-pj/src/2.5/
+MASTER_SITES= http://ftp.dti.ad.jp/pub/unix/net/irc/irchat-pj/2.5/
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}p
@@ -20,10 +17,14 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= IRC client which runs under Emacsen
+LICENSE= GPLv2 # (or later)
+
BUILD_DEPENDS= ${LOCALBASE}/${LISPDIR:S,${PORTNAME},pure,g}/pure-make.el:${PORTSDIR}/irc/pure-${EMACS_PORT_NAME}
RUN_DEPENDS= ${LOCALBASE}/${LISPDIR:S,${PORTNAME},pure,g}/pure-make.el:${PORTSDIR}/irc/pure-${EMACS_PORT_NAME} \
${LOCALBASE}/bin/dcc:${PORTSDIR}/irc/dcc
+OPTIONS_DEFINE= DOCS
+
USE_BZIP2= yes
USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
@@ -43,8 +44,10 @@ PLIST_SUB= LISPDIR=${LISPDIR} \
ETCDIR=${ETCDIR} \
XEMACS_ONLY=${XEMACS_ONLY}
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/${ETCDIR}
.for f in ${DOCS}
${INSTALL_MAN} ${WRKSRC}/${f} ${PREFIX}/${ETCDIR}