aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ffe/Makefile31
-rw-r--r--textproc/ffe/distinfo3
-rw-r--r--textproc/ffe/pkg-descr6
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index de500b05d895..f12720b7aba7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -129,6 +129,7 @@
SUBDIR += ezxml
SUBDIR += fa-aspell
SUBDIR += fdp-tools
+ SUBDIR += ffe
SUBDIR += fi-aspell
SUBDIR += filepp
SUBDIR += fist
diff --git a/textproc/ffe/Makefile b/textproc/ffe/Makefile
new file mode 100644
index 000000000000..7cf6136f74bc
--- /dev/null
+++ b/textproc/ffe/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ffe
+# Date created: 19 September 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ffe
+PORTVERSION= 0.1.6
+CATEGORIES= textproc
+MASTER_SITES= SF/ff-extractor
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Flat file extractor
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${MAN1PREFIX}/man
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+PORTDOCS= ${PORTNAME}.html
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/^install-data-am: install-htmlDATA install-info-am install-man/install-data-am: install-man/' ${WRKSRC}/doc/Makefile.in
+
+post-install:
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ffe/distinfo b/textproc/ffe/distinfo
new file mode 100644
index 000000000000..1ae8ccd2f97e
--- /dev/null
+++ b/textproc/ffe/distinfo
@@ -0,0 +1,3 @@
+MD5 (ffe-0.1.6.tar.gz) = 0cede583a57d3e4d602cda6a3cc9418f
+SHA256 (ffe-0.1.6.tar.gz) = 7c83a0523bab6c5c4077def484659a0fae9a2cfbcfad4dd590c598bb131bdde4
+SIZE (ffe-0.1.6.tar.gz) = 222547
diff --git a/textproc/ffe/pkg-descr b/textproc/ffe/pkg-descr
new file mode 100644
index 000000000000..7b17ecabc6c4
--- /dev/null
+++ b/textproc/ffe/pkg-descr
@@ -0,0 +1,6 @@
+ffe is a program for extracting fields from flat file records and dis-
+playing them in different formats. ffe relies on the configuration file
+to control input file structure and the output format.
+
+WWW: http://sourceforge.net/projects/ff-extractor/
+Author: Timo Savinen <tjsa@iki.fi>