aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/libuta/Makefile2
-rw-r--r--devel/wftk/Makefile2
-rw-r--r--multimedia/xawtv/Makefile5
3 files changed, 5 insertions, 4 deletions
diff --git a/devel/libuta/Makefile b/devel/libuta/Makefile
index 9ed45b0904fc..be97404ea6c5 100644
--- a/devel/libuta/Makefile
+++ b/devel/libuta/Makefile
@@ -22,6 +22,7 @@ USE_LIBTOOL= yes
USE_SDL= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
@@ -40,7 +41,6 @@ WITH_SDL_MIXER= yes
LIB_DEPENDS+= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
.endif
-
pre-everything::
@${ECHO} ""
@${ECHO} "You may use the following build options:"
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
index 9ed45b0904fc..be97404ea6c5 100644
--- a/devel/wftk/Makefile
+++ b/devel/wftk/Makefile
@@ -22,6 +22,7 @@ USE_LIBTOOL= yes
USE_SDL= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
@@ -40,7 +41,6 @@ WITH_SDL_MIXER= yes
LIB_DEPENDS+= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
.endif
-
pre-everything::
@${ECHO} ""
@${ECHO} "You may use the following build options:"
diff --git a/multimedia/xawtv/Makefile b/multimedia/xawtv/Makefile
index a7c7009be702..f0a99827948c 100644
--- a/multimedia/xawtv/Makefile
+++ b/multimedia/xawtv/Makefile
@@ -29,6 +29,7 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
CONFIGURE_ENV= LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
MAKE_ENV= verbose=yes
+INSTALLS_SHLIB= yes
FILES_LIBJPEG= console/Subdir.mk debug/Subdir.mk x11/Subdir.mk
@@ -42,9 +43,9 @@ MAN8= v4l-conf.8
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386
.else
-ONLY_FOR_ARCHS= alpha i386 ia64
+ONLY_FOR_ARCHS= alpha i386 ia64
.endif
.if defined(WITH_LIBDV)