aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/mnoGoSearch-current/Makefile9
-rw-r--r--www/mnogosearch/Makefile9
-rw-r--r--www/mnogosearch31/Makefile9
3 files changed, 24 insertions, 3 deletions
diff --git a/www/mnoGoSearch-current/Makefile b/www/mnoGoSearch-current/Makefile
index 9dd6b063b781..16216957f7d2 100644
--- a/www/mnoGoSearch-current/Makefile
+++ b/www/mnoGoSearch-current/Makefile
@@ -23,10 +23,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-phrase \
--enable-shared \
--enable-freebsd-pthreads \
- --with-openssl \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+.ifndef NO_OPENSSL
+USE_OPENSSL= yes
+.endif
+
+.ifdef USE_OPENSSL
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
# To enable Cyrillic charset guesser, define this
# Guesser mode ignores charsets comes from HTTP header or <META> tag
.if defined(WITH_MNOGO_GUESSER)
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 9dd6b063b781..16216957f7d2 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -23,10 +23,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-phrase \
--enable-shared \
--enable-freebsd-pthreads \
- --with-openssl \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+.ifndef NO_OPENSSL
+USE_OPENSSL= yes
+.endif
+
+.ifdef USE_OPENSSL
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
# To enable Cyrillic charset guesser, define this
# Guesser mode ignores charsets comes from HTTP header or <META> tag
.if defined(WITH_MNOGO_GUESSER)
diff --git a/www/mnogosearch31/Makefile b/www/mnogosearch31/Makefile
index 9dd6b063b781..16216957f7d2 100644
--- a/www/mnogosearch31/Makefile
+++ b/www/mnogosearch31/Makefile
@@ -23,10 +23,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-phrase \
--enable-shared \
--enable-freebsd-pthreads \
- --with-openssl \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+.ifndef NO_OPENSSL
+USE_OPENSSL= yes
+.endif
+
+.ifdef USE_OPENSSL
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
# To enable Cyrillic charset guesser, define this
# Guesser mode ignores charsets comes from HTTP header or <META> tag
.if defined(WITH_MNOGO_GUESSER)