aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/abiword-plugins/Makefile4
-rw-r--r--editors/abiword/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/editors/abiword-plugins/Makefile b/editors/abiword-plugins/Makefile
index 4ae57f4e1e93..84669bbb84c9 100644
--- a/editors/abiword-plugins/Makefile
+++ b/editors/abiword-plugins/Makefile
@@ -37,6 +37,10 @@ MD5_FILE= ${.CURDIR}/../abiword/distinfo
ABIVERSION= 2.2
PLIST_SUB+= ABIVERSION=${ABIVERSION}
+EXCLUDE_EXTRACT= MSVC6 MSVC71 abidistfiles abipbx abiword-docs expat \
+ fribidi libiconv libpng pbx popt wv zlib
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXCLUDE_EXTRACT:S/^/--exclude /}
+
# NOTE: Please, keep those knobs in the ABC's order.
.if defined(WITH_AIKSAURUS) || defined(PACKAGE_BUILDING)
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 02d133ff1613..b4b9f1d34d05 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -41,6 +41,10 @@ CONFIGURE_ARGS= --enable-xft \
--disable-peer-config
MAKEFILE= GNUmakefile
+EXCLUDE_EXTRACT= MSVC6 MSVC71 abipbx abiword-docs abiword-plugins expat \
+ fribidi libiconv libpng pbx popt wv zlib
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXCLUDE_EXTRACT:S/^/--exclude /}
+
ABIVERSION= 2.2
PLIST_SUB+= ABIVERSION=${ABIVERSION}
WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi