aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/cgit/Makefile4
-rw-r--r--devel/cgit/pkg-plist1
2 files changed, 4 insertions, 1 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index 2af9185ff6ee..80ea65fd861c 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cgit
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= devel www
MASTER_SITES= http://hjemli.net/git/cgit/snapshot/:cgit \
http://www.kernel.org/pub/software/scm/git/:git
@@ -38,9 +39,10 @@ post-extract:
@${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
post-install:
- @${MKDIR} /var/cache/${PORTNAME} ${DOCSDIR}
+ @${MKDIR} /var/cache/${PORTNAME}
@${CHOWN} ${WWWOWN}:${WWWGRP} /var/cache/${PORTNAME}
.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}rc.5.txt ${DOCSDIR}/
.endif
diff --git a/devel/cgit/pkg-plist b/devel/cgit/pkg-plist
index 57a478f6bdca..95b2ffa19e2d 100644
--- a/devel/cgit/pkg-plist
+++ b/devel/cgit/pkg-plist
@@ -3,5 +3,6 @@
%%WWWDIR%%/cgit.png
%%PORTDOCS%%%%DOCSDIR%%/cgitrc.5.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%WWWDIR%%
@exec mkdir -p /var/cache/%%PORTNAME%%
@unexec rmdir /var/cache/%%PORTNAME%% 2>/dev/null || true