aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/modd/Makefile23
-rw-r--r--devel/modd/distinfo3
-rw-r--r--devel/modd/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6b96d6e3459f..c3a9e8e22219 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1542,6 +1542,7 @@
SUBDIR += mk-configure
SUBDIR += mm
SUBDIR += mm-common
+ SUBDIR += modd
SUBDIR += mongo-c-driver
SUBDIR += mongo-cxx-driver
SUBDIR += mono-addins
diff --git a/devel/modd/Makefile b/devel/modd/Makefile
new file mode 100644
index 000000000000..9e457962b25c
--- /dev/null
+++ b/devel/modd/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= modd
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.8
+CATEGORIES= devel sysutils
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Developer tool that runs processes and responds to filesystem changes
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+USE_GITHUB= yes
+GH_ACCOUNT= cortesi
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= ${GO_PKGNAME}/cmd/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/modd/distinfo b/devel/modd/distinfo
new file mode 100644
index 000000000000..9b626e9da2a8
--- /dev/null
+++ b/devel/modd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1560573972
+SHA256 (cortesi-modd-v0.8_GH0.tar.gz) = 04e9bacf5a73cddea9455f591700f452d2465001ccc0c8e6f37d27b8b376b6e0
+SIZE (cortesi-modd-v0.8_GH0.tar.gz) = 4984260
diff --git a/devel/modd/pkg-descr b/devel/modd/pkg-descr
new file mode 100644
index 000000000000..71d52356f2a0
--- /dev/null
+++ b/devel/modd/pkg-descr
@@ -0,0 +1,10 @@
+Modd is a developer tool that triggers commands and manages daemons in response
+to filesystem changes.
+
+If you use modd, you should also look at devd, a compact HTTP daemon for
+developers. Devd integrates with modd, allowing you to trigger in-browser
+live-reload with modd.
+
+devd (www/devd) is a sister-project of modd.
+
+WWW: https://github.com/cortesi/modd