aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--net/Makefile1
-rw-r--r--net/mldonkey-src/Makefile83
-rw-r--r--net/mldonkey-src/distinfo1
-rw-r--r--net/mldonkey-src/files/kill_mldonkey23
-rw-r--r--net/mldonkey-src/files/wrapper.sh18
-rw-r--r--net/mldonkey-src/pkg-descr16
-rw-r--r--net/mldonkey-src/pkg-message22
-rw-r--r--net/mldonkey-src/pkg-plist19
9 files changed, 1 insertions, 183 deletions
diff --git a/MOVED b/MOVED
index f81fbe7a9a2e..577eee765edb 100644
--- a/MOVED
+++ b/MOVED
@@ -374,3 +374,4 @@ devel/pear-install|devel/pear-PEAR|2003-06-08|merged
textproc/gnomespell-devel|textproc/gnomespell|2003-06-11|rolled into gnomespell
mail/evolution-devel|mail/evolution|2003-06-11|rolled into evolution
misc/wmessage|x11/wmessage|2003-06-12|accurate category
+net/mldonkey-src|net/mldonkey|2003-06-15|no londer needed
diff --git a/net/Makefile b/net/Makefile
index 52af3e1aaaa8..5452e33da85e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -320,7 +320,6 @@
SUBDIR += mldonkey-gui
SUBDIR += mldonkey-perlreactor
SUBDIR += mldonkey-serverspy
- SUBDIR += mldonkey-src
SUBDIR += mldonkey-urlslave
SUBDIR += mmucl
SUBDIR += mopd
diff --git a/net/mldonkey-src/Makefile b/net/mldonkey-src/Makefile
deleted file mode 100644
index 9a7a84dee0c7..000000000000
--- a/net/mldonkey-src/Makefile
+++ /dev/null
@@ -1,83 +0,0 @@
-# New ports collection makefile for: mldonkey
-# Date created: 18 January 2003
-# Whom: Holger Lamm <holger@e-gitt.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= mldonkey
-PORTVERSION= 2.04.r1
-CATEGORIES= net
-MASTER_SITES= http://savannah.nongnu.org/download/mldonkey/release-${PORTVERSION:S/.r/rc/}/
-PKGNAMESUFFIX= -src
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}.sources
-
-MAINTAINER= holger@e-gitt.net
-COMMENT= A OCAML client for eDonkey and Overnet peer-to-peer networks
-
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-multinet \
- --enable-pthread
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
-ALL_TARGET= depend all
-
-.if defined(WITHOUT_GUI)
-# have no 'without-' flag
-CONFIGURE_ARGS+= --disable-gui
-PLIST_SUB+= GUI="@comment "
-.else
-PLIST_SUB+= GUI=""
-BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
- ${LOCALBASE}/lib/ocaml/jabbr.cma:${PORTSDIR}/net/ocaml-jabbr
-# we don't need lablgtk as RUN dependency, but we need gtk+glib
-USE_GNOME= gtk12
-.endif
-
-DOCFILES= AUTHORS BUGS ChangeLog Developers.txt FAQ.html \
- Readme.txt TODO ed2k_links.txt
-
-pre-everything::
-.if !defined(WITHOUT_GUI)
- @${ECHO_MSG} "You can disable the GUI by defining WITHOUT_GUI."
-.endif
-
-post-patch:
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
- ${WRKDIR}/wrapper.sh
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey ${PREFIX}/bin/mldonkey-real
- @${INSTALL_SCRIPT} ${FILESDIR}/kill_mldonkey ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mldonkey
-.ifndef(WITHOUT_GUI)
- @${INSTALL_SCRIPT} ${WRKSRC}/distrib/mldonkey_previewer ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_guistarter ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui2 ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey+gui ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mlchat ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mlim ${PREFIX}/bin
-.endif
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${DOCFILES}
- @${INSTALL_DATA} ${WRKSRC}/distrib/${file} ${DOCSDIR}
-.endfor
-.endif
-
-post-install:
- @${FMT} < ${PKGMESSAGE}
-
-install-user: extract
-.if !defined(LANG)
- @${ECHO_MSG} "Please call as: make install-user LANG=<lang>"
- @${ECHO_MSG} "with <lang> one of en,de,fr,fr.noaccents,sp !"
-.else
- @${CP} ${WRKSRC}/distrib/i18n/gui_messages.ini.${LANG}\
- ${HOME}/.mldonkey_gui_messages.ini
-.endif
-
-.include <bsd.port.mk>
diff --git a/net/mldonkey-src/distinfo b/net/mldonkey-src/distinfo
deleted file mode 100644
index da6a2d346f9d..000000000000
--- a/net/mldonkey-src/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (mldonkey-2.04rc1.sources.tar.gz) = ea7a2320fd7d89c994de5a098e0e119a
diff --git a/net/mldonkey-src/files/kill_mldonkey b/net/mldonkey-src/files/kill_mldonkey
deleted file mode 100644
index 2c4f923c3516..000000000000
--- a/net/mldonkey-src/files/kill_mldonkey
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-
-#
-# Add Username and password here
-# like this:
-#
-HTTPUSER="you"
-HTTPPASS="yourpassword"
-
-# Add location and port of mldonkey core
-HTTPURL="127.0.0.1:4080"
-
-# internal configuration
-HTTP_COMMAND="/usr/bin/fetch"
-HTTP_COMMAND_ARGS="-1 -q -s"
-
-if [ -n "${HTTPUSER} -a -n "${HTTPPASS}" ]
-then
- export HTTP_AUTH=basic:*:${HTTPUSER}:${HTTPPASS}
-fi
-
-${HTTP_COMMAND} ${HTTP_COMMAND_ARGS} "http://${HTTPURL}/submit?q=kill"
-
diff --git a/net/mldonkey-src/files/wrapper.sh b/net/mldonkey-src/files/wrapper.sh
deleted file mode 100644
index c25fd62bc133..000000000000
--- a/net/mldonkey-src/files/wrapper.sh
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-PREFIX="%%PREFIX%%/bin"
-PROGRAM="${0}"
-DIRNAME=${HOME}/.mldonkey
-
-if [ ! -d ${DIRNAME} ]
-then
- mkdir -p ${DIRNAME}
-fi
-
-echo " ${*} " | grep " \-createdironly " ||
-{
- cd ${DIRNAME} &&
- echo Running under ${DIRNAME} &&
- exec ${PREFIX}/${PROGRAM##*/}-real "${@}" ||
- echo PROBLEM. Cannot create directory ${DIRNAME}, make sure you have the proper permissions to create it and try again
-}
diff --git a/net/mldonkey-src/pkg-descr b/net/mldonkey-src/pkg-descr
deleted file mode 100644
index 30534114f3cd..000000000000
--- a/net/mldonkey-src/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-mldonkey is a OCAML/GTK client for both eDonkey and Overnet
-peer-to-peer networks.
-(see http://www.edonkey2000.com/ and the 'edonkey' ports)
-(see http://www.overnet.com/)
-
-It is separated into a core with telnet and web interfaces, and
-a GTK GUI. This port will build it from sources.
-
-Other features over the original eDonkey client are:
-- better stability
-- faster operation
-- much better control
-- saves its current state, checksums and known peers
- (instead of starting from scratch every time)
-
-WWW: http://www.freesoftware.fsf.org/mldonkey/
diff --git a/net/mldonkey-src/pkg-message b/net/mldonkey-src/pkg-message
deleted file mode 100644
index 24cf886c0572..000000000000
--- a/net/mldonkey-src/pkg-message
+++ /dev/null
@@ -1,22 +0,0 @@
- ATTENTIONATTENTION:
-
-- If you want to know how to use mldonkey, read "Readme.txt" or
- "FAQ.html" in the port docs (/usr/local/share/doc/mldonkey)
-
-- It is not a bad idea to install mplayer. You will be able
- to preview half-downloaded files (if you have the beginning).
-
-- Please make sure that you read
- /usr/local/share/doc/mldonkey/Readme.txt.
- It contains important information about how to run mldonkey.
-
-- You can import the downloads you started with eDonkey
- (try "import /home/directory/path/.edonkey2000-core"
- on the console), but you can NOT go back!
-
-- If this is the first time you install mldonkey,
- please go to the mldonkey-gui ports dir as a user and enter:
-
- make install-user
-
- this will set up your user config.
diff --git a/net/mldonkey-src/pkg-plist b/net/mldonkey-src/pkg-plist
deleted file mode 100644
index 1e5026a7f90d..000000000000
--- a/net/mldonkey-src/pkg-plist
+++ /dev/null
@@ -1,19 +0,0 @@
-bin/kill_mldonkey
-bin/mldonkey
-bin/mldonkey-real
-%%GUI%%bin/mldonkey_guistarter
-%%GUI%%bin/mldonkey_previewer
-%%GUI%%bin/mlchat
-%%GUI%%bin/mldonkey+gui
-%%GUI%%bin/mldonkey_gui
-%%GUI%%bin/mldonkey_gui2
-%%GUI%%bin/mlim
-%%PORTDOCS%%share/doc/mldonkey/AUTHORS
-%%PORTDOCS%%share/doc/mldonkey/BUGS
-%%PORTDOCS%%share/doc/mldonkey/ChangeLog
-%%PORTDOCS%%share/doc/mldonkey/Developers.txt
-%%PORTDOCS%%share/doc/mldonkey/FAQ.html
-%%PORTDOCS%%share/doc/mldonkey/Readme.txt
-%%PORTDOCS%%share/doc/mldonkey/TODO
-%%PORTDOCS%%share/doc/mldonkey/ed2k_links.txt
-%%PORTDOCS%%@dirrm share/doc/mldonkey