aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/autoreconf.mk4
-rw-r--r--Mk/Uses/libtool.mk2
-rw-r--r--Mk/bsd.autotools.mk4
-rw-r--r--databases/libmemcached/Makefile4
-rw-r--r--databases/libmemcached/files/patch-configure.ac19
-rw-r--r--devel/automake/Makefile15
-rw-r--r--devel/automake/distinfo4
-rw-r--r--devel/automake/pkg-descr2
-rw-r--r--devel/automake/pkg-plist9
-rw-r--r--devel/autotools/Makefile2
-rw-r--r--devel/gettext-runtime/pkg-plist2
-rw-r--r--devel/gettext-tools/pkg-plist6
-rw-r--r--devel/gettext/Makefile.common2
-rw-r--r--devel/gettext/distinfo4
-rw-r--r--devel/git-merge-changelog/Makefile2
-rw-r--r--devel/libltdl/pkg-descr2
-rw-r--r--devel/libtool/Makefile4
-rw-r--r--devel/libtool/Makefile.common4
-rw-r--r--devel/libtool/distinfo4
-rw-r--r--devel/libtool/files/patch-build-aux_ltmain.sh30
-rw-r--r--devel/libtool/files/patch-configure42
-rw-r--r--devel/libtool/files/patch-libtoolize.in34
-rw-r--r--devel/libtool/files/patch-m4_libtool.m412
-rw-r--r--devel/libtool/pkg-descr2
-rw-r--r--devel/libtool/pkg-plist6
-rw-r--r--devel/xfce4-dev-tools/Makefile5
-rw-r--r--security/sssd/files/patch-configure.ac21
27 files changed, 85 insertions, 162 deletions
diff --git a/Mk/Uses/autoreconf.mk b/Mk/Uses/autoreconf.mk
index fb4a29f296d1..fdadef8c1f79 100644
--- a/Mk/Uses/autoreconf.mk
+++ b/Mk/Uses/autoreconf.mk
@@ -57,8 +57,8 @@ _USES_POST+= autoreconf
BUILD_DEPENDS+= autoconf-2.69:${PORTSDIR}/devel/autoconf \
autoheader-2.69:${PORTSDIR}/devel/autoconf \
autoreconf-2.69:${PORTSDIR}/devel/autoconf \
- aclocal-1.14:${PORTSDIR}/devel/automake \
- automake-1.14:${PORTSDIR}/devel/automake
+ aclocal-1.15:${PORTSDIR}/devel/automake \
+ automake-1.15:${PORTSDIR}/devel/automake
.if defined(libtool_ARGS) && empty(libtool_ARGS:Mbuild)
BUILD_DEPENDS+= libtoolize:${PORTSDIR}/devel/libtool
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index de121b7cd257..c73be3400e9f 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -57,7 +57,7 @@ patch-libtool:
-e '/if.*prog.*linkmode.*relink !=.*mode/s/if.*;/if :;/'\
-e '/if.*linkmode.*prog.*mode.* = relink/s/||.*;/;/' \
-e '/if.*prog.*linkmode.*relink = .*mode/s/||.*;/;/' \
- -e 's/|-p|-pg|/|-B*|-p|-pg|/'
+ -e 's/|-p|-pg|/|-B*|-fstack-protector*|-p|-pg|/'
patch-lafiles:
.if ${libtool_ARGS:Mkeepla}
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index f304d8a0b8eb..b6e68d8ebad0 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -104,8 +104,8 @@ GNU_CONFIGURE= yes
.endif
.if defined(_AUTOTOOL_automake)
-AUTOMAKE_VERSION= 1.14
-AUTOMAKE_APIVER= 1.14
+AUTOMAKE_VERSION= 1.15
+AUTOMAKE_APIVER= 1.15
AUTOMAKE_PORT= devel/automake
. if ${_AUTOTOOL_automake} == "yes"
diff --git a/databases/libmemcached/Makefile b/databases/libmemcached/Makefile
index 8e342cfac1c6..27185414aed3 100644
--- a/databases/libmemcached/Makefile
+++ b/databases/libmemcached/Makefile
@@ -19,9 +19,10 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-memcached \
+ --without-sphinx-build \
--enable-libmemcachedprotocol
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+LIBS+= -L${LOCALBASE}/lib -lexecinfo
CXXFLAGS+= -D__STDC_CONSTANT_MACROS
OPTIONS_DEFINE= DEBUG DTRACE MEMASLAP SASL
@@ -50,6 +51,7 @@ PATHFIX_MAKEFILEIN= include.am
post-patch:
@${REINPLACE_CMD} -e '/^LDFLAGS *=/ s/$$/ $${LTLIBSASL2}/' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} '/MAKE.*man/d' ${WRKSRC}/man/include.am
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so.*
diff --git a/databases/libmemcached/files/patch-configure.ac b/databases/libmemcached/files/patch-configure.ac
new file mode 100644
index 000000000000..6b9c0665e33d
--- /dev/null
+++ b/databases/libmemcached/files/patch-configure.ac
@@ -0,0 +1,19 @@
+--- configure.ac.orig 2014-02-09 11:52:42 UTC
++++ configure.ac
+@@ -13,13 +13,13 @@ m4_include([version.m4])
+ AC_PREREQ([2.61])
+ AC_INIT([libmemcached],VERSION_NUMBER,[http://libmemcached.org/])
+
++AC_CONFIG_AUX_DIR([build-aux])
++AC_CONFIG_MACRO_DIR([m4])
++
+ # Setup the compilers early on
+ AC_PROG_CC([cc gcc clang])
+ AC_PROG_CXX([c++ g++ clang++])
+
+-AC_CONFIG_AUX_DIR([build-aux])
+-AC_CONFIG_MACRO_DIR([m4])
+-
+ AC_CANONICAL_HOST
+ AC_ARG_PROGRAM
+ AC_USE_SYSTEM_EXTENSIONS
diff --git a/devel/automake/Makefile b/devel/automake/Makefile
index 758f488c0d0f..0c547fdb2ff9 100644
--- a/devel/automake/Makefile
+++ b/devel/automake/Makefile
@@ -2,26 +2,23 @@
# $FreeBSD$
PORTNAME= automake
-PORTVERSION= 1.14
-PORTREVISION= 1
+PORTVERSION= 1.15
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= automake
-DISTNAME= automake-${PORTVERSION}
+MASTER_SITES= GNU
MAINTAINER= autotools@FreeBSD.org
COMMENT= GNU Standards-compliant Makefile generator
-RUN_DEPENDS= ${AUTOCONF_DEPENDS} \
+BUILD_DEPENDS= autoconf-2.69:${PORTSDIR}/devel/autoconf
+RUN_DEPENDS= autoconf-2.69:${PORTSDIR}/devel/autoconf \
automake-wrapper:${PORTSDIR}/devel/automake-wrapper
-USE_AUTOTOOLS= autoconf:env
-BUILD_VERSION= 1.14
+BUILD_VERSION= 1.15
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
USES= makeinfo perl5 tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION}
-CONFIGURE_ENV+= MAKEINFO="makeinfo --no-split"
+MAKE_ENV+= MAKEINFOFLAGS=--no-split
INFO= automake
.include <bsd.port.mk>
diff --git a/devel/automake/distinfo b/devel/automake/distinfo
index b643cf80d596..7611ba297864 100644
--- a/devel/automake/distinfo
+++ b/devel/automake/distinfo
@@ -1,2 +1,2 @@
-SHA256 (automake-1.14.tar.xz) = e1188f5d074374cf06946cabb2b9e70bee141637a8fd1fab9a660c8930fe8059
-SIZE (automake-1.14.tar.xz) = 1485516
+SHA256 (automake-1.15.tar.xz) = 9908c75aabd49d13661d6dcb1bc382252d22cc77bf733a2d55e87f2aa2db8636
+SIZE (automake-1.15.tar.xz) = 1496708
diff --git a/devel/automake/pkg-descr b/devel/automake/pkg-descr
index 5d7f85e52d7f..f096d0316901 100644
--- a/devel/automake/pkg-descr
+++ b/devel/automake/pkg-descr
@@ -9,4 +9,4 @@ program. aclocal is a program to generate an 'aclocal.m4' based on the
contents of 'configure.in'. It is useful as an extensible, maintainable
mechanism for augmenting autoconf.
-WWW: http://www.gnu.org/software/automake/
+WWW: https://www.gnu.org/software/automake/
diff --git a/devel/automake/pkg-plist b/devel/automake/pkg-plist
index 85bc42a19e59..0537c7b74130 100644
--- a/devel/automake/pkg-plist
+++ b/devel/automake/pkg-plist
@@ -1,9 +1,9 @@
bin/aclocal-%%BUILD_VERSION%%
bin/automake-%%BUILD_VERSION%%
-man/man1/aclocal-1.14-1.14.1.gz
-man/man1/aclocal-1.14.1.gz
-man/man1/automake-1.14-1.14.1.gz
-man/man1/automake-1.14.1.gz
+man/man1/aclocal-%%BUILD_VERSION%%-%%BUILD_VERSION%%.1.gz
+man/man1/aclocal-%%BUILD_VERSION%%.1.gz
+man/man1/automake-%%BUILD_VERSION%%-%%BUILD_VERSION%%.1.gz
+man/man1/automake-%%BUILD_VERSION%%.1.gz
share/aclocal-%%BUILD_VERSION%%/amversion.m4
share/aclocal-%%BUILD_VERSION%%/ar-lib.m4
share/aclocal-%%BUILD_VERSION%%/as.m4
@@ -109,7 +109,6 @@ share/automake-%%BUILD_VERSION%%/mdate-sh
share/automake-%%BUILD_VERSION%%/missing
share/automake-%%BUILD_VERSION%%/mkinstalldirs
share/automake-%%BUILD_VERSION%%/py-compile
-share/automake-%%BUILD_VERSION%%/tap-driver.pl
share/automake-%%BUILD_VERSION%%/tap-driver.sh
share/automake-%%BUILD_VERSION%%/test-driver
share/automake-%%BUILD_VERSION%%/texinfo.tex
diff --git a/devel/autotools/Makefile b/devel/autotools/Makefile
index 1d62f20e813d..17753f2fe4e6 100644
--- a/devel/autotools/Makefile
+++ b/devel/autotools/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= libtoolize:${PORTSDIR}/devel/libtool \
autoconf-2.13:${PORTSDIR}/devel/autoconf213 \
autoconf-2.69:${PORTSDIR}/devel/autoconf \
automake-1.4:${PORTSDIR}/devel/automake14 \
- automake-1.14:${PORTSDIR}/devel/automake
+ automake-1.15:${PORTSDIR}/devel/automake
PLIST_FILES= share/${PORTNAME}
NO_BUILD= yes
diff --git a/devel/gettext-runtime/pkg-plist b/devel/gettext-runtime/pkg-plist
index 6cb2b44697f5..4c1d4a9a319f 100644
--- a/devel/gettext-runtime/pkg-plist
+++ b/devel/gettext-runtime/pkg-plist
@@ -11,7 +11,7 @@ lib/libasprintf.so.0.0.0
lib/libintl.a
lib/libintl.so
lib/libintl.so.8
-lib/libintl.so.8.1.2
+lib/libintl.so.8.1.3
lib/libintl.so.9
man/man1/envsubst.1.gz
man/man1/gettext.1.gz
diff --git a/devel/gettext-tools/pkg-plist b/devel/gettext-tools/pkg-plist
index 23043d9bc218..412d58b6e9f5 100644
--- a/devel/gettext-tools/pkg-plist
+++ b/devel/gettext-tools/pkg-plist
@@ -17,13 +17,13 @@ bin/msguniq
bin/recode-sr-latin
bin/xgettext
include/gettext-po.h
-lib/libgettextlib-0.19.3.so
+lib/libgettextlib-0.19.4.so
lib/libgettextlib.so
lib/libgettextpo.a
lib/libgettextpo.so
lib/libgettextpo.so.0
-lib/libgettextpo.so.0.5.2
-lib/libgettextsrc-0.19.3.so
+lib/libgettextpo.so.0.5.3
+lib/libgettextsrc-0.19.4.so
lib/libgettextsrc.so
lib/gettext/hostname
lib/gettext/project-id
diff --git a/devel/gettext/Makefile.common b/devel/gettext/Makefile.common
index ad0c17a7a12b..1807bc7758ae 100644
--- a/devel/gettext/Makefile.common
+++ b/devel/gettext/Makefile.common
@@ -4,7 +4,7 @@
# experimental ports run. Untested commits may be backed out at portmgr's
# discretion.
-PORTVERSION= 0.19.3
+PORTVERSION= 0.19.4
PORTREVISION?= 0 # Leave this zero. Set in Makefile instead.
CATEGORIES= devel
MASTER_SITES= GNU/gettext
diff --git a/devel/gettext/distinfo b/devel/gettext/distinfo
index 70c42117363f..5fe7ecf10e00 100644
--- a/devel/gettext/distinfo
+++ b/devel/gettext/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gettext-0.19.3.tar.xz) = f6fdb29c9ee8ce85c7e574f60ff64fa91cf0f4f018437dfe800227d15595db46
-SIZE (gettext-0.19.3.tar.xz) = 6628460
+SHA256 (gettext-0.19.4.tar.xz) = 719adadb8bf3e36bac52c243a01c0add18d23506a3a40437e6f5899ceab18d20
+SIZE (gettext-0.19.4.tar.xz) = 6656168
diff --git a/devel/git-merge-changelog/Makefile b/devel/git-merge-changelog/Makefile
index 53134121ff00..b8391dfbb826 100644
--- a/devel/git-merge-changelog/Makefile
+++ b/devel/git-merge-changelog/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= knu@FreeBSD.org
COMMENT= Git "merge" driver for GNU style ChangeLog files
EXTRACT_DEPENDS= ${GNULIB_DIR}/lib/${PORTNAME}.c:${GNULIB_PORTDIR} \
- automake-1.14:${PORTSDIR}/devel/automake \
+ automake-1.15:${PORTSDIR}/devel/automake \
autoconf-2.69:${PORTSDIR}/devel/autoconf
GNU_CONFIGURE= yes
diff --git a/devel/libltdl/pkg-descr b/devel/libltdl/pkg-descr
index e57b99f21a5c..d86a469c6bfa 100644
--- a/devel/libltdl/pkg-descr
+++ b/devel/libltdl/pkg-descr
@@ -7,3 +7,5 @@ It supports the following dlopen interfaces:
* load_add_on (BeOS)
* GNU DLD (emulates dynamic linking for static libraries)
* libtool's dlpreopen
+
+WWW: https://www.gnu.org/software/libtool/
diff --git a/devel/libtool/Makefile b/devel/libtool/Makefile
index a6d2eb23cb8b..2be46e804953 100644
--- a/devel/libtool/Makefile
+++ b/devel/libtool/Makefile
@@ -23,8 +23,6 @@ INFO= libtool
post-patch:
@${RM} -f ${WRKSRC}/doc/*.info*
-.for f in build-aux/ltmain.sh configure libtoolize.in m4/libtool.m4
- @${TOUCH} -mr ${WRKSRC}/${f}.orig ${WRKSRC}/${f}
-.endfor
+ @${TOUCH} ${WRKSRC}/doc/libtool.1
.include <bsd.port.mk>
diff --git a/devel/libtool/Makefile.common b/devel/libtool/Makefile.common
index 9a4e07e19bbc..bf4095650c22 100644
--- a/devel/libtool/Makefile.common
+++ b/devel/libtool/Makefile.common
@@ -1,9 +1,9 @@
# $FreeBSD$
-PORTVERSION= 2.4.2.418
+PORTVERSION= 2.4.5
PORTREVISION?= 0 # Leave this zero. Set in Makefile instead.
CATEGORIES= devel
-MASTER_SITES= GNU_ALPHA/libtool
+MASTER_SITES= GNU/libtool
DISTNAME= libtool-${PORTVERSION}
MAINTAINER= autotools@FreeBSD.org
diff --git a/devel/libtool/distinfo b/devel/libtool/distinfo
index 04a7797b6d94..a743169c2ce0 100644
--- a/devel/libtool/distinfo
+++ b/devel/libtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libtool-2.4.2.418.tar.xz) = 6465c7e6ebb7c9083aa610d510498aadf7be0c6dc5f2f4e57008686879d27d8c
-SIZE (libtool-2.4.2.418.tar.xz) = 941808
+SHA256 (libtool-2.4.5.tar.xz) = 84aac136513b009278896ffa255e4d685bcdb0cb0e5363be36adad64c986177e
+SIZE (libtool-2.4.5.tar.xz) = 971620
diff --git a/devel/libtool/files/patch-build-aux_ltmain.sh b/devel/libtool/files/patch-build-aux_ltmain.sh
deleted file mode 100644
index 8b617eb99390..000000000000
--- a/devel/libtool/files/patch-build-aux_ltmain.sh
+++ /dev/null
@@ -1,30 +0,0 @@
---- build-aux/ltmain.sh.orig 2013-10-26 22:53:58 UTC
-+++ build-aux/ltmain.sh
-@@ -8598,13 +8598,13 @@ func_mode_link ()
- #
- case $version_type in
- # correct linux to gnu/linux during the next big refactor
-- darwin|linux|osf|windows|none)
-+ darwin|freebsd-elf|linux|osf|windows|none)
- func_arith $number_major + $number_minor
- current=$func_arith_result
- age=$number_minor
- revision=$number_revision
- ;;
-- freebsd-aout|freebsd-elf|qnx|sunos)
-+ freebsd-aout|qnx|sunos)
- current=$number_major
- revision=$number_minor
- age=0
-@@ -8690,8 +8690,9 @@ func_mode_link ()
- ;;
-
- freebsd-elf)
-- major=.$current
-- versuffix=.$current
-+ func_arith $current - $age
-+ major=.$func_arith_result
-+ versuffix=$major.$age.$revision
- ;;
-
- irix | nonstopux)
diff --git a/devel/libtool/files/patch-configure b/devel/libtool/files/patch-configure
deleted file mode 100644
index f388f32064ea..000000000000
--- a/devel/libtool/files/patch-configure
+++ /dev/null
@@ -1,42 +0,0 @@
---- configure.orig 2013-10-26 22:53:35 UTC
-+++ configure
-@@ -11582,7 +11582,8 @@ freebsd* | dragonfly*)
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
-+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
-+ soname_spec='$libname$release$shared_ext$major'
- need_version=no
- need_lib_prefix=no
- ;;
-@@ -16739,7 +16740,8 @@ freebsd* | dragonfly*)
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
-+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
-+ soname_spec='$libname$release$shared_ext$major'
- need_version=no
- need_lib_prefix=no
- ;;
-@@ -19695,7 +19697,8 @@ freebsd* | dragonfly*)
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
-+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
-+ soname_spec='$libname$release$shared_ext$major'
- need_version=no
- need_lib_prefix=no
- ;;
-@@ -22786,7 +22789,8 @@ freebsd* | dragonfly*)
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
-+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
-+ soname_spec='$libname$release$shared_ext$major'
- need_version=no
- need_lib_prefix=no
- ;;
diff --git a/devel/libtool/files/patch-libtoolize.in b/devel/libtool/files/patch-libtoolize.in
deleted file mode 100644
index 9200d99bb561..000000000000
--- a/devel/libtool/files/patch-libtoolize.in
+++ /dev/null
@@ -1,34 +0,0 @@
---- libtoolize.in.orig 2013-08-23 05:06:01 UTC
-+++ libtoolize.in
-@@ -393,7 +393,7 @@ func_copy ()
- # Filters always take priority.
- if test -n "$my_filter"; then
- if $opt_dry_run || {
-- ( umask 0
-+ (
- $SED -e "$my_filter" "$my_srcfile" > "$my_destfile"
- ) >/dev/null 2>&1
- }
-@@ -423,7 +423,7 @@ func_copy ()
- $opt_verbose && my_copy_msg="$my_copycmd $my_srcfile $my_destdir"
-
- if $opt_dry_run || {
-- ( umask 0
-+ (
- $my_copycmd "$my_srcfile" "$my_destfile"
- ) >/dev/null 2>&1
- }
-@@ -1894,9 +1894,10 @@ func_require_seen_libtool ()
- # Lists of all files libtoolize has ever installed. These are removed
- # before installing the latest files when --force was passed to help
- # ensure a clean upgrade.
-- # Do not remove config.guess nor config.sub, we don't install them
-- # without --install, and the project may not be using Automake.
-- all_pkgaux_files="compile install-sh depcomp missing ltmain.sh snippet/_Noreturn.h snippet/arg-nonnull.h snippet/c++defs.h snippet/warn-on-use.h"
-+ # Do not remove config.guess, config.sub or install-sh, we don't
-+ # install them without --install, and the project may not be using
-+ # Automake.
-+ all_pkgaux_files="compile depcomp missing ltmain.sh snippet/_Noreturn.h snippet/arg-nonnull.h snippet/c++defs.h snippet/warn-on-use.h"
- all_pkgmacro_files="argz.m4 libtool.m4 ltdl.m4 ltoptions.m4 ltsugar.m4 ltversion.in ltversion.m4 lt~obsolete.m4"
- all_pkgltdl_files="COPYING.LIB Makefile Makefile.in Makefile.inc Makefile.am README acinclude.m4 aclocal.m4 argz_.h argz.c config.h.in config-h.in configure configure.ac configure.in libltdl/lt__alloc.h libltdl/lt__dirent.h libltdl/lt__glibc.h libltdl/lt__private.h libltdl/lt__strl.h libltdl/lt_dlloader.h libltdl/lt_error.h libltdl/lt_system.h libltdl/slist.h loaders/dld_link.c loaders/dlopen.c loaders/dyld.c loaders/load_add_on.c loaders/loadlibrary.c loaders/preopen.c loaders/shl_load.c lt__alloc.c lt__dirent.c lt__strl.c lt_dlloader.c lt_error.c ltdl.c ltdl.h ltdl.mk slist.c"
-
diff --git a/devel/libtool/files/patch-m4_libtool.m4 b/devel/libtool/files/patch-m4_libtool.m4
deleted file mode 100644
index 166403936d9d..000000000000
--- a/devel/libtool/files/patch-m4_libtool.m4
+++ /dev/null
@@ -1,12 +0,0 @@
---- m4/libtool.m4.orig 2013-10-25 23:37:46 UTC
-+++ m4/libtool.m4
-@@ -2547,7 +2547,8 @@ freebsd* | dragonfly*)
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
-+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
-+ soname_spec='$libname$release$shared_ext$major'
- need_version=no
- need_lib_prefix=no
- ;;
diff --git a/devel/libtool/pkg-descr b/devel/libtool/pkg-descr
index 1dea88bf6d51..4d1a31a0b60b 100644
--- a/devel/libtool/pkg-descr
+++ b/devel/libtool/pkg-descr
@@ -5,4 +5,4 @@ interface.
To use libtool, add the new generic library building commands to your
Makefile, Makefile.in, or Makefile.am.
-WWW: http://www.gnu.org/software/libtool/
+WWW: https://www.gnu.org/software/libtool/
diff --git a/devel/libtool/pkg-plist b/devel/libtool/pkg-plist
index 1c0683fb8c1d..e3ab7e6742af 100644
--- a/devel/libtool/pkg-plist
+++ b/devel/libtool/pkg-plist
@@ -2,8 +2,8 @@ bin/libtool
bin/libtoolize
man/man1/libtool.1.gz
man/man1/libtoolize.1.gz
-share/aclocal/argz.m4
share/aclocal/libtool.m4
+share/aclocal/ltargz.m4
share/aclocal/ltdl.m4
share/aclocal/ltoptions.m4
share/aclocal/ltsugar.m4
@@ -14,8 +14,6 @@ share/aclocal/lt~obsolete.m4
%%DATADIR%%/Makefile.in
%%DATADIR%%/README
%%DATADIR%%/aclocal.m4
-%%DATADIR%%/argz.c
-%%DATADIR%%/argz_.h
%%DATADIR%%/build-aux/compile
%%DATADIR%%/build-aux/config.guess
%%DATADIR%%/build-aux/config.sub
@@ -27,6 +25,7 @@ share/aclocal/lt~obsolete.m4
%%DATADIR%%/configure
%%DATADIR%%/configure.ac
%%DATADIR%%/libltdl/lt__alloc.h
+%%DATADIR%%/libltdl/lt__argz_.h
%%DATADIR%%/libltdl/lt__dirent.h
%%DATADIR%%/libltdl/lt__glibc.h
%%DATADIR%%/libltdl/lt__private.h
@@ -43,6 +42,7 @@ share/aclocal/lt~obsolete.m4
%%DATADIR%%/loaders/preopen.c
%%DATADIR%%/loaders/shl_load.c
%%DATADIR%%/lt__alloc.c
+%%DATADIR%%/lt__argz.c
%%DATADIR%%/lt__dirent.c
%%DATADIR%%/lt__strl.c
%%DATADIR%%/lt_dlloader.c
diff --git a/devel/xfce4-dev-tools/Makefile b/devel/xfce4-dev-tools/Makefile
index 328f6c3b90e4..98a858cb8338 100644
--- a/devel/xfce4-dev-tools/Makefile
+++ b/devel/xfce4-dev-tools/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-dev-tools
PORTVERSION= 4.10.0
+PORTREVISION= 1
CATEGORIES= devel xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
@@ -10,7 +11,9 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce 4 development tools
-RUN_DEPENDS= ${LOCALBASE}/share/autotools:${PORTSDIR}/devel/autotools
+RUN_DEPENDS= autoconf-2.69:${PORTSDIR}/devel/autoconf \
+ automake-1.15:${PORTSDIR}/devel/automake \
+ libtoolize:${PORTSDIR}/devel/libtool
GNU_CONFIGURE= yes
USE_XFCE= configenv # to get MASTER_SITE_SUBDIR something has to be defined
diff --git a/security/sssd/files/patch-configure.ac b/security/sssd/files/patch-configure.ac
new file mode 100644
index 000000000000..4ce24d7010f4
--- /dev/null
+++ b/security/sssd/files/patch-configure.ac
@@ -0,0 +1,21 @@
+--- configure.ac.orig 2013-11-06 18:35:03 UTC
++++ configure.ac
+@@ -5,15 +5,15 @@ AC_INIT([sssd],
+ VERSION_NUMBER,
+ [sssd-devel@lists.fedorahosted.org])
+
++AC_CONFIG_SRCDIR([BUILD.txt])
++AC_CONFIG_AUX_DIR([build])
++
+ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
+ [AC_USE_SYSTEM_EXTENSIONS],
+ [AC_GNU_SOURCE])
+
+ CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"
+
+-AC_CONFIG_SRCDIR([BUILD.txt])
+-AC_CONFIG_AUX_DIR([build])
+-
+ AM_INIT_AUTOMAKE([-Wall foreign subdir-objects tar-pax])
+ AM_PROG_CC_C_O
+ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])