aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk29
-rw-r--r--devel/bcc/Makefile2
-rw-r--r--devel/error/Makefile2
-rw-r--r--devel/linux_kdump/Makefile2
-rw-r--r--devel/plan9port/Makefile2
-rw-r--r--dns/ldns/Makefile2
-rw-r--r--editors/mined/Makefile2
-rw-r--r--games/wesnoth-devel/Makefile4
-rw-r--r--games/wesnoth/Makefile4
-rw-r--r--games/xmulti/Makefile2
-rw-r--r--games/xscorch/Makefile2
-rw-r--r--german/manpages/Makefile2
-rw-r--r--lang/erlang/Makefile2
-rw-r--r--lang/erlang14/Makefile2
-rw-r--r--lang/gcc34/Makefile2
-rw-r--r--lang/gnat-gcc41/Makefile2
-rw-r--r--lang/gnat-gcc42/Makefile2
-rw-r--r--lang/gnat-gcc43/Makefile2
-rw-r--r--lang/gnat-gcc44/Makefile2
-rw-r--r--misc/freedialog/files/patch-aa2
-rw-r--r--misc/shuffle/Makefile2
-rw-r--r--net/htpdate/Makefile2
-rw-r--r--net/mopd/Makefile2
-rw-r--r--net/v6eval/Makefile2
-rw-r--r--palm/p5-Palm/Makefile2
-rw-r--r--ports-mgmt/portbrowser/Makefile2
-rw-r--r--print/enscriptfonts/Makefile2
-rw-r--r--print/perlftlib/Makefile2
-rw-r--r--security/qident/Makefile2
-rw-r--r--sysutils/dc42wrap/Makefile2
-rw-r--r--sysutils/heirloom/Makefile2
-rw-r--r--sysutils/readlink/Makefile2
-rw-r--r--sysutils/wmpccard/Makefile2
-rw-r--r--textproc/freegrep/files/patch-aa2
-rw-r--r--www/p5-AMF-Perl/Makefile2
-rw-r--r--x11-toolkits/p5-Prima/Makefile2
-rw-r--r--x11/chameleon/files/Makefile2
37 files changed, 52 insertions, 53 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a968852a140d..a636c3c35362 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -620,7 +620,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
#
# Set the following to specify all manpages that your port installs.
# These manpages will be automatically listed in ${PLIST}. Depending
-# on the setting of NOMANCOMPRESS, the make rules will compress the
+# on the setting of NO_MANCOMPRESS, the make rules will compress the
# manpages for you.
#
# MAN<sect> - A list of manpages, categorized by section. For
@@ -653,7 +653,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# MANCOMPRESSED - This variable can take values "yes", "no" or
# "maybe". "yes" means manpages are installed
# compressed; "no" means they are not; "maybe" means
-# it changes depending on the value of NOMANCOMPRESS.
+# it changes depending on the value of NO_MANCOMPRESS.
# Default: "yes" if USE_IMAKE is set and NO_INSTALL_MANPAGES
# is not set, and "no" otherwise.
#
@@ -2291,7 +2291,7 @@ EXTRACT_BEFORE_ARGS?= -dc
.if defined(EXTRACT_PRESERVE_OWNERSHIP)
EXTRACT_AFTER_ARGS?= | ${TAR} -xf -
.else
-EXTRACT_AFTER_ARGS?= | ${TAR} -xf - --no-same-owner
+EXTRACT_AFTER_ARGS?= | ${TAR} -xf - --no-same-owner --no-same-permissions
.endif
.if defined(USE_BZIP2)
EXTRACT_CMD?= ${BZIP2_CMD}
@@ -2955,7 +2955,7 @@ MANNPREFIX?= ${MANPREFIX}
MANLANG?= "" # english only by default
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
MANEXT= .gz
.endif
@@ -3039,7 +3039,7 @@ _TMLINKS=
.if defined(_MANPAGES)
-.if defined(NOMANCOMPRESS)
+.if defined(NO_MANCOMPRESS)
__MANPAGES:= ${_MANPAGES:S%^${PREFIX}/%%}
.else
__MANPAGES:= ${_MANPAGES:S%^${PREFIX}/%%:S%$%.gz%}
@@ -4253,10 +4253,10 @@ _CHROOT_SEQ= post-chroot
.else
_CHROOT_SEQ=
.endif
-_SANITY_SEQ= ${_CHROOT_SEQ} pre-everything check-makefile check-categories \
- check-makevars check-desktop-entries check-depends \
- check-deprecated check-vulnerable buildanyway-message \
- options-message
+_SANITY_SEQ= ${_CHROOT_SEQ} pre-everything check-makefile \
+ check-categories check-makevars check-desktop-entries \
+ check-conflicts check-depends check-deprecated \
+ check-vulnerable buildanyway-message options-message
_FETCH_DEP= check-sanity
_FETCH_SEQ= fetch-depends pre-fetch pre-fetch-script \
do-fetch post-fetch post-fetch-script
@@ -4275,8 +4275,7 @@ _BUILD_DEP= configure
_BUILD_SEQ= build-message pre-build pre-build-script do-build \
post-build post-build-script
_INSTALL_DEP= build
-_INSTALL_SEQ= install-message check-conflicts \
- run-depends lib-depends apply-slist pre-install \
+_INSTALL_SEQ= install-message run-depends lib-depends apply-slist pre-install \
pre-install-script generate-plist check-already-installed
_INSTALL_SUSEQ= check-umask install-mtree pre-su-install \
pre-su-install-script create-users-groups do-install \
@@ -5479,7 +5478,7 @@ missing:
. if !target(describe)
_EXTRACT_DEPENDS=${EXTRACT_DEPENDS:C/^[^ :]+:([^ :]+)(:[^ :]+)?/\1/:O:u}
_PATCH_DEPENDS=${PATCH_DEPENDS:C/^[^ :]+:([^ :]+)(:[^ :]+)?/\1/:O:u}
-_FETCH_DEPENDS=${FETCH_DEPENDS:C/^[^ :]+:([^ :]+)(:[^ :]+)?/\1/:O:u}
+_FETCH_DEPENDS=${FETCH_DEPENDS:C/^[^ :]+:([^ :]+)(:[^ :]+)?/\1/:O:u}
_LIB_DEPENDS=${LIB_DEPENDS:C/^[^ :]+:([^ :]+)(:[^ :]+)?/\1/:O:u}
_BUILD_DEPENDS=${BUILD_DEPENDS:C/^[^ :]+:([^ :]+)(:[^ :]+)?/\1/:O:u} ${_LIB_DEPENDS}
_RUN_DEPENDS=${RUN_DEPENDS:C/^[^ :]+:([^ :]+)(:[^ :]+)?/\1/:O:u} ${_LIB_DEPENDS}
@@ -5502,7 +5501,7 @@ describe:
break; \
;; \
esac; \
- done < ${DESCR}; ${ECHO_CMD}
+ done < ${DESCR}; ${ECHO_CMD}
. endif
.else
. if !target(describe)
@@ -5875,10 +5874,10 @@ install-rc-script:
.if !target(compress-man)
compress-man:
.if defined(_MANPAGES) || defined(_MLINKS)
-.if ${MANCOMPRESSED} == yes && defined(NOMANCOMPRESS)
+.if ${MANCOMPRESSED} == yes && defined(NO_MANCOMPRESS)
@${ECHO_MSG} "===> Uncompressing manual pages for ${PKGNAME}"
@_manpages='${_MANPAGES:S/'/'\''/g}' && [ "$${_manpages}" != "" ] && ( eval ${GUNZIP_CMD} $${_manpages} ) || ${TRUE}
-.elif ${MANCOMPRESSED} == no && !defined(NOMANCOMPRESS)
+.elif ${MANCOMPRESSED} == no && !defined(NO_MANCOMPRESS)
@${ECHO_MSG} "===> Compressing manual pages for ${PKGNAME}"
@_manpages='${_MANPAGES:S/'/'\''/g}' && [ "$${_manpages}" != "" ] && ( eval ${GZIP_CMD} $${_manpages} ) || ${TRUE}
.endif
diff --git a/devel/bcc/Makefile b/devel/bcc/Makefile
index 1c6ea218fd3a..f923ca614918 100644
--- a/devel/bcc/Makefile
+++ b/devel/bcc/Makefile
@@ -15,7 +15,7 @@ COMMENT= Bruce's C compiler (with as and ld); can do 16-bit code
CONFLICTS= bin86-[0-9]* dev86-[0-9]*
MAN1= as86.1 bcc.1 bcc-cc1.1 ld86.1
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
MANCOMPRESSED= yes
.endif
diff --git a/devel/error/Makefile b/devel/error/Makefile
index 0d673aa7b70d..e9a04572cba7 100644
--- a/devel/error/Makefile
+++ b/devel/error/Makefile
@@ -20,7 +20,7 @@ MANCOMPRESSED= maybe
PLIST_FILES= bin/error
# MAN page COMPression SUFFIX
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
MANCOMPSUFFIX= .gz
.else
MANCOMPSUFFIX=
diff --git a/devel/linux_kdump/Makefile b/devel/linux_kdump/Makefile
index 4d5809e498db..161fb22cd05b 100644
--- a/devel/linux_kdump/Makefile
+++ b/devel/linux_kdump/Makefile
@@ -18,8 +18,8 @@ COMMENT= Linux-compatability ktrace.out processor
BUILD_DEPENDS= ${LINUXBASE}/usr/bin/gcc:${PORTSDIR}/emulators/linux_base-gentoo-stage3
ONLY_FOR_ARCHS= i386 amd64
+NO_MANCOMPRESS= yes
MAN1= linux_kdump.1.gz
-NOMANCOMPRESS= true
PLIST_FILES= bin/linux_kdump
.include <bsd.port.pre.mk>
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index f4949669f0ab..d125283b5046 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -82,7 +82,7 @@ MAN8= listen1.8 vbackup.8 venti-backup.8 venti-fmt.8 venti.8
MAN9= 0intro.9p attach.9p clunk.9p error.9p flush.9p open.9p \
openfd.9p read.9p remove.9p stat.9p version.9p walk.9p
MANCOMPRESSED= no
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
EMPTY_DIRS= plan9/log \
plan9/bin/lpbin \
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index 4fee76b512ea..450c7210d0b0 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -31,7 +31,7 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
ALL_TARGET+= doc
INSTALL_TARGET+=install-manpages
-NOMANCOMPRESS= true
+NO_MANCOMPRESS= yes
MANCOMPRESSED= no
MAN3= ldns_bget_token.3 ldns_bgetc.3 ldns_bskipcs.3 ldns_buffer.3 \
ldns_buffer2pkt_wire.3 ldns_buffer_at.3 ldns_buffer_available.3 \
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
index dc7bb1ed3446..422b633ff5e7 100644
--- a/editors/mined/Makefile
+++ b/editors/mined/Makefile
@@ -29,7 +29,7 @@ MAKE_ARGS= GMAKE=${GMAKE} CC=${CC:T} OPT="${CFLAGS}"
INSTALL_TARGET= localinstall
MAKE_JOBS_UNSAFE= yes
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN1= mined.1 minmacs.1 mpico.1 mstar.1 umined.1 uterm.1 xmined.1
PRFX2FIX= src/makefile.bsd usrshare/conf_user/xinitrc.mined \
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
index 4934e0be001a..403865869e4c 100644
--- a/games/wesnoth-devel/Makefile
+++ b/games/wesnoth-devel/Makefile
@@ -70,7 +70,7 @@ BROKEN= does not compile
.for manlang in ${MANLANG_GAME}
MAN6_${manlang:U}= wesnoth.6
-.if defined(NOMANCOMPRESS)
+.if defined(NO_MANCOMPRESS)
PLIST_FILES+= man/${manlang}/man6/wesnoth.6
.else
PLIST_FILES+= man/${manlang}/man6/wesnoth.6.gz
@@ -208,7 +208,7 @@ BROKEN= NOPORT(DOCS|DATA) is not supported
post-install: .SILENT
-update-desktop-database
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
. for manlang in ${MANLANG_GAME}
${GZIP_CMD} ${PREFIX}/man/${manlang}/man6/wesnoth.6
. endfor
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index e4220a044293..35600c11afb2 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -52,7 +52,7 @@ OPTIONS= CAMPAIGN "Enable campaign server" On \
.for manlang in ${MANLANG_GAME}
MAN6_${manlang:U}= wesnoth.6
-.if defined(NOMANCOMPRESS)
+.if defined(NO_MANCOMPRESS)
PLIST_FILES+= man/${manlang}/man6/wesnoth.6
.else
PLIST_FILES+= man/${manlang}/man6/wesnoth.6.gz
@@ -118,7 +118,7 @@ BROKEN= you need NLS support for `campaignd' or `wesnothd' or tools to link aga
post-install: .SILENT
-update-desktop-database
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
. for manlang in ${MANLANG_GAME}
${GZIP_CMD} ${PREFIX}/man/${manlang}/man6/wesnoth.6
. endfor
diff --git a/games/xmulti/Makefile b/games/xmulti/Makefile
index 450ffd00ebd3..4c6221ec8800 100644
--- a/games/xmulti/Makefile
+++ b/games/xmulti/Makefile
@@ -21,7 +21,7 @@ USE_IMAKE= yes
USE_XORG= x11 xext xaw xmu xt xpm sm ice
MAN1= xmaid.1
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
DOCSDIR= ${PREFIX}/share/doc/ja/{PORTNAME}
post-install:
diff --git a/games/xscorch/Makefile b/games/xscorch/Makefile
index f2477cb988d7..02716a2ae6ee 100644
--- a/games/xscorch/Makefile
+++ b/games/xscorch/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk
MAN6= xscorch.6
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
.include <bsd.port.pre.mk>
diff --git a/german/manpages/Makefile b/german/manpages/Makefile
index 34af90f2f4d1..aaa4dd584181 100644
--- a/german/manpages/Makefile
+++ b/german/manpages/Makefile
@@ -23,7 +23,7 @@ manpages= ${PORTNAME}-${PORTVERSION}
do-build:
makewhatis ${WRKSRC}/${manpages}
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
${GZIP_CMD} -r ${WRKSRC}/${manpages}/man* || exit 0
.endif
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 042dfaf75740..e5aa6ba7b2cf 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -100,7 +100,7 @@ MAKE_ARGS+= ARCH=x86
# Erlang man pages are more of internal documentation using the man format than
# actual system man pages. (erl.1 and epmd.1 perhaps being the exception).
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN1PREFIX= ${PREFIX}/lib/erlang
MAN3PREFIX= ${PREFIX}/lib/erlang
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 042dfaf75740..e5aa6ba7b2cf 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -100,7 +100,7 @@ MAKE_ARGS+= ARCH=x86
# Erlang man pages are more of internal documentation using the man format than
# actual system man pages. (erl.1 and epmd.1 perhaps being the exception).
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN1PREFIX= ${PREFIX}/lib/erlang
MAN3PREFIX= ${PREFIX}/lib/erlang
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index 3a2ee442356c..dac050d99773 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -33,7 +33,7 @@ USE_PERL5_BUILD=yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
-NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
+NO_MANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
diff --git a/lang/gnat-gcc41/Makefile b/lang/gnat-gcc41/Makefile
index a732fbfe8754..f0ffa5280d32 100644
--- a/lang/gnat-gcc41/Makefile
+++ b/lang/gnat-gcc41/Makefile
@@ -37,7 +37,7 @@ MAN1= cpp${gcc_suffix}.1 \
gcc${gcc_suffix}.1 \
gcov${gcc_suffix}.1
MAN7= ${fsf_mans:S/$/${fsf_suffix}.7/}
-NOMANCOMPRESS= yes # XXX 5-cur and releng4 problems?
+NO_MANCOMPRESS= yes # XXX 5-cur and releng4 problems?
INFO= gcc${gcc_suffix}/cpp \
gcc${gcc_suffix}/cppinternals \
gcc${gcc_suffix}/gcc \
diff --git a/lang/gnat-gcc42/Makefile b/lang/gnat-gcc42/Makefile
index b32765e78671..e75a363d8a8d 100644
--- a/lang/gnat-gcc42/Makefile
+++ b/lang/gnat-gcc42/Makefile
@@ -37,7 +37,7 @@ MAN1= cpp${gcc_suffix}.1 \
gcc${gcc_suffix}.1 \
gcov${gcc_suffix}.1
MAN7= ${fsf_mans:S/$/${fsf_suffix}.7/}
-NOMANCOMPRESS= yes # XXX 5-cur and releng4 problems?
+NO_MANCOMPRESS= yes # XXX 5-cur and releng4 problems?
INFO= gcc${gcc_suffix}/cpp \
gcc${gcc_suffix}/cppinternals \
gcc${gcc_suffix}/gcc \
diff --git a/lang/gnat-gcc43/Makefile b/lang/gnat-gcc43/Makefile
index fa5db3b7fa7b..bdd94cd2a5e3 100644
--- a/lang/gnat-gcc43/Makefile
+++ b/lang/gnat-gcc43/Makefile
@@ -40,7 +40,7 @@ MAN1= cpp${gcc_suffix}.1 \
gcc${gcc_suffix}.1 \
gcov${gcc_suffix}.1
MAN7= ${fsf_mans:S/$/${fsf_suffix}.7/}
-NOMANCOMPRESS= yes # XXX 5-cur and releng4 problems?
+NO_MANCOMPRESS= yes # XXX 5-cur and releng4 problems?
INFO= gcc${gcc_suffix}/cpp \
gcc${gcc_suffix}/cppinternals \
gcc${gcc_suffix}/gcc \
diff --git a/lang/gnat-gcc44/Makefile b/lang/gnat-gcc44/Makefile
index 3586f054c6ce..b77765573195 100644
--- a/lang/gnat-gcc44/Makefile
+++ b/lang/gnat-gcc44/Makefile
@@ -37,7 +37,7 @@ MAN1= cpp${gcc_suffix}.1 \
gcc${gcc_suffix}.1 \
gcov${gcc_suffix}.1
MAN7= ${fsf_mans:S/$/${fsf_suffix}.7/}
-NOMANCOMPRESS= yes # XXX 5-cur and releng4 problems?
+NO_MANCOMPRESS= yes # XXX 5-cur and releng4 problems?
INFO= gcc${gcc_suffix}/cpp \
gcc${gcc_suffix}/cppinternals \
gcc${gcc_suffix}/gcc \
diff --git a/misc/freedialog/files/patch-aa b/misc/freedialog/files/patch-aa
index b6c961bb3f2b..e5db8832e905 100644
--- a/misc/freedialog/files/patch-aa
+++ b/misc/freedialog/files/patch-aa
@@ -4,7 +4,7 @@
+DESTDIR= ${PREFIX}
+BINDIR= /bin
+MANDIR= /man/man
-+NOMANCOMPRESS= 1
++NO_MANCOMPRESS= 1
+
PROG= dialog
SRCS= dialog.c
diff --git a/misc/shuffle/Makefile b/misc/shuffle/Makefile
index 90234179e3d3..fab2b3f57134 100644
--- a/misc/shuffle/Makefile
+++ b/misc/shuffle/Makefile
@@ -19,7 +19,7 @@ MAN1= shuffle.1
MANCOMPRESSED= maybe
# MAN page COMPression SUFFIX
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
MANCOMPSUFFIX= .gz
.else
MANCOMPSUFFIX=
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
index 64fceabcd1f8..e2b7a6fd9d89 100644
--- a/net/htpdate/Makefile
+++ b/net/htpdate/Makefile
@@ -16,7 +16,7 @@ COMMENT= Time synchronization over http utility
USE_BZIP2= yes
MANCOMPRESSED= no
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN8= htpdate.8.gz
PLIST_FILES= bin/htpdate
diff --git a/net/mopd/Makefile b/net/mopd/Makefile
index d6a6c9844117..eefd23515f00 100644
--- a/net/mopd/Makefile
+++ b/net/mopd/Makefile
@@ -23,7 +23,7 @@ COMMENT= MOP Loader Daemon for netbooting DEC machines
.include <bsd.port.pre.mk>
-MAKE_ENV= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man NOMANCOMPRESS=true
+MAKE_ENV= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man NO_MANCOMPRESS=true
MAN1= mopprobe.1 moptrace.1 mopchk.1 mopa.out.1
MAN8= mopd.8
diff --git a/net/v6eval/Makefile b/net/v6eval/Makefile
index 681e461e0bee..9a1569261a99 100644
--- a/net/v6eval/Makefile
+++ b/net/v6eval/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect \
USE_PERL5= yes
USE_OPENSSL= yes
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN1PREFIX= ${PREFIX}/v6eval
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN1= pktctl.1.gz pktsend.1.gz
diff --git a/palm/p5-Palm/Makefile b/palm/p5-Palm/Makefile
index 1fd95dfa11dc..ca7539037d3b 100644
--- a/palm/p5-Palm/Makefile
+++ b/palm/p5-Palm/Makefile
@@ -17,7 +17,7 @@ PERL_CONFIGURE= YES
WRKSRC= ${WRKDIR}/p5-Palm-1.003_000
# Just so that the .packlist conforms to reality
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN1= pdbdump.1
MAN3= Palm::Address.3 \
Palm::Datebook.3 \
diff --git a/ports-mgmt/portbrowser/Makefile b/ports-mgmt/portbrowser/Makefile
index fe668cf5710d..d9042fabc9d0 100644
--- a/ports-mgmt/portbrowser/Makefile
+++ b/ports-mgmt/portbrowser/Makefile
@@ -19,7 +19,7 @@ COMMENT= Graphical frontend for the BSD ports system
USE_GNOME= gtk20
MAKE_ENV= MANDIR=${PREFIX}/man/man \
BINDIR=${PREFIX}/bin \
- NOMANCOMPRESS=YES
+ NO_MANCOMPRESS=YES
CFLAGS+= -DINDEXFILE=\\\"${PORTSDIR}/${INDEXFILE}\\\" \
-DPORTS_DIR=\\\"${PORTSDIR}\\\"
PLIST_FILES= bin/pbrowser
diff --git a/print/enscriptfonts/Makefile b/print/enscriptfonts/Makefile
index 6c6b6aa6add5..1f45e2277b8b 100644
--- a/print/enscriptfonts/Makefile
+++ b/print/enscriptfonts/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= araujo@FreeBSD.org
COMMENT= More than 120 free- and share-ware fonts to extend enscript-1.5
NO_WRKSUBDIR= YES
-NOMANCOMPRESS= YES
+NO_MANCOMPRESS= YES
NO_BUILD= YES
SUB_FILES+= pkg-message
diff --git a/print/perlftlib/Makefile b/print/perlftlib/Makefile
index 7cb692efd6d0..3bca14c4996b 100644
--- a/print/perlftlib/Makefile
+++ b/print/perlftlib/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${SITE_PERL}/jcode.pl:${PORTSDIR}/japanese/jcode.pl
USE_FREETYPE= yes
USE_PERL5= yes
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN1= mkttfdir.1 ftinfo.1
MAN3= FreeType.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/security/qident/Makefile b/security/qident/Makefile
index e40f3c55b1a1..34d7e0459a3c 100644
--- a/security/qident/Makefile
+++ b/security/qident/Makefile
@@ -20,7 +20,7 @@ MAN1= qident.1
MANCOMPRESSED= maybe
# MAN page COMPression SUFFIX
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
MANCOMPSUFFIX= .gz
.else
MANCOMPSUFFIX=
diff --git a/sysutils/dc42wrap/Makefile b/sysutils/dc42wrap/Makefile
index 850ae3435b4c..1287b6ed24ac 100644
--- a/sysutils/dc42wrap/Makefile
+++ b/sysutils/dc42wrap/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Wrap a \"raw\" floppy image as an Apple DiskCopy 4.2 file
MAKEFILE= Makefile,freebsd
-MAKE_ENV= BINDIR=${PREFIX}/bin SHAREDIR=${PREFIX} NOMANCOMPRESS=yes
+MAKE_ENV= BINDIR=${PREFIX}/bin SHAREDIR=${PREFIX} NO_MANCOMPRESS=yes
MAN1= dc42wrap.1
PLIST_FILES= bin/dc42wrap
diff --git a/sysutils/heirloom/Makefile b/sysutils/heirloom/Makefile
index fab37a602b26..53424f81616d 100644
--- a/sysutils/heirloom/Makefile
+++ b/sysutils/heirloom/Makefile
@@ -56,7 +56,7 @@ _M1LINKS= df.1 dfspace.1 \
more.1 page.1 \
pgrep.1 pkill.1 \
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
MANEXT= .gz
.endif
diff --git a/sysutils/readlink/Makefile b/sysutils/readlink/Makefile
index 85b9d5e51665..a3e4be22b6c3 100644
--- a/sysutils/readlink/Makefile
+++ b/sysutils/readlink/Makefile
@@ -19,7 +19,7 @@ MAN1= readlink.1
MANCOMPRESSED= maybe
# MAN page COMPression SUFFIX
-.if !defined(NOMANCOMPRESS)
+.if !defined(NO_MANCOMPRESS)
MANCOMPSUFFIX= .gz
.else
MANCOMPSUFFIX=
diff --git a/sysutils/wmpccard/Makefile b/sysutils/wmpccard/Makefile
index 85f71ad230b8..8724aff4713c 100644
--- a/sysutils/wmpccard/Makefile
+++ b/sysutils/wmpccard/Makefile
@@ -16,7 +16,7 @@ COMMENT= PCcard monitor for FreeBSD + PAO
USE_XORG= x11 xpm
MAN1= wmpccard.1.gz
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
PLIST_FILES= bin/wmpccard
do-install:
diff --git a/textproc/freegrep/files/patch-aa b/textproc/freegrep/files/patch-aa
index b90122ecf5fb..610769dfb00e 100644
--- a/textproc/freegrep/files/patch-aa
+++ b/textproc/freegrep/files/patch-aa
@@ -8,7 +8,7 @@
+DESTDIR= ${PREFIX}
+BINDIR= /bin
+MANDIR= /man/man
-+NOMANCOMPRESS= 1
++NO_MANCOMPRESS= 1
-LDADD= -lz -L/usr/local/lib/ -liberty
+CFLAGS+= -I${LOCALBASE}/include -Wall -pedantic
diff --git a/www/p5-AMF-Perl/Makefile b/www/p5-AMF-Perl/Makefile
index b20affc0c545..0cc0ace372d5 100644
--- a/www/p5-AMF-Perl/Makefile
+++ b/www/p5-AMF-Perl/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Clas
PERL_CONFIGURE= yes
-NOMANCOMPRESS= no
+NO_MANCOMPRESS= no
MAN3= AMF::Perl.3 AMF::Perl::App::Executive.3 \
AMF::Perl::IO::Deserializer.3 AMF::Perl::IO::InputStream.3 \
AMF::Perl::IO::OutputStream.3 AMF::Perl::IO::Serializer.3 \
diff --git a/x11-toolkits/p5-Prima/Makefile b/x11-toolkits/p5-Prima/Makefile
index a55d1ae2c44c..bab4d0b3d919 100644
--- a/x11-toolkits/p5-Prima/Makefile
+++ b/x11-toolkits/p5-Prima/Makefile
@@ -51,7 +51,7 @@ CONFIGURE_SCRIPT= Makefile.PL
USE_XORG= x11 xpm xext xrender
USE_PERL5= yes
MAN3PREFIX= lib/perl5/${PERL_VERSION}
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
post-configure:
@cd ${CONFIGURE_WRKSRC} && ${PERL5} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
diff --git a/x11/chameleon/files/Makefile b/x11/chameleon/files/Makefile
index d0d6666c960d..e462886992a1 100644
--- a/x11/chameleon/files/Makefile
+++ b/x11/chameleon/files/Makefile
@@ -10,7 +10,7 @@ PREFIX?= /usr/X11R6
DESTDIR= ${PREFIX}
BINDIR= /bin
MANDIR= /man/man
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
FILES= cham.xpm
FILESDIR= /share/pixmaps