aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/remmina-plugins/bsd.plugin.mk2
-rw-r--r--net/remmina/Makefile7
2 files changed, 3 insertions, 6 deletions
diff --git a/net/remmina-plugins/bsd.plugin.mk b/net/remmina-plugins/bsd.plugin.mk
index b278e5a67cc7..ca439d19edec 100644
--- a/net/remmina-plugins/bsd.plugin.mk
+++ b/net/remmina-plugins/bsd.plugin.mk
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS+= remmina>=${PORTVERSION}:net/remmina
RUN_DEPENDS+= remmina>=${PORTVERSION}:net/remmina
-USES+= cmake gmake pkgconfig
+USES+= cmake gmake localbase:ldflags pkgconfig
USE_GNOME+= atk gdkpixbuf2 glib20 gtk30 pango
INSTALLS_ICONS= yes
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index 3bcdac8499e2..24bb3ed62d47 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -16,7 +16,7 @@ USE_GITHUB= yes
GH_ACCOUNT= FreeRDP
GH_PROJECT= Remmina
-USES= cmake:outsource gmake pathfix pkgconfig
+USES= cmake:outsource gettext gmake localbase:ldflags pathfix pkgconfig
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
USE_XORG= ice sm x11 xext
PATHFIX_WRKSRC= ${WRKSRC}/remmina
@@ -41,8 +41,7 @@ AVAHI_CMAKE_BOOL= WITH_AVAHI
GCRYPT_LIB_DEPENDS= libgcrypt.so:security/libgcrypt
GCRYPT_CMAKE_BOOL= WITH_GCRYPT
-NLS_USES= gettext localbase
-NLS_CMAKE_BOOL= WITH_GETTEXT
+NLS_CMAKE_BOOL= WITH_TRANSLATIONS
SSH_LIB_DEPENDS= libssh_threads.so:security/libssh
SSH_LDFLAGS= -fstack-protector
@@ -66,7 +65,5 @@ post-patch:
${REINPLACE_CMD} -e's|add_subdirectory(remmina-plugins)||' ${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e's|add_subdirectory(remmina-plugins-gnome)||' ${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e's|add_subdirectory(external_tools)||' ${WRKSRC}/remmina/CMakeLists.txt
-post-patch-NLS-off:
- ${REINPLACE_CMD} -e's|add_subdirectory(po)||' ${WRKSRC}/remmina/CMakeLists.txt
.include <bsd.port.post.mk>