aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/qucs/Makefile1
-rw-r--r--devel/ois/Makefile4
-rw-r--r--games/chromium-bsu/Makefile4
-rw-r--r--games/chromium/Makefile4
-rw-r--r--games/fillets-ng/Makefile4
-rw-r--r--games/hedgewars/Makefile1
-rw-r--r--games/kobodeluxe/Makefile1
-rw-r--r--games/lander/Makefile1
-rw-r--r--games/meritous/Makefile1
-rw-r--r--games/moonlander/Makefile1
-rw-r--r--games/neverball/Makefile4
-rw-r--r--games/qnetwalk/Makefile1
-rw-r--r--games/tetzle/Makefile1
-rw-r--r--games/vegastrike/Makefile1
-rw-r--r--games/xmoto/Makefile1
-rw-r--r--graphics/ftgl/Makefile1
-rw-r--r--graphics/lprof-devel/Makefile1
-rw-r--r--graphics/pngcrush/Makefile4
18 files changed, 25 insertions, 11 deletions
diff --git a/cad/qucs/Makefile b/cad/qucs/Makefile
index dda6344da9c1..19ad5eb6fced 100644
--- a/cad/qucs/Makefile
+++ b/cad/qucs/Makefile
@@ -17,6 +17,7 @@ COMMENT= Graphical circuit design and simulation tool
USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN1= ps2sp.1 qucs.1 qucsator.1 qucsattenuator.1 qucsconv.1 \
qucsdigi.1 qucsedit.1 qucsfilter.1 qucshelp.1 qucslib.1 \
diff --git a/devel/ois/Makefile b/devel/ois/Makefile
index 88acd860e979..715786b65eec 100644
--- a/devel/ois/Makefile
+++ b/devel/ois/Makefile
@@ -9,8 +9,7 @@ PORTNAME= ois
PORTVERSION= 1.2.0
PORTREVISION= 2
CATEGORIES= devel
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= wgois
+MASTER_SITES= SF/whois
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
@@ -22,6 +21,7 @@ USE_GNOME= gnomehack
USE_AUTOTOOLS= libtool:15:env aclocal:19:env autoheader:262:env automake:19:env autoconf:262:env
USE_XORG= x11 xaw
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
diff --git a/games/chromium-bsu/Makefile b/games/chromium-bsu/Makefile
index b31222f39597..7ac1eb098995 100644
--- a/games/chromium-bsu/Makefile
+++ b/games/chromium-bsu/Makefile
@@ -8,8 +8,7 @@
PORTNAME= chromium
PORTVERSION= 0.9.13.3
CATEGORIES= games
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= chromium-bsu
+MASTER_SITES= SF/chromium-bsu
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An arcade-style, top-scrolling space shooter
@@ -22,6 +21,7 @@ GNU_CONFIGURE= yes
USE_GL= gl glu
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
PORTDOCS= *
diff --git a/games/chromium/Makefile b/games/chromium/Makefile
index b31222f39597..7ac1eb098995 100644
--- a/games/chromium/Makefile
+++ b/games/chromium/Makefile
@@ -8,8 +8,7 @@
PORTNAME= chromium
PORTVERSION= 0.9.13.3
CATEGORIES= games
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= chromium-bsu
+MASTER_SITES= SF/chromium-bsu
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An arcade-style, top-scrolling space shooter
@@ -22,6 +21,7 @@ GNU_CONFIGURE= yes
USE_GL= gl glu
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
PORTDOCS= *
diff --git a/games/fillets-ng/Makefile b/games/fillets-ng/Makefile
index f11c7e223409..b6341430257c 100644
--- a/games/fillets-ng/Makefile
+++ b/games/fillets-ng/Makefile
@@ -8,8 +8,7 @@
PORTNAME= fillets-ng
PORTVERSION= 0.8.1
CATEGORIES= games
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= fillets
+MASTER_SITES= SF/fillets
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
${PORTNAME}-data-${DATAVERSION}${EXTRACT_SUFX}
DIST_SUBDIR= fillets-ng
@@ -21,6 +20,7 @@ USE_SDL= sdl mixer image ttf
USE_LUA= 5.1
USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LUA_INCDIR}" LDFLAGS="-L${LUA_LIBDIR}"
CONFIGURE_ARGS= --datadir="${DATADIR}" --with-lua="${LOCALBASE}"
diff --git a/games/hedgewars/Makefile b/games/hedgewars/Makefile
index f882d9dda000..ae4b743c24d8 100644
--- a/games/hedgewars/Makefile
+++ b/games/hedgewars/Makefile
@@ -25,6 +25,7 @@ USE_SDL= sdl mixer image ttf net
USE_FPC= opengl
USE_QT_VER= 4
QT_COMPONENTS= corelib gui moc_build network qmake_build rcc_build svg xml
+MAKE_JOBS_SAFE= yes
post-patch:
${ECHO} "include_directories(${LOCALBASE}/include)" >> \
diff --git a/games/kobodeluxe/Makefile b/games/kobodeluxe/Makefile
index 2be8501f09a5..0acdba4c3455 100644
--- a/games/kobodeluxe/Makefile
+++ b/games/kobodeluxe/Makefile
@@ -20,6 +20,7 @@ USE_BZIP2= yes
USE_SDL= image sdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sharedstatedir=${SCOREDIR} --enable-oss
+MAKE_JOBS_SAFE= yes
MAN6= kobodl.6
diff --git a/games/lander/Makefile b/games/lander/Makefile
index b77fac6fe5cc..1ad22d386053 100644
--- a/games/lander/Makefile
+++ b/games/lander/Makefile
@@ -20,6 +20,7 @@ GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_SDL= sdl image mixer
USE_GL= gl glu
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
diff --git a/games/meritous/Makefile b/games/meritous/Makefile
index af8f743de10f..698d82e93a1b 100644
--- a/games/meritous/Makefile
+++ b/games/meritous/Makefile
@@ -21,6 +21,7 @@ USE_GMAKE= yes
USE_SDL= sdl mixer image
ALL_TARGET= default
USE_DOS2UNIX= dat/d/helpfile.txt
+MAKE_JOBS_SAFE= yes
PORTDOCS= *
diff --git a/games/moonlander/Makefile b/games/moonlander/Makefile
index 158799300592..21f80f2bd3cb 100644
--- a/games/moonlander/Makefile
+++ b/games/moonlander/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Land a spacecraft on the moon
USE_SDL= mixer image sdl
+MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/moon-lander
diff --git a/games/neverball/Makefile b/games/neverball/Makefile
index 01405eb7c8c0..252dd797da3d 100644
--- a/games/neverball/Makefile
+++ b/games/neverball/Makefile
@@ -9,7 +9,8 @@ PORTNAME= neverball
PORTVERSION= 1.5.0
CATEGORIES= games
MASTER_SITES= http://offload1.icculus.org:9090/neverball/ \
- http://offload2.icculus.org:9090/neverball/
+ http://offload2.icculus.org:9090/neverball/ \
+ http://mirror.amdmi3.ru/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Tilt the floor to guide a ball through an obstacle course
@@ -22,6 +23,7 @@ USE_GL= gl
USE_SDL= ttf
USE_GMAKE= yes
MAKE_ENV+= ENABLE_WII=0
+MAKE_JOBS_SAFE= yes
DOCS= CHANGES COPYING README
MAN6= neverball.6 neverputt.6
diff --git a/games/qnetwalk/Makefile b/games/qnetwalk/Makefile
index 7af79b59efe4..5d3c28b92c23 100644
--- a/games/qnetwalk/Makefile
+++ b/games/qnetwalk/Makefile
@@ -16,6 +16,7 @@ COMMENT= Qt-version of the NetWalk game
USE_QT_VER= 4
QT_COMPONENTS= corelib gui qmake_build moc_build rcc_build
+MAKE_JOBS_SAFE= yes
MAN6= qnetwalk.6
diff --git a/games/tetzle/Makefile b/games/tetzle/Makefile
index 7747d40dc0d4..831a8e814a2c 100644
--- a/games/tetzle/Makefile
+++ b/games/tetzle/Makefile
@@ -20,6 +20,7 @@ USE_QT_VER= 4
QT_COMPONENTS= corelib gui moc_build opengl qmake_build rcc_build xml
WANT_GNOME= yes
INSTALLS_ICONS= yes
+MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index d8146acf3451..60574c1aedac 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -31,6 +31,7 @@ USE_GNOME= gtk20
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_JOBS_SAFE= yes
# cegui and ffmpeg are not used yet
CONFIGURE_ARGS= --disable-cegui --disable-ffmpeg \
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 4dd767a74a3e..6bcc28f77f3c 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -29,6 +29,7 @@ USE_SQLITE= 3
USE_SDL= sdl mixer ttf net
USE_GL= gl glu
USE_DOS2UNIX= src/*.cpp src/*.h
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include -I${LUA_INCDIR}
diff --git a/graphics/ftgl/Makefile b/graphics/ftgl/Makefile
index d1d29ab7252b..dc5219918ce3 100644
--- a/graphics/ftgl/Makefile
+++ b/graphics/ftgl/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ARGS= --with-gl-inc="${LOCALBASE}/include" \
--without-glut-inc
USE_GNOME= gnomehack
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S/-/~/}
diff --git a/graphics/lprof-devel/Makefile b/graphics/lprof-devel/Makefile
index 77250649ceb7..6adb1951fb73 100644
--- a/graphics/lprof-devel/Makefile
+++ b/graphics/lprof-devel/Makefile
@@ -26,6 +26,7 @@ USE_XORG= x11 xext sm ice xxf86vm
USE_QT_VER= 4
QT_COMPONENTS= corelib gui qt3support assistantclient linguist_build qmake_build moc_build uic_build rcc_build
USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
CMAKE_ARGS= -DQTTRANS_LRELEASE_EXECUTABLE="${LOCALBASE}/bin/lrelease-qt4"
CMAKE_USE_PTHREAD= yes
diff --git a/graphics/pngcrush/Makefile b/graphics/pngcrush/Makefile
index 71c2d62dc71e..1b891ddf7881 100644
--- a/graphics/pngcrush/Makefile
+++ b/graphics/pngcrush/Makefile
@@ -8,8 +8,7 @@
PORTNAME= pngcrush
PORTVERSION= 1.6.15
CATEGORIES= graphics
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= pmt
+MASTER_SITES= SF/pmt
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An optimizer for PNG files
@@ -17,6 +16,7 @@ COMMENT= An optimizer for PNG files
USE_BZIP2= yes
USE_GMAKE= yes
MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}" LD="${CC}"
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/pngcrush