aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.ldap.mk2
-rw-r--r--UPDATING17
-rw-r--r--net/openldap24-client/Makefile7
-rw-r--r--net/openldap24-sasl-client/Makefile9
-rw-r--r--net/openldap24-server/Makefile46
5 files changed, 47 insertions, 34 deletions
diff --git a/Mk/bsd.ldap.mk b/Mk/bsd.ldap.mk
index ca978ebbd479..b99bd729d59f 100644
--- a/Mk/bsd.ldap.mk
+++ b/Mk/bsd.ldap.mk
@@ -23,6 +23,8 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# Default: 24.
# WANT_OPENLDAP_VER
# - Maintainer can set an arbitrary version of OpenLDAP by using it.
+# WANT_OPENLDAP_SASL
+# - If set, this port depends on SASL enabled OpenLDAP client.
# IGNORE_OPENLDAP_OPENLDAP
# - This variable can be defined if the ports doesn't support
# one or more version of OpenLDAP.
diff --git a/UPDATING b/UPDATING
index d28097570381..cb2dc1b406fb 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,23 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20121212:
+ AFFECTS: users of openldap24-client who uses SASL
+ AUTHOR: Xin Li <delphij@FreeBSD.org>
+
+ There is a change in the openldap24-client port which removes the SASL
+ option. If the user previously install openldap24-client, but enabled
+ SASL from the config menu, the user would have to replace it with
+ openldap24-sasl-client.
+
+ Note that this only affects those who manually set SASL from the menu,
+ most of the users are not affected.
+
+ If you use portmaster:
+ portmaster -o net/openldap24-sasl-client openldap24-client
+ If you use portupgrade:
+ portupgrade -fo net/openldap24-sasl-client openldap24-client
+
+20121212:
AFFECTS: users of horde-* applications
AUTHOR: Martin Matuska <mm@FreeBSD.org>
diff --git a/net/openldap24-client/Makefile b/net/openldap24-client/Makefile
index e4024a08ff18..c83ba8fbb5d0 100644
--- a/net/openldap24-client/Makefile
+++ b/net/openldap24-client/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: openldap24-client
-# Date created: 19 May 2006
-# Whom: Xin LI <delphij@FreeBSD.org>
-#
+# Created by: Xin LI <delphij@FreeBSD.org>
# $FreeBSD$
-#
CLIENT_ONLY= yes
-WITHOUT_SASL= yes
MASTERDIR= ${.CURDIR}/../openldap24-server
diff --git a/net/openldap24-sasl-client/Makefile b/net/openldap24-sasl-client/Makefile
index 18c63f04190b..9f6339acdf7d 100644
--- a/net/openldap24-sasl-client/Makefile
+++ b/net/openldap24-sasl-client/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: openldap24-sasl-client
-# Date created: 19 May 2006
-# Whom: Xin LI <delphij@FreeBSD.org>
-#
+# Created by: Xin LI <delphij@FreeBSD.org>
# $FreeBSD$
-#
-CLIENT_ONLY= yes
-WITH_SASL= yes
+CLIENT_ONLY= sasl
MASTERDIR= ${.CURDIR}/../openldap24-server
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index c7b84c7774af..d05e61ad165b 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openldap24-server
-# Date created: 19 May 2006
-# Whom: Xin LI <delphij@FreeBSD.org>
-#
+# Created by: Xin LI <delphij@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= openldap
DISTVERSION= 2.4.33
@@ -17,7 +13,24 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.nl.uu.net/pub/unix/db/openldap/%SUBDIR%/ \
ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/%SUBDIR%/
MASTER_SITE_SUBDIR= openldap-release
+
+.if defined(CLIENT_ONLY)
+.if ${CLIENT_ONLY} == sasl
+PKGNAMESUFFIX= -sasl-client
+COMMENT= Open source LDAP client implementation with SASL2 support
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[!4].*
+.else
+PKGNAMESUFFIX= -client
+COMMENT= Open source LDAP client implementation
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[!4].* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
+.endif
+.else
PKGNAMESUFFIX?= -server
+# Do not use ${PKGNAMESUFFIX} here has it can change later
+OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}24-server/options
+.endif
EXTRACT_SUFX= .tgz
MAINTAINER= delphij@FreeBSD.org
@@ -46,9 +59,8 @@ PORTREVISION_CLIENT= 1
PORTREVISION_SERVER= 1
OPENLDAP_SHLIB_MAJOR= 8
-OPTIONS_DEFINE= SASL FETCH
+OPTIONS_DEFINE= FETCH
-SASL_DESC= With (Cyrus) SASL2 support
FETCH_DESC= Enable fetch(3) support
.if !defined(CLIENT_ONLY)
@@ -57,7 +69,7 @@ OPTIONS_DEFINE+= SOCK ODBC RLOOKUPS SLP SLAPI TCP_WRAPPERS
OPTIONS_DEFINE+= ACCESSLOG AUDITLOG COLLECT CONSTRAINT DDS
OPTIONS_DEFINE+= DEREF DYNGROUP DYNLIST MEMBEROF PPOLICY PROXYCACHE
OPTIONS_DEFINE+= REFINT RETCODE RWM SEQMOD SSSVLV SYNCPROV TRANSLUCENT
-OPTIONS_DEFINE+= UNIQUE VALSORT SMBPWD DYNAMIC_BACKENDS
+OPTIONS_DEFINE+= UNIQUE VALSORT SMBPWD DYNAMIC_BACKENDS SASL
OPTIONS_DEFAULT= BDB TCP_WRAPPERS SEQMOD SYNCPROV DYNAMIC_BACKENDS
@@ -90,6 +102,7 @@ PROXYCACHE_DESC= With Proxy Cache overlay
REFINT_DESC= With Referential Integrity overlay
RETCODE_DESC= With Return Code testing overlay
RWM_DESC= With Rewrite/Remap overlay
+SASL_DESC= With (Cyrus) SASL2 support
SEQMOD_DESC= With Sequential Modify overlay
SSSVLV_DESC= With ServerSideSort/VLV overlay
SYNCPROV_DESC= With Syncrepl Provider overlay
@@ -112,21 +125,12 @@ CONFIGURE_SED= -e 's,-kthread,${PTHREAD_LIBS},g' -e 's,uuid/uuid.h,xxuuid/uuid.
.include <bsd.port.pre.mk>
-.if defined(CLIENT_ONLY)
-.if ${PORT_OPTIONS:MSASL}
-PKGNAMESUFFIX= -sasl-client
-COMMENT= Open source LDAP client implementation with SASL2 support
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
- ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[!4].*
-.else
-PKGNAMESUFFIX= -client
-COMMENT= Open source LDAP client implementation
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[!4].* \
- ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
-.endif
-
PORTDOCS= CHANGES drafts rfc
+.if defined(CLIENT_ONLY)
+.if ${CLIENT_ONLY} == sasl
+PORT_OPTIONS+= SASL
+.endif
.if defined(USE_OPENLDAP)
BROKEN= You have `USE_OPENLDAP' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif