aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/quaqut/Makefile33
-rw-r--r--games/quaqut/distinfo3
-rw-r--r--games/quaqut/files/patch-display.c13
-rw-r--r--games/quaqut/files/quaqut.in33
-rw-r--r--games/quaqut/pkg-descr6
6 files changed, 89 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e4aff63f05e6..151fb5b914e3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -597,6 +597,7 @@
SUBDIR += quake3
SUBDIR += quake3-data
SUBDIR += quakeforge
+ SUBDIR += quaqut
SUBDIR += qudos
SUBDIR += quetoo
SUBDIR += quit
diff --git a/games/quaqut/Makefile b/games/quaqut/Makefile
new file mode 100644
index 000000000000..7da4820099f9
--- /dev/null
+++ b/games/quaqut/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: quaqut
+# Date created: 19 October 2006
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quaqut
+PORTVERSION= 0.2.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Queries information from Unreal Tournament 2004 game servers
+
+HAS_CONFIGURE= yes
+USE_RC_SUBR= ${PORTNAME}
+MAN1= ${PORTNAME}.1
+PORTDOCS= AUTHORS COPYING ChangeLog README
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/quaqut/distinfo b/games/quaqut/distinfo
new file mode 100644
index 000000000000..f192ad035ccd
--- /dev/null
+++ b/games/quaqut/distinfo
@@ -0,0 +1,3 @@
+MD5 (quaqut-0.2.0.tar.gz) = eed70af25d2e0255363858d416c8d70f
+SHA256 (quaqut-0.2.0.tar.gz) = 0eb16c36599922c316ccf690428408ec6a0e2c0d1060e01d192d2faf98d4c1e1
+SIZE (quaqut-0.2.0.tar.gz) = 299205
diff --git a/games/quaqut/files/patch-display.c b/games/quaqut/files/patch-display.c
new file mode 100644
index 000000000000..e77ea7166e26
--- /dev/null
+++ b/games/quaqut/files/patch-display.c
@@ -0,0 +1,13 @@
+--- src/display.c.orig Tue Sep 28 22:49:58 2004
++++ src/display.c Thu Oct 19 17:50:41 2006
+@@ -122,7 +122,9 @@
+
+ if ( quaqut.options & QUAQUT_OPTION_LOGFILE )
+ fclose(destination);
+-
++ else
++ fflush(stdout);
++
+ return 1;
+ }
+
diff --git a/games/quaqut/files/quaqut.in b/games/quaqut/files/quaqut.in
new file mode 100644
index 000000000000..193cc2c6176f
--- /dev/null
+++ b/games/quaqut/files/quaqut.in
@@ -0,0 +1,33 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: quaqut
+# REQUIRE: NETWORKING
+#
+# Add the following line to /etc/rc.conf[.local] to enable quaqut
+#
+# quaqut_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable quaqut.
+# quaqut_host (str): Server hostname.
+# quaqut_logfile (str): Logfile name.
+# quaqut_interval (number): Query interval duration.
+# It must be a number between 10 and 9999.
+#
+
+. %%RC_SUBR%%
+
+name="quaqut"
+rcvar=${name}_enable
+
+load_rc_config $name
+
+: ${quaqut_enable="NO"}
+: ${quaqut_host="some.ut2004server.tld"}
+: ${quaqut_logfile="/var/log/quaqut.log"}
+: ${quaqut_interval="10"}
+
+command="/usr/local/bin/quaqut"
+command_args="-d ${quaqut_interval} ${quaqut_flags} ${quaqut_host} >> ${quaqut_logfile} &"
+
+run_rc_command "$1"
diff --git a/games/quaqut/pkg-descr b/games/quaqut/pkg-descr
new file mode 100644
index 000000000000..84ace81dc19e
--- /dev/null
+++ b/games/quaqut/pkg-descr
@@ -0,0 +1,6 @@
+Quaqut is a simple program that queries Unreal Tournament 2004 (TM)
+game servers and retrieves information like those available while
+browsing servers in the game. That means information like server
+name, game type and current map, names and scores of players, and much more.
+
+WWW: http://quaqut.sourceforge.net/