aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/wxmupen64plus/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/emulators/wxmupen64plus/Makefile b/emulators/wxmupen64plus/Makefile
index d52b809f1622..ab6a0b14427f 100644
--- a/emulators/wxmupen64plus/Makefile
+++ b/emulators/wxmupen64plus/Makefile
@@ -13,6 +13,8 @@ DIST_SUBDIR= ${PORTNAME:S/wx//}
MAINTAINER= acm@FreeBSD.org
COMMENT= Mupen64Plus 2.0 GUI frontend written using wxWidgets
+BROKEN_FreeBSD_8= does not build: lack of long long support
+
LIB_DEPENDS= libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core
RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:${PORTSDIR}/emulators/mupen64plus-audio-sdl \
@@ -22,7 +24,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64p
mupen64plus:${PORTSDIR}/emulators/mupen64plus-ui-console
PROJECTHOST= bsdistfiles
-USES= python
+USES= compiler:c++11-lib python
+USE_CXXSTD= c++11
USE_SDL= yes
USE_WX= 3.0
WX_UNICODE= yes