aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/spass/Makefile26
-rw-r--r--security/spass/distinfo3
-rw-r--r--security/spass/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e905ffaa54fc..f14979e09ad2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -808,6 +808,7 @@
SUBDIR += snortsms
SUBDIR += snortsnarf
SUBDIR += softhsm
+ SUBDIR += spass
SUBDIR += spike-proxy
SUBDIR += spybye
SUBDIR += sqlmap
diff --git a/security/spass/Makefile b/security/spass/Makefile
new file mode 100644
index 000000000000..bffbb2ab655b
--- /dev/null
+++ b/security/spass/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: spass
+# Date created: 27 October 2010
+# Whom: Eitan Adler <ports@eitanadler.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spass
+PORTVERSION= 2.0
+CATEGORIES= security
+MASTER_SITES= http://www.guyrutenberg.com/wp-content/uploads/2010/08/
+
+MAINTAINER= ports@eitanadler.com
+COMMENT= A secure password generator with a true random number generator
+
+LIB_DEPENDS= boost_program_options:${PORTSDIR}/devel/boost-libs
+
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+USE_BZIP2= yes
+
+PLIST_FILES= bin/spass
+
+.include <bsd.port.mk>
diff --git a/security/spass/distinfo b/security/spass/distinfo
new file mode 100644
index 000000000000..29cb0c80e149
--- /dev/null
+++ b/security/spass/distinfo
@@ -0,0 +1,3 @@
+MD5 (spass-2.0.tar.bz2) = 19b8a964100c9f4f126dbce5d338a4b9
+SHA256 (spass-2.0.tar.bz2) = 9dcda4c68f635e71fb23a2971c8fca2e2b1fbc5ee602c6182fa06155281e1d58
+SIZE (spass-2.0.tar.bz2) = 76762
diff --git a/security/spass/pkg-descr b/security/spass/pkg-descr
new file mode 100644
index 000000000000..f4d4dc770bb3
--- /dev/null
+++ b/security/spass/pkg-descr
@@ -0,0 +1,3 @@
+spass is a random password generator written by Guy Rutenberg
+
+WWW: http://www.guyrutenberg.com/2010/08/13/statistical-tests-for-my-audio-based-random-number-generator/