aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/utf8proc/Makefile28
-rw-r--r--textproc/utf8proc/distinfo3
-rw-r--r--textproc/utf8proc/files/patch-Makefile11
-rw-r--r--textproc/utf8proc/pkg-descr9
-rw-r--r--textproc/utf8proc/pkg-plist5
6 files changed, 57 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3081d5a81c8c..5ca9f7d8a54d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -986,6 +986,7 @@
SUBDIR += unroff
SUBDIR += unrtf
SUBDIR += urlview
+ SUBDIR += utf8proc
SUBDIR += uz-aspell
SUBDIR += vbindiff
SUBDIR += wa-aspell
diff --git a/textproc/utf8proc/Makefile b/textproc/utf8proc/Makefile
new file mode 100644
index 000000000000..bcb25f05d55d
--- /dev/null
+++ b/textproc/utf8proc/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: utf8proc
+# Date created: 2007-10-15
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= utf8proc
+PORTVERSION= 1.1.2
+CATEGORIES= textproc devel
+MASTER_SITES= http://www.flexiguided.de/pub/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= UTF-8 processing library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= c-library
+
+USE_LDCONFIG= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/libutf8proc.so ${PREFIX}/lib/libutf8proc.so.1
+ ${INSTALL_DATA} ${WRKSRC}/libutf8proc.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/utf8proc.h ${PREFIX}/include
+ ${LN} -sf ${PREFIX}/lib/libutf8proc.so.0 ${PREFIX}/lib/libutf8proc.so
+
+.include <bsd.port.mk>
diff --git a/textproc/utf8proc/distinfo b/textproc/utf8proc/distinfo
new file mode 100644
index 000000000000..be3c00106195
--- /dev/null
+++ b/textproc/utf8proc/distinfo
@@ -0,0 +1,3 @@
+MD5 (utf8proc-v1.1.2.tar.gz) = 28dc73f8f8b479318b08576a0d28c3d2
+SHA256 (utf8proc-v1.1.2.tar.gz) = d9b8b5e35971da03f397af6ab56a7c37f26a1e48b171cb02c19584fe069a77d0
+SIZE (utf8proc-v1.1.2.tar.gz) = 283391
diff --git a/textproc/utf8proc/files/patch-Makefile b/textproc/utf8proc/files/patch-Makefile
new file mode 100644
index 000000000000..b69166638c65
--- /dev/null
+++ b/textproc/utf8proc/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2007-07-22 14:53:03.000000000 +0800
++++ Makefile 2007-10-15 10:43:18.000000000 +0800
+@@ -4,7 +4,7 @@
+ # settings
+
+ cflags = -O2 -std=c99 -pedantic -Wall -fpic $(CFLAGS)
+-cc = gcc $(cflags)
++cc = $(CC) $(cflags)
+
+
+ # meta targets
diff --git a/textproc/utf8proc/pkg-descr b/textproc/utf8proc/pkg-descr
new file mode 100644
index 000000000000..8d1fa4f83d03
--- /dev/null
+++ b/textproc/utf8proc/pkg-descr
@@ -0,0 +1,9 @@
+utf8proc is a library for processing UTF-8 encoded Unicode strings.
+Some features are Unicode normalization, stripping of default ignorable
+characters, case folding and detection of grapheme cluster boundaries.
+A special character mapping is available, which converts for example the
+characters "Hyphen" (U+2010), "Minus" (U+2212) and
+"Hyphen-Minus" (U+002D, ASCII Minus) all into the ASCII minus sign, to
+make them equal for comparisons.
+
+WWW: http://www.flexiguided.de/publications.utf8proc.en.html
diff --git a/textproc/utf8proc/pkg-plist b/textproc/utf8proc/pkg-plist
new file mode 100644
index 000000000000..852a806e97b0
--- /dev/null
+++ b/textproc/utf8proc/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+include/utf8proc.h
+lib/libutf8proc.a
+lib/libutf8proc.so
+lib/libutf8proc.so.1