aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/quickcheck++/Makefile5
-rw-r--r--japanese/mailman/Makefile59
-rw-r--r--japanese/rubygem-jpmobile/Makefile15
-rw-r--r--misc/rabbit/Makefile11
-rw-r--r--net-im/mikutter/Makefile19
-rw-r--r--net-im/mikutter003/Makefile19
-rw-r--r--www/testlink/Makefile27
7 files changed, 77 insertions, 78 deletions
diff --git a/devel/quickcheck++/Makefile b/devel/quickcheck++/Makefile
index 727977226435..0f695008fbef 100644
--- a/devel/quickcheck++/Makefile
+++ b/devel/quickcheck++/Makefile
@@ -26,11 +26,12 @@ NO_BUILD= yes
PORTDOCS= COPYRIGHT README
PORTEXAMPLES= examples.cc
-OPTIONS= DOXYGEN "Build documentation with doxygen" off
+OPTIONS_DEFINE= DOXYGEN
+DOXYGEN_DESC= Build documentation with doxygen
.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
+.if !defined(NOPORTDOCS) && ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
PORTDOCS+= html
diff --git a/japanese/mailman/Makefile b/japanese/mailman/Makefile
index 617eb71b76ae..880887112c0e 100644
--- a/japanese/mailman/Makefile
+++ b/japanese/mailman/Makefile
@@ -69,46 +69,37 @@ PORTDOCS= ACKNOWLEDGMENTS BUGS FAQ INSTALL NEWS NEWS.japan.utf-8 \
mailman-member.txt \
FreeBSD-post-install-notes
-OPTIONS= SENDMAIL "for use with sendmail" off \
- EXIM3 "for use with exim3" off \
- EXIM4 "for use with exim4" off \
- POSTFIX "for use with postfix" off \
- COURIER "for use with courier" off \
- INTEGRATION "integrating postfix and mailman" off \
- NAMAZU2 "make private archives searchable with namazu2" off
+OPTIONS_DEFINE= INTEGRATION NAMAZU2
+
+OPTIONS_SINGLE= MTA
+OPTIONS_SINGLE_MTA= SENDMAIL EXIM3 EXIM4 POSTFIX COURIER
+
+INTEGRATION_DESC= integrating postfix and mailman
+NAMAZU2_DESC= make private archives searchable with namazu2
+SENDMAIL_DESC= for use with sendmail
+EXIM3_DESC= for use with exim3
+EXIM4_DESC= for use with exim4
+POSTFIX_DESC= for use with postfix
+COURIER_DESC= for use with courier
+
+OPTIONS_DEFAULT= SENDMAIL
.include <bsd.port.options.mk>
-.if defined(WITH_SENDMAIL)
-.if defined(WITH_EXIM3) || defined(WITH_EXIM4) || defined(WITH_POSTFIX) || \
-defined(WITH_COURIER)
-IGNORE= can only have one MTA selected to integrate with
-.endif
+.if ${PORT_OPTIONS:MSENDMAIL}
MAIL_GID?= mailnull
.endif
-.if defined(WITH_EXIM3)
-.if defined(WITH_SENDMAIL) || defined(WITH_EXIM4) || defined(WITH_POSTFIX) || \
-defined(WITH_COURIER)
-IGNORE= can only have one MTA selected to integrate with
-.endif
+.if ${PORT_OPTIONS:MEXIM3}
MAIL_GID?= nobody
.endif
-.if defined(WITH_EXIM4)
-.if defined(WITH_SENDMAIL) || defined(WITH_EXIM3) || defined(WITH_POSTFIX) || \
-defined(WITH_COURIER)
-IGNORE= can only have one MTA selected to integrate with
-.endif
+.if ${PORT_OPTIONS:MEXIM4}
MAIL_GID?= mail
.endif
-.if defined(WITH_POSTFIX)
-.if defined(WITH_SENDMAIL) || defined(WITH_EXIM3) || defined(WITH_EXIM4) || \
-defined(WITH_COURIER)
-IGNORE= can only have one MTA selected to integrate with
-.endif
-.if defined(WITH_INTEGRATION)
+.if ${PORT_OPTIONS:MPOSTFIX}
+.if ${PORT_OPTIONS:MINTEGRATION}
MAIL_GID?= mailman
.else
MAIL_GID?= nobody
@@ -116,15 +107,11 @@ MAIL_GID?= nobody
EXTRA_PATCHES+= ${FILESDIR}/postfix-verp.diff
.endif
-.if defined(WITH_COURIER)
-.if defined(WITH_SENDMAIL) || defined(WITH_EXIM3) || defined(WITH_EXIM4) || \
-defined(WITH_POSTFIX)
-IGNORE= can only have one MTA selected to integrate with
-.endif
+.if ${PORT_OPTIONS:MCOURIER}
MAIL_GID?= courier
.endif
-.if defined(WITH_NAMAZU2)
+.if ${PORT_OPTIONS:MNAMAZU2}
RUN_DEPENDS+= mknmz:${PORTSDIR}/japanese/namazu2
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Mailman-Cgi-private.py
.endif
@@ -149,7 +136,7 @@ post-patch:
pre-configure:
@${ECHO} "DEFAULT_SERVER_LANGUAGE = 'ja'" >> ${WRKSRC}/Mailman/mm_cfg.py.dist.in
@${ECHO} "GLOBAL_PIPELINE.insert(1, 'iso2022jpfix')" >> ${WRKSRC}/Mailman/mm_cfg.py.dist.in
-.if defined(WITH_POSTFIX) && defined(WITH_INTEGRATION)
+.if ${PORT_OPTIONS:MPOSTFIX} && ${PORT_OPTIONS:MINTEGRATION}
@${ECHO} "MTA = 'Postfix'" >> ${WRKSRC}/Mailman/mm_cfg.py.dist.in
.endif
@@ -175,7 +162,7 @@ post-install:
.endif
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.if defined(WITH_POSTFIX)
+.if ${PORT_OPTIONS:MPOSTFIX}
@if [ "x`${LOCALBASE}/sbin/postconf -h myhostname`" != "xlocalhost" ]; then \
${ECHO_CMD} ""; \
${ECHO_CMD} "Your Postfix hostname is non-default."; \
diff --git a/japanese/rubygem-jpmobile/Makefile b/japanese/rubygem-jpmobile/Makefile
index 0e538c8c783b..9c6dc53cc96d 100644
--- a/japanese/rubygem-jpmobile/Makefile
+++ b/japanese/rubygem-jpmobile/Makefile
@@ -21,23 +21,26 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-OPTIONS= GEOKIT "Run with geokit" Off \
- IPADDRESSES "IP address validation support" On \
- TERMINFO "terminal information support" On
+OPTIONS_DEFINE= GEOKIT IPADDRESSES TERMINFO
+GEOKIT_DESC= Run with geokit
+IPADDRESSES_DESC= IP address validation support
+TERMINFO_DESC= terminal information support
+
+OPTIONS_DEFAULT= IPADDRESSES TERMINFO
.include <bsd.port.pre.mk>
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}rubygem-
-.if !defined(WITHOUT_GEOKIT)
+.if ${PORT_OPTIONS:MGEOKIT}
RUN_DEPENDS+= rubygem-geokit>=1.5.0:${PORTSDIR}/graphics/rubygem-geokit
.endif
-.if defined(WITH_IPADDRESSES)
+.if ${PORT_OPTIONS:MIPADDRESSES}
RUN_DEPENDS+= ja-rubygem-jpmobile-ipaddresses>=0.0.1:${PORTSDIR}/japanese/rubygem-jpmobile-ipaddresses
.endif
-.if defined(WITH_TERMINFO)
+.if ${PORT_OPTIONS:MTERMINFO}
RUN_DEPENDS+= ja-rubygem-jpmobile-terminfo>=0.0.2:${PORTSDIR}/japanese/rubygem-jpmobile-terminfo
.endif
diff --git a/misc/rabbit/Makefile b/misc/rabbit/Makefile
index b7f25ed741f0..fcc6cdb92602 100644
--- a/misc/rabbit/Makefile
+++ b/misc/rabbit/Makefile
@@ -52,16 +52,17 @@ PORTDOCS= *
PORTEXAMPLES= *
PORTDATA= *
-OPTIONS= MIMETEX "Run with mimetex" off \
- TWITTER "Run with Twitter" off
+OPTIONS_DEFAULT= MIMETEX TWITTER
+MIMETEX_DESC= Run with mimetex
+TWITTER_DESC= Run with Twitter
.include <bsd.port.options.mk>
-.if defined(WITH_MIMETEX)
+.if ${PORT_OPTIONS:MMIMETEX}
RUN_DEPENDS+= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:${PORTSDIR}/www/mimetex
.endif
-.if defined(WITH_TWITTER)
+.if ${PORT_OPTIONS:MTWITTER}
RUN_DEPENDS+= rubygem-twitter_oauth>=0:${PORTSDIR}/security/rubygem-twitter_oauth \
rubygem-twitter-stream>=0:${PORTSDIR}/net/rubygem-twitter-stream
.endif
@@ -73,7 +74,7 @@ post-patch:
${RUBY} -i -pe 'sub %r|(require "hikidoc")|, %Q|require "rubygems"\n\\1|' ${WRKSRC}/lib/rabbit/parser/wiki.rb
${RUBY} -i -pe "sub %r|((\s*)require 'twitter_oauth')|, %Q|\\\2require 'rubygems'\n\\\1|" ${WRKSRC}/lib/rabbit/twitter.rb
${RUBY} -i -pe "sub %r|(require 'coderay')|, %Q|require 'rubygems'\n\\\1|" ${WRKSRC}/lib/rabbit/parser/ext/coderay.rb
-.if defined(WITH_MIMETEX)
+.if ${PORT_OPTIONS:MMIMETEX}
${REINPLACE_CMD} -e 's|"mimetex.cgi"|"${PREFIX}/www/mimetex/cgi-bin/mimetex.cgi"|' \
${WRKSRC}/lib/rabbit/parser/ext/tex.rb
.endif
diff --git a/net-im/mikutter/Makefile b/net-im/mikutter/Makefile
index 6ac10ff6192b..987e7676c0b1 100644
--- a/net-im/mikutter/Makefile
+++ b/net-im/mikutter/Makefile
@@ -45,19 +45,22 @@ SUB_LIST= RUBY_SITELIBDIR=${RUBY_SITELIBDIR}
PORTDOCS= README
PORTSCOUT= limit:^0\.0\.3\.[0-9]*
-OPTIONS= NOTIFY "notify-send support" on \
- HTTPCLIENT "httpclient support" on
+OPTIONS_DEFINE= HTTPCLIENT NOTIFY
+HTTPCLIENT_DESC= httpclient support
+NOTIFY_DESC= notify-send support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-.if defined(WITH_NOTIFY)
-RUN_DEPENDS+= notify-send:${PORTSDIR}/devel/libnotify
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITH_HTTPCLIENT)
+.if ${PORT_OPTIONS:MHTTPCLIENT}
RUN_DEPENDS+= rubygem-httpclient>=0:${PORTSDIR}/www/rubygem-httpclient
.endif
+.if ${PORT_OPTIONS:MNOTIFY}
+RUN_DEPENDS+= notify-send:${PORTSDIR}/devel/libnotify
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "50s|chdir\(.*\)|chdir\('${RUBY_SITELIBDIR}/mikutter/core'\)|" \
${WRKSRC}/mikutter.rb
@@ -89,4 +92,4 @@ x-generate-plist:
${ECHO} @exec ${MKDIR:S|/bin/||} %D/%%RUBY_SITELIBDIR%%/mikutter/core/hatsunelisp >> pkg-plist.new
${FIND} ${RUBY_SITELIBDIR}/mikutter -type d -depth | ${SORT} -r | ${SED} -e 's,${RUBY_SITELIBDIR},@dirrm %%RUBY_SITELIBDIR%%,' >> pkg-plist.new
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/mikutter003/Makefile b/net-im/mikutter003/Makefile
index 6ac10ff6192b..987e7676c0b1 100644
--- a/net-im/mikutter003/Makefile
+++ b/net-im/mikutter003/Makefile
@@ -45,19 +45,22 @@ SUB_LIST= RUBY_SITELIBDIR=${RUBY_SITELIBDIR}
PORTDOCS= README
PORTSCOUT= limit:^0\.0\.3\.[0-9]*
-OPTIONS= NOTIFY "notify-send support" on \
- HTTPCLIENT "httpclient support" on
+OPTIONS_DEFINE= HTTPCLIENT NOTIFY
+HTTPCLIENT_DESC= httpclient support
+NOTIFY_DESC= notify-send support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-.if defined(WITH_NOTIFY)
-RUN_DEPENDS+= notify-send:${PORTSDIR}/devel/libnotify
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITH_HTTPCLIENT)
+.if ${PORT_OPTIONS:MHTTPCLIENT}
RUN_DEPENDS+= rubygem-httpclient>=0:${PORTSDIR}/www/rubygem-httpclient
.endif
+.if ${PORT_OPTIONS:MNOTIFY}
+RUN_DEPENDS+= notify-send:${PORTSDIR}/devel/libnotify
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "50s|chdir\(.*\)|chdir\('${RUBY_SITELIBDIR}/mikutter/core'\)|" \
${WRKSRC}/mikutter.rb
@@ -89,4 +92,4 @@ x-generate-plist:
${ECHO} @exec ${MKDIR:S|/bin/||} %D/%%RUBY_SITELIBDIR%%/mikutter/core/hatsunelisp >> pkg-plist.new
${FIND} ${RUBY_SITELIBDIR}/mikutter -type d -depth | ${SORT} -r | ${SED} -e 's,${RUBY_SITELIBDIR},@dirrm %%RUBY_SITELIBDIR%%,' >> pkg-plist.new
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/testlink/Makefile b/www/testlink/Makefile
index 6529e7528b4c..8bd236c4aaab 100644
--- a/www/testlink/Makefile
+++ b/www/testlink/Makefile
@@ -25,30 +25,31 @@ PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
PORTDOCS= *
PORTEXAMPLES= *
-OPTIONS= MYSQL "MySQL back-end (use mysql PHP extension)" on \
- PGSQL "PostgreSQL back-end (use pgsql PHP extension)" off \
- OPENLDAP "Enable OpenLDAP support" off \
- EXTJS "Enable Ext JS support" on
+OPTIONS_DEFINE= OPENLDAP EXTJS
+OPTIONS_MULTI= BACKEND
+OPTIONS_MULTI_BACKEND= MYSQL PGSQL
+MYSQL_DESC= back-end (use mysql PHP extension)
+PGSQL_DESC= back-end (use pgsql PHP extension)
+OPENLDAP_DESC= Enable OpenLDAP support
+EXTJS_DESC= Enable Ext JS support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= MYSQL EXTJS
-.if defined(WITHOUT_MYSQL) && !defined(WITH_PGSQL)
-IGNORE= needs at least one database back-end
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
-.if defined(WITH_OPENLDAP)
+.if ${PORT_OPTIONS:MOPENLDAP}
USE_PHP+= ldap
.endif
-.if defined(WITH_EXTJS)
+.if ${PORT_OPTIONS:MEXTJS}
USE_PHP+= json
.endif
@@ -87,4 +88,4 @@ x-generate-plist:
.endfor
${ECHO} '@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%' >> pkg-plist.new
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>