aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/bogofilter-current/Makefile4
-rw-r--r--mail/bogofilter/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/mail/bogofilter-current/Makefile b/mail/bogofilter-current/Makefile
index dce8ba74f91e..bd30ab55cd87 100644
--- a/mail/bogofilter-current/Makefile
+++ b/mail/bogofilter-current/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS+= gsl.5:${PORTSDIR}/math/gsl
CONFLICTS?= bogofilter-tdb*
+USE_REINPLACE= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
@@ -32,6 +33,9 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 \
bogol.1 bogotune.1
+post-patch:
+ ${REINPLACE_CMD} -e 's/^@ENABLE_XMLTO_TRUE@//' ${WRKSRC}/doc/Makefile.in
+
post-build::
cd ${WRKSRC} && make check SHELL=${SH}
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index dce8ba74f91e..bd30ab55cd87 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS+= gsl.5:${PORTSDIR}/math/gsl
CONFLICTS?= bogofilter-tdb*
+USE_REINPLACE= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
@@ -32,6 +33,9 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 \
bogol.1 bogotune.1
+post-patch:
+ ${REINPLACE_CMD} -e 's/^@ENABLE_XMLTO_TRUE@//' ${WRKSRC}/doc/Makefile.in
+
post-build::
cd ${WRKSRC} && make check SHELL=${SH}