aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-HTML_Common/Makefile32
-rw-r--r--devel/pear-HTML_Common/distinfo1
-rw-r--r--devel/pear-HTML_Common/pkg-comment1
-rw-r--r--devel/pear-HTML_Common/pkg-descr8
-rw-r--r--devel/pear-HTML_Common/pkg-plist2
6 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 28023b6b345c..2583a0a1c1de 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -650,6 +650,7 @@
SUBDIR += pear
SUBDIR += pear-Console_Getopt
SUBDIR += pear-Date
+ SUBDIR += pear-HTML_Common
SUBDIR += pear-PEAR
SUBDIR += pear-install
SUBDIR += pedisassem
diff --git a/devel/pear-HTML_Common/Makefile b/devel/pear-HTML_Common/Makefile
new file mode 100644
index 000000000000..af4d4136a94e
--- /dev/null
+++ b/devel/pear-HTML_Common/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pear-HTML_Common
+# Date created: 29 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_Common
+PORTVERSION= 1.0
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+
+LPHP_LIB= lib/php
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MKDIR} ${PEARDIR}/HTML
+ @${CP} -Rp ${WRKSRC}/Common.php ${PEARDIR}/HTML
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML
+
+.include <bsd.port.mk>
diff --git a/devel/pear-HTML_Common/distinfo b/devel/pear-HTML_Common/distinfo
new file mode 100644
index 000000000000..1187d9e4f9cf
--- /dev/null
+++ b/devel/pear-HTML_Common/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/HTML_Common-1.0.tgz) = 7190426df5f75e53b5ac5a6de8ec56b5
diff --git a/devel/pear-HTML_Common/pkg-comment b/devel/pear-HTML_Common/pkg-comment
new file mode 100644
index 000000000000..96b5a7aa1ce5
--- /dev/null
+++ b/devel/pear-HTML_Common/pkg-comment
@@ -0,0 +1 @@
+PEAR::HTML_Common is a base class for other HTML classes
diff --git a/devel/pear-HTML_Common/pkg-descr b/devel/pear-HTML_Common/pkg-descr
new file mode 100644
index 000000000000..a2959a73b976
--- /dev/null
+++ b/devel/pear-HTML_Common/pkg-descr
@@ -0,0 +1,8 @@
+The PEAR::HTML_Common package provides methods for html code display and
+attributes handling.
+
+* Methods to set, remove, update html attributes.
+* Handles comments in HTML code.
+* Handles layout and tabs for nicer HTML code.
+
+WWW: http://pear.php.net/package-info.php?pacid=69
diff --git a/devel/pear-HTML_Common/pkg-plist b/devel/pear-HTML_Common/pkg-plist
new file mode 100644
index 000000000000..20031ff27b56
--- /dev/null
+++ b/devel/pear-HTML_Common/pkg-plist
@@ -0,0 +1,2 @@
+%%PEARDIR%%/HTML/Common.php
+@dirrm %%PEARDIR%%/HTML