aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/Makefile1
-rw-r--r--science/py-pysal/Makefile23
-rw-r--r--science/py-pysal/distinfo2
-rw-r--r--science/py-pysal/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index efa3109a5bb4..6a828c9a0e82 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -147,6 +147,7 @@
SUBDIR += py-pyaixi
SUBDIR += py-pydap
SUBDIR += py-pydicom
+ SUBDIR += py-pysal
SUBDIR += py-scikit-learn
SUBDIR += py-scimath
SUBDIR += py-scipy
diff --git a/science/py-pysal/Makefile b/science/py-pysal/Makefile
new file mode 100644
index 000000000000..f2bf6f3d1c82
--- /dev/null
+++ b/science/py-pysal/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pysal
+PORTVERSION= 1.8.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PySAL-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Cross-platform library of spatial analysis functions
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.3:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.7:${PORTSDIR}/science/py-scipy
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PYTHON= autoplist distutils
+USES= python:2
+
+.include <bsd.port.mk>
diff --git a/science/py-pysal/distinfo b/science/py-pysal/distinfo
new file mode 100644
index 000000000000..9706018a9acb
--- /dev/null
+++ b/science/py-pysal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PySAL-1.8.0.tar.gz) = 8c79492332dec86d22db0d0c6042689d36a4770f540118a5e5b46a8fc28dbc6b
+SIZE (PySAL-1.8.0.tar.gz) = 10214780
diff --git a/science/py-pysal/pkg-descr b/science/py-pysal/pkg-descr
new file mode 100644
index 000000000000..75335ef28b95
--- /dev/null
+++ b/science/py-pysal/pkg-descr
@@ -0,0 +1,6 @@
+PySAL is a cross-platform library of spatial analysis functions written in
+Python. It is intended to support the development of high level applications for
+spatial analysis.
+
+WWW: https://pypi.python.org/pypi/PySAL
+WWW: http://pysal.org/