aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/httprint/Makefile28
-rw-r--r--security/httprint/distinfo3
-rw-r--r--security/httprint/pkg-descr10
-rw-r--r--security/httprint/pkg-plist47
5 files changed, 89 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 19c73dc42cf3..662597b94ce3 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -168,6 +168,7 @@
SUBDIR += hlfl
SUBDIR += hmap
SUBDIR += hostsentry
+ SUBDIR += httprint
SUBDIR += hunch
SUBDIR += hydra
SUBDIR += idea
diff --git a/security/httprint/Makefile b/security/httprint/Makefile
new file mode 100644
index 000000000000..49ab6049c3ca
--- /dev/null
+++ b/security/httprint/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: httprint
+# Date created: 05 July 2006
+# Whom: Yonatan <onatan@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httprint
+PORTVERSION= 301
+CATEGORIES= security
+MASTER_SITES= http://www.net-square.com/httprint/
+DISTNAME= ${PORTNAME}_freebsd_${PORTVERSION}
+
+MAINTAINER= onatan@gmail.com
+COMMENT= Web server fingerprinting tool
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/freebsd/
+USE_ZIP= yes
+
+RESTRICTED= No cost for personal, education and non-commercial use.
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} -Rp ${WRKSRC} ${DATADIR}
+ ${LN} -s ${DATADIR}/httprint ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/httprint/distinfo b/security/httprint/distinfo
new file mode 100644
index 000000000000..8dd76e11e16a
--- /dev/null
+++ b/security/httprint/distinfo
@@ -0,0 +1,3 @@
+MD5 (httprint_freebsd_301.zip) = d5efd9463f671ce92f50ce3222f1774e
+SHA256 (httprint_freebsd_301.zip) = 168127b70bc87f1a6e9256ed4aa3a076a7a23c7155e3fe8d5b11a25dc880fcce
+SIZE (httprint_freebsd_301.zip) = 512708
diff --git a/security/httprint/pkg-descr b/security/httprint/pkg-descr
new file mode 100644
index 000000000000..c477bea70306
--- /dev/null
+++ b/security/httprint/pkg-descr
@@ -0,0 +1,10 @@
+httprint is a web server fingerprinting tool. It relies on web server
+characteristics to accurately identify web servers, despite the fact that
+they may have been obfuscated by changing the server banner strings, or
+by plug-ins such as mod_security or servermask. httprint can also be used
+to detect web enabled devices which do not have a server banner string,
+such as wireless access points, routers, switches, cable modems, etc.
+httprint uses text signature strings and it is very easy to add signatures
+to the signature database.
+
+WWW: http://net-square.com/httprint/index.shtml
diff --git a/security/httprint/pkg-plist b/security/httprint/pkg-plist
new file mode 100644
index 000000000000..55b4dea9a588
--- /dev/null
+++ b/security/httprint/pkg-plist
@@ -0,0 +1,47 @@
+bin/httprint
+%%DATADIR%%/httprint
+%%DATADIR%%/input.txt
+%%DATADIR%%/nmapportlist.txt
+%%DATADIR%%/readme.txt
+%%DATADIR%%/signatures.txt
+%%DATADIR%%/images/_1x1blue.gif
+%%DATADIR%%/images/_1x1grey.gif
+%%DATADIR%%/images/_1x1white.gif
+%%DATADIR%%/images/_blue-end.gif
+%%DATADIR%%/images/_blue-front.gif
+%%DATADIR%%/images/_blue-mid.gif
+%%DATADIR%%/images/_end.gif
+%%DATADIR%%/images/_front.gif
+%%DATADIR%%/images/_grey-end.gif
+%%DATADIR%%/images/_grey-mid.gif
+%%DATADIR%%/images/_httprint.gif
+%%DATADIR%%/images/_netsquare.gif
+%%DATADIR%%/images/_tick.gif
+%%DATADIR%%/images/aol.gif
+%%DATADIR%%/images/apache.gif
+%%DATADIR%%/images/bea.gif
+%%DATADIR%%/images/cisco.gif
+%%DATADIR%%/images/compaq.gif
+%%DATADIR%%/images/domino.gif
+%%DATADIR%%/images/hp.gif
+%%DATADIR%%/images/ibm.gif
+%%DATADIR%%/images/iis4_5.gif
+%%DATADIR%%/images/iis51_6.gif
+%%DATADIR%%/images/jana.gif
+%%DATADIR%%/images/linksys.gif
+%%DATADIR%%/images/mikrotik.gif
+%%DATADIR%%/images/netscape.gif
+%%DATADIR%%/images/novell.gif
+%%DATADIR%%/images/smc.gif
+%%DATADIR%%/images/snap.gif
+%%DATADIR%%/images/sun.gif
+%%DATADIR%%/images/thttpd.gif
+%%DATADIR%%/images/tomcat.gif
+%%DATADIR%%/images/tux.gif
+%%DATADIR%%/images/ubicom.gif
+%%DATADIR%%/images/vnc.gif
+%%DATADIR%%/images/xerver.gif
+%%DATADIR%%/images/zeus.gif
+%%DATADIR%%/images/zope.gif
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%