aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/ccrtp/Makefile3
-rw-r--r--devel/cvstrac/Makefile9
-rw-r--r--devel/ding-libs/Makefile9
-rw-r--r--devel/etl/Makefile9
-rw-r--r--devel/jansson/Makefile4
-rw-r--r--devel/jna/Makefile4
-rw-r--r--devel/json-c/Makefile3
-rw-r--r--devel/lasi/Makefile5
-rw-r--r--devel/libdlna/Makefile9
-rw-r--r--devel/libev/Makefile8
-rw-r--r--devel/libftdi/Makefile2
-rw-r--r--devel/libleaftag/Makefile10
-rw-r--r--devel/libmcs/Makefile3
-rw-r--r--devel/liboil/Makefile9
-rw-r--r--devel/libopendaap/Makefile8
-rw-r--r--devel/libopkele/Makefile9
-rw-r--r--devel/libpthread-stubs/Makefile9
-rw-r--r--devel/librelp/Makefile2
-rw-r--r--devel/libsigc++12/Makefile9
-rw-r--r--devel/libstatgrab/Makefile8
-rw-r--r--devel/libukcprog/Makefile9
-rw-r--r--devel/libzvbi/Makefile9
-rw-r--r--devel/log4shib/Makefile11
-rw-r--r--devel/mono-addins/Makefile3
-rw-r--r--devel/mq4cpp/Makefile9
-rw-r--r--devel/omniORB/Makefile9
-rw-r--r--devel/orc/Makefile3
-rw-r--r--devel/p5-Net-DBus/Makefile10
-rw-r--r--devel/p5-Unix-Statgrab/Makefile10
-rw-r--r--devel/pcsc-lite/Makefile5
-rw-r--r--devel/protobuf-c/Makefile9
-rw-r--r--devel/ptlib/Makefile5
-rw-r--r--devel/ruby-statgrab/Makefile8
33 files changed, 66 insertions, 166 deletions
diff --git a/devel/ccrtp/Makefile b/devel/ccrtp/Makefile
index 145d7eed69f8..9363b434864f 100644
--- a/devel/ccrtp/Makefile
+++ b/devel/ccrtp/Makefile
@@ -13,8 +13,7 @@ COMMENT= Implementation of the real-time transport protocol
LIB_DEPENDS= commoncpp:${PORTSDIR}/devel/ucommon
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USES= gmake pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -pthread"
diff --git a/devel/cvstrac/Makefile b/devel/cvstrac/Makefile
index 944359b20214..0ae12d2be83a 100644
--- a/devel/cvstrac/Makefile
+++ b/devel/cvstrac/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvstrac
-# Date created: 29 August 2002
-# Whom: Bruce M Simpson <bms@spc.org>
-#
+# Created by: Bruce M Simpson <bms@spc.org>
# $FreeBSD$
-#
PORTNAME?= cvstrac
PORTVERSION= 2.0.1
@@ -16,8 +12,7 @@ COMMENT?= Web-Based Bug And Patch-Set Tracking System For CVS
WRKSRC= ${WRKDIR}/cvstrac-${PORTVERSION}
USE_SQLITE= yes
-USE_GNOME= pkgconfig
-USE_GMAKE= yes
+USES= gmake pkgconfig
MAKE_ARGS+= SRCDIR=${WRKSRC} PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/ding-libs/Makefile b/devel/ding-libs/Makefile
index 65d2a36710a9..8c2ec9a337de 100644
--- a/devel/ding-libs/Makefile
+++ b/devel/ding-libs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ding-libs
-# Date created: Sep 6 2011
-# Whom: Andrew Elble <aweits@rit.edu>
-#
+# Created by: Andrew Elble <aweits@rit.edu>
# $FreeBSD$
-#
PORTNAME= ding-libs
DISTVERSION= 0.1.3
@@ -18,8 +14,7 @@ LICENSE= GPLv3
GNU_CONFIGURE= yes
CPPFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-USES= gettext
-USE_GNOME= pkgconfig
+USES= gettext pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ENV+= DOXYGEN=""
diff --git a/devel/etl/Makefile b/devel/etl/Makefile
index d33851efe7be..788685158e90 100644
--- a/devel/etl/Makefile
+++ b/devel/etl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ETL
-# Date created: 25 Jun 2006
-# Whom: Yinghong Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= etl
PORTVERSION= 0.04.15
@@ -14,8 +10,7 @@ DISTNAME= ETL-${PORTVERSION}
MAINTAINER= dhn@FreeBSD.org
COMMENT= Voria Extended Class and Template Library
-USE_GNOME= gnomehack pkgconfig
-USE_GMAKE= yes
+USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
post-install:
diff --git a/devel/jansson/Makefile b/devel/jansson/Makefile
index 3a9148c1be3e..e391e94ba5ed 100644
--- a/devel/jansson/Makefile
+++ b/devel/jansson/Makefile
@@ -7,11 +7,11 @@ CATEGORIES= devel
MASTER_SITES= http://www.digip.org/jansson/releases/
MAINTAINER= vanilla@FreeBSD.org
-COMMENT= A C library for encoding, decoding, and manipulating JSON data
+COMMENT= C library for encoding, decoding, and manipulating JSON data
+USES= pathfix pkgconfig
USE_BZIP2= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig
.include <bsd.port.mk>
diff --git a/devel/jna/Makefile b/devel/jna/Makefile
index e4a811cd637d..ef2aeed216c9 100644
--- a/devel/jna/Makefile
+++ b/devel/jna/Makefile
@@ -11,11 +11,13 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Java access to native shared libraries
+USES= gmake
+USE_GCC= any
USE_ANT= yes
-USE_GMAKE= yes
USE_JAVA= 1.4+
USE_ZIP= yes
USE_XORG= x11 xt
+MAKE_ARGS= -DCC=${CC} -DLD=${LD}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
DOCSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-doc
diff --git a/devel/json-c/Makefile b/devel/json-c/Makefile
index ad30e13de3e6..2321053d54b1 100644
--- a/devel/json-c/Makefile
+++ b/devel/json-c/Makefile
@@ -11,8 +11,7 @@ COMMENT= JSON (JavaScript Object Notation) implementation in C
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= pkgconfig gnomehack
+USES= gmake pathfix pkgconfig
CONFLICTS= cocaine-core-[0-9]*
diff --git a/devel/lasi/Makefile b/devel/lasi/Makefile
index 2866c91e20af..4985c2c7fa3e 100644
--- a/devel/lasi/Makefile
+++ b/devel/lasi/Makefile
@@ -1,6 +1,7 @@
# Created by: giffunip
# $FreeBSD$
# $MCom: ports/devel/lasi/Makefile,v 1.1 2006/10/04 20:25:40 ahze Exp $
+
PORTNAME= lasi
PORTVERSION= 1.1.1
PORTREVISION= 1
@@ -11,14 +12,14 @@ DISTNAME= libLASi-${PORTVERSION}
MAINTAINER= lme@FreeBSD.org
COMMENT= C++ stream output interface for creating Postscript documents
-USE_GNOME= pango pkgconfig
+USES= cmake pkgconfig
+USE_GNOME= pango
USE_AUTOTOOLS= libltdl
PKG_CONFIG_PATH= ${PREFIX}/libdata/pkgconfig
CONFIGURE_ENV+= PKG_CONFIG_PATH=${PKG_CONFIG_PATH}
USE_LDCONFIG= yes
-USES= cmake
CMAKE_ARGS+= -DCMAKE_INSTALL_DATADIR:PATH=${DATADIR}
.if !defined(NOPORTDOCS)
diff --git a/devel/libdlna/Makefile b/devel/libdlna/Makefile
index 7128cced471d..bddbcdb43f5e 100644
--- a/devel/libdlna/Makefile
+++ b/devel/libdlna/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/libdlna
-# Date created: Sat Feb 9 20:20:00 UTC 2008
-# Whom: Dave Grochowski <malus.x@gmail.com>
-#
+# Created by: Dave Grochowski <malus.x@gmail.com>
# $FreeBSD$
-#
PORTNAME= libdlna
PORTVERSION= 0.2.3
@@ -20,8 +16,7 @@ LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
HAS_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USES= gmake pkgconfig
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/libev/Makefile b/devel/libev/Makefile
index a8daad903d12..ced009d94e11 100644
--- a/devel/libev/Makefile
+++ b/devel/libev/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libev
-# Date created: 18 Dec 2007
-# Whom: vsevolod
-#
+# Created by: vsevolod
# $FreeBSD$
-#
PORTNAME= libev
PORTVERSION= 4.15
@@ -17,7 +13,7 @@ COMMENT= A full-featured and high-performance event loop library
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GNOME= pkgconfig
+USES= pkgconfig
MAN3= ev.3
diff --git a/devel/libftdi/Makefile b/devel/libftdi/Makefile
index a934b92f37e2..515b2899b4ec 100644
--- a/devel/libftdi/Makefile
+++ b/devel/libftdi/Makefile
@@ -17,7 +17,7 @@ USE_AUTOTOOLS= autoconf libtool automake
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
-USE_GNOME= pkgconfig gnomehack
+USES= pathfix pkgconfig
PORTDOCS= COPYING.LIB ChangeLog README
diff --git a/devel/libleaftag/Makefile b/devel/libleaftag/Makefile
index 5022ce0198ec..79c0d61d163a 100644
--- a/devel/libleaftag/Makefile
+++ b/devel/libleaftag/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libleaftag
-# Date Created: 24 May 2006
-# Whom: Khairil Yusof <kaeru@inigo-tech.com>
-#
+# Created by: Khairil Yusof <kaeru@inigo-tech.com>
# $FreeBSD$
-#
PORTNAME= libleaftag
PORTVERSION= 0.3.1
@@ -15,9 +11,9 @@ MAINTAINER= kaeru@inigo-tech.com
COMMENT= Leaftag is a library for tagging files on the desktop
USE_SQLITE= 2
-USE_GMAKE= yes
+USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack glib20 pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/libmcs/Makefile b/devel/libmcs/Makefile
index f00806a5758c..62df5570aa49 100644
--- a/devel/libmcs/Makefile
+++ b/devel/libmcs/Makefile
@@ -18,8 +18,7 @@ OPTIONS_DEFAULT= GCONF
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USES= gmake pkgconfig
.include <bsd.port.options.mk>
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index 255e78e49171..cf4e996590be 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: liboil
-# Date created: Nov 24, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
# $MCom: ports/devel/liboil/Makefile,v 1.7 2008/03/23 06:57:57 marcus Exp $
-# $Id: Makefile 23 2006-10-25 14:24:32Z buhnux $
PORTNAME= liboil
PORTVERSION= 0.3.17
@@ -18,7 +14,8 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GCC= any
-USE_GNOME= pkgconfig gnomehack ltverhack
+USES= pathfix pkgconfig
+USE_GNOME= ltverhack
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-gtk-doc \
diff --git a/devel/libopendaap/Makefile b/devel/libopendaap/Makefile
index 97484fa70855..52f09e5363bc 100644
--- a/devel/libopendaap/Makefile
+++ b/devel/libopendaap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libopendaap
-# Date created: 2004-03-10
-# Whom: Michael Johnson <ahze@ahze.net>
-#
+# Created by: Michael Johnson <ahze@ahze.net>
# $FreeBSD$
-#
PORTNAME= libopendaap
PORTVERSION= 0.4.0
@@ -16,7 +12,7 @@ COMMENT= C lib used to connect to iTunes(R) music shares
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_GNOME= gnomehack pkgconfig
+USES= pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
index 35e978787d0b..bf147122e8d3 100644
--- a/devel/libopkele/Makefile
+++ b/devel/libopkele/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libopkele
-# Date created: 28 November 2007
-# Whom: Sutra Zhou <zhoushuqun@gmail.com>
-#
+# Created by: Sutra Zhou <zhoushuqun@gmail.com>
# $FreeBSD$
-#
PORTNAME= libopkele
PORTVERSION= 2.0.4
@@ -21,9 +17,8 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
tidy:${PORTSDIR}/www/tidy-lib \
xslt:${PORTSDIR}/textproc/libxslt
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_GNOME= pkgconfig
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= "OPENSSL_CFLAGS=${CFLAGS} -l${OPENSSLINC}" \
OPENSSL_LIBS=-L${OPENSSLLIB}
diff --git a/devel/libpthread-stubs/Makefile b/devel/libpthread-stubs/Makefile
index 2c9dfaa4fc76..dc21e5560b5d 100644
--- a/devel/libpthread-stubs/Makefile
+++ b/devel/libpthread-stubs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libpthread-stubs
-# Date created: 24 January 2007
-# Whom: wahjava
-#
+# Created by: wahjava
# $FreeBSD$
-#
PORTNAME= libpthread-stubs
PORTVERSION= 0.3
@@ -14,9 +10,8 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= ashish@FreeBSD.org
COMMENT= This library provides weak aliases for pthread functions
-USE_GMAKE= yes
+USES= gmake pathfix pkgconfig
USE_BZIP2= yes
-USE_GNOME= gnomehack pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/devel/librelp/Makefile b/devel/librelp/Makefile
index bbe02bd1c6c9..0368c8d619fa 100644
--- a/devel/librelp/Makefile
+++ b/devel/librelp/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://download.rsyslog.com/librelp/
MAINTAINER= brd@FreeBSD.org
COMMENT= Reliable event logging protocol library
-USE_GNOME= gnomehack pkgconfig
+USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/devel/libsigc++12/Makefile b/devel/libsigc++12/Makefile
index 92a8d07afb12..f8ad10ea2e93 100644
--- a/devel/libsigc++12/Makefile
+++ b/devel/libsigc++12/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libsigc++
-# Date created: 30 September 2002
-# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
-#
+# Created by: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
# $FreeBSD$
-#
PORTNAME= libsigc++
PORTVERSION= 1.2.7
@@ -19,10 +15,9 @@ COMMENT= Callback Framework for C++
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
LATEST_LINK= libsigc++12
USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig
+USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/devel/libstatgrab/Makefile b/devel/libstatgrab/Makefile
index 69481e944b57..b747e1947268 100644
--- a/devel/libstatgrab/Makefile
+++ b/devel/libstatgrab/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libstatgrab
-# Date created: 30 March 2003
-# Whom: Tim Bishop <tim@bishnet.net>
-#
+# Created by: Tim Bishop <tim@bishnet.net>
# $FreeBSD$
-#
PORTNAME= libstatgrab
PORTVERSION= 0.17
@@ -21,7 +17,7 @@ COMMENT= Provides a useful interface to system statistics
DIST_SUBDIR= i-scream
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig
+USES= pathfix pkgconfig
MAN3= sg_get_cpu_percents.3 sg_get_cpu_stats.3 \
sg_get_cpu_stats_diff.3 sg_get_disk_io_stats.3 \
diff --git a/devel/libukcprog/Makefile b/devel/libukcprog/Makefile
index 79f870b7ca7f..474f7112c974 100644
--- a/devel/libukcprog/Makefile
+++ b/devel/libukcprog/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libukcprog
-# Date created: 30 March 2003
-# Whom: Tim Bishop <tim@bishnet.net>
-#
+# Created by: Tim Bishop <tim@bishnet.net>
# $FreeBSD$
-#
PORTNAME= libukcprog
PORTVERSION= 1.0.2
@@ -26,6 +22,7 @@ MAN3= ukcprog.3
DIST_SUBDIR= i-scream
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig lthack
+USES= pathfix pkgconfig
+USE_GNOME= lthack
.include <bsd.port.mk>
diff --git a/devel/libzvbi/Makefile b/devel/libzvbi/Makefile
index 8209b377b8c4..776b29aeea9a 100644
--- a/devel/libzvbi/Makefile
+++ b/devel/libzvbi/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libzvbi
-# Date created: 15 May 2003
-# Whom: Oliver Lehmann <oliver@freebsd.org>
-#
+# Created by: Oliver Lehmann <oliver@freebsd.org>
# $FreeBSD$
-#
PORTNAME= libzvbi
PORTVERSION= 0.2.34
@@ -17,9 +13,8 @@ COMMENT= Routines to access raw VBI capture devices
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
unicode.0:${PORTSDIR}/devel/libunicode
-USES= gettext
+USES= gettext pathfix pkgconfig
USE_BZIP2= yes
-USE_GNOME= gnomehack pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAN1= zvbi-ntsc-cc.1
diff --git a/devel/log4shib/Makefile b/devel/log4shib/Makefile
index f199c3dce320..010deb3e90e3 100644
--- a/devel/log4shib/Makefile
+++ b/devel/log4shib/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: log4shib
-# Date created: Feb 13 2008
-# Whom: vanilla
-#
+# Created by: vanilla
# $FreeBSD$
-#
PORTNAME= log4shib
DISTVERSION= 1.0.7
@@ -15,13 +10,11 @@ MAINTAINER= girgen@FreeBSD.org
COMMENT= A library of C++ classes for flexible logging
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
+USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig gnomehack
CONFIGURE_ARGS= --disable-html-docs --disable-doxygen
USE_LDCONFIG= yes
-USES= pathfix
post-patch:
@${REINPLACE_CMD} -e 's| -pedantic||g' ${WRKSRC}/configure
diff --git a/devel/mono-addins/Makefile b/devel/mono-addins/Makefile
index 0cc7bb887063..4e34255bbf79 100644
--- a/devel/mono-addins/Makefile
+++ b/devel/mono-addins/Makefile
@@ -16,8 +16,7 @@ RUN_DEPENDS+= ${LIB_PC_DEPENDS}
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig
+USES= gmake pathfix pkgconfig
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= GTK2
diff --git a/devel/mq4cpp/Makefile b/devel/mq4cpp/Makefile
index f5f55961875b..9396b3f9c45a 100644
--- a/devel/mq4cpp/Makefile
+++ b/devel/mq4cpp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mp4cpp
-# Date created: Jan 4 2007
-# Whom: vanilla
-#
+# Created by: vanilla
# $FreeBSD$
-#
PORTNAME= mq4cpp
PORTVERSION= 1.16
@@ -15,7 +11,8 @@ COMMENT= Message Queuing for C++
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack pkgconfig ltverhack
+USES= pathfix pkgconfig
+USE_GNOME= ltverhack
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/devel/omniORB/Makefile b/devel/omniORB/Makefile
index 8c67b7ac9962..0fbcb712d756 100644
--- a/devel/omniORB/Makefile
+++ b/devel/omniORB/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: omniORB
-# Date created: 14 May 1997
-# Whom: ejc@bazzle.com
-#
+# Created by: ejc@bazzle.com
# $FreeBSD$
-#
PORTNAME= omniORB
PORTVERSION= 4.1.6
@@ -14,11 +10,10 @@ COMMENT= A robust high performance CORBA ORB for C++ and Python
PLIST_SUB+= SONUM=${PORTVERSION:C/.*\.//}
USE_GCC= any
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_PYTHON= yes
USE_OPENSSL= yes
-USE_GNOME= pkgconfig
+USES= gmake pkgconfig
USE_BZIP2= yes
USE_LDCONFIG= yes
MAKEFILE= GNUmakefile
diff --git a/devel/orc/Makefile b/devel/orc/Makefile
index 5e0e05f92367..82bc57d34da1 100644
--- a/devel/orc/Makefile
+++ b/devel/orc/Makefile
@@ -12,10 +12,9 @@ COMMENT= Library and toolset to operate arrays of data
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNOME= pkgconfig
+USES= gmake pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USE_GMAKE= yes
CONFIGURE_ARGS+= --disable-gtk-doc
diff --git a/devel/p5-Net-DBus/Makefile b/devel/p5-Net-DBus/Makefile
index cb6d48a2ba40..e7bd76877bea 100644
--- a/devel/p5-Net-DBus/Makefile
+++ b/devel/p5-Net-DBus/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Net-DBus
-# Date created: 2005-11-25
-# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
-#
+# Created by: Roman Bogorodskiy <novel@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Net-DBus
PORTVERSION= 1.0.0
@@ -19,8 +15,8 @@ RUN_DEPENDS= p5-XML-Twig>=0:${PORTSDIR}/textproc/p5-XML-Twig \
p5-XML-Grove>=0:${PORTSDIR}/textproc/p5-XML-Grove \
p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
-USE_GNOME= pkgconfig
-PERL_CONFIGURE= yes
+USES= pkgconfig perl5
+USES_PERL5= configure
MAN3= Net::DBus::ASyncReply.3 Net::DBus::Annotation.3 Net::DBus::Tutorial.3 \
Net::DBus::RemoteObject.3 Net::DBus::Binding::Connection.3 \
diff --git a/devel/p5-Unix-Statgrab/Makefile b/devel/p5-Unix-Statgrab/Makefile
index 0809fa969ddb..92e518a99310 100644
--- a/devel/p5-Unix-Statgrab/Makefile
+++ b/devel/p5-Unix-Statgrab/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Unix-Statgrab
-# Date created: June 20th, 2004
-# Whom: Tim Bishop <tim@bishnet.net>
-#
+# Created by: Tim Bishop <tim@bishnet.net>
# $FreeBSD$
-#
PORTNAME= Unix-Statgrab
PORTVERSION= 0.04
@@ -17,9 +13,9 @@ COMMENT= Perl extension for collecting information about the machine
LIB_DEPENDS= statgrab.8:${PORTSDIR}/devel/libstatgrab
-USE_GNOME= pkgconfig
+USES= perl5 pkgconfig
+USE_PERL5= configure
-PERL_CONFIGURE= yes
CONFIGURE_ARGS+= INC="`pkg-config libstatgrab --cflags`" \
LIBS="`pkg-config libstatgrab --libs`"
diff --git a/devel/pcsc-lite/Makefile b/devel/pcsc-lite/Makefile
index 47900a176b1b..736d5c7adf64 100644
--- a/devel/pcsc-lite/Makefile
+++ b/devel/pcsc-lite/Makefile
@@ -17,9 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
-USE_GNOME= gnomehack pkgconfig
+USES= gmake perl5 pathfix pkgconfig
+USE_PERL5= build
USE_RC_SUBR= pcscd
USE_LDCONFIG= yes
diff --git a/devel/protobuf-c/Makefile b/devel/protobuf-c/Makefile
index b62e1e83a8ea..3ca9aa0d5d0c 100644
--- a/devel/protobuf-c/Makefile
+++ b/devel/protobuf-c/Makefile
@@ -1,9 +1,5 @@
-# New Ports collection makefile for: protobuf
-# Date created: 2011.05.16
-# Whom: Aaron Hurt <ahurt@anbcs.com>
-#
+# Created by: Aaron Hurt <ahurt@anbcs.com>
# $FreeBSD$
-#
PORTNAME= protobuf-c
PORTVERSION= 0.15
@@ -16,10 +12,9 @@ COMMENT= This package provides a code generator and runtime libraries to use Pro
LIB_DEPENDS= protobuf:${PORTSDIR}/devel/protobuf
-USE_GMAKE= yes
+USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/devel/ptlib/Makefile b/devel/ptlib/Makefile
index 2267e6a22ba2..b8a6b595eff8 100644
--- a/devel/ptlib/Makefile
+++ b/devel/ptlib/Makefile
@@ -16,11 +16,8 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
CONFLICTS= pwlib-1.* ptlib-2.6.*
-USES= bison
-USE_GMAKE= yes
+USES= bison gmake pkgconfig
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig
-WANT_GNOME= yes
WANT_SDL= yes
USE_OPENSSL= yes
USE_LDCONFIG= yes
diff --git a/devel/ruby-statgrab/Makefile b/devel/ruby-statgrab/Makefile
index 61786d2e96f2..8198497f7046 100644
--- a/devel/ruby-statgrab/Makefile
+++ b/devel/ruby-statgrab/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ruby-statgrab
-# Date created: 16 June 2008
-# Whom: Tim Bishop <tdb@FreeBSD.org>
-#
+# Created by: Tim Bishop <tdb@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= statgrab
PORTVERSION= 0.1
@@ -19,7 +15,7 @@ LIB_DEPENDS= statgrab.8:${PORTSDIR}/devel/libstatgrab
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_GNOME= pkgconfig
+USES= pkgconfig
INSTALL_TARGET= site-install