aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pecomato/Makefile55
-rw-r--r--graphics/pecomato/distinfo2
-rw-r--r--graphics/pecomato/pkg-descr24
4 files changed, 82 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 385c5b12e472..e57fe65c9a6e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -411,6 +411,7 @@
SUBDIR += pear-Image_Color
SUBDIR += pear-Image_Graph
SUBDIR += pecl-imagick
+ SUBDIR += pecomato
SUBDIR += peps
SUBDIR += pgperl
SUBDIR += pgplot
diff --git a/graphics/pecomato/Makefile b/graphics/pecomato/Makefile
new file mode 100644
index 000000000000..695b48ed8ad3
--- /dev/null
+++ b/graphics/pecomato/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: pecomato
+# Date created: 16 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pecomato
+PORTVERSION= 0.0.12
+CATEGORIES= graphics
+MASTER_SITES= http://82.225.188.10/projects/pecomato/download/sources/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command-line picture metadata processor
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_PYTHON= yes
+
+MAKEFILE= Makefile.unix
+MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
+
+PLIST_FILES= bin/pecomato
+MAN1= pecomato.1
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(CC.*\)=|\1?=|; s|^\(all:.*\)|\1 docs|' \
+ ${WRKSRC}/Makefile.unix
+ @${REINPLACE_CMD} -e 's|^\(PYTHON\).*|\1 = ${PYTHON_CMD}|' \
+ ${WRKSRC}/Makefile.posix.inc
+.if !defined(NOPORTDOCS)
+ @${REINPLACE_CMD} \
+ -E 's/^(HTML_DOCS|TXT_DOCS).*=.*(README\.(html|txt)\ TODO\.(html|txt)).*/\1=\2/' \
+ ${WRKSRC}/doc/Makefile.posix
+.else
+ @${REINPLACE_CMD} -E '/^(HTML_DOCS|TXT_DOCS)/d' \
+ ${WRKSRC}/doc/Makefile.posix
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/.man/manpage.man \
+ ${MANPREFIX}/man/man1/${PORTNAME}.1
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/html ${DOCSDIR}/txt
+.for f in README TODO
+.for t in txt html
+ ${INSTALL_DATA} ${WRKSRC}/doc/.${t}/${f}.${t} ${DOCSDIR}/${t}
+.endfor
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/pecomato/distinfo b/graphics/pecomato/distinfo
new file mode 100644
index 000000000000..dfac86bfc299
--- /dev/null
+++ b/graphics/pecomato/distinfo
@@ -0,0 +1,2 @@
+MD5 (pecomato-0.0.12.tar.gz) = e610397b942dfda56bfdf3720bfd6cac
+SIZE (pecomato-0.0.12.tar.gz) = 139030
diff --git a/graphics/pecomato/pkg-descr b/graphics/pecomato/pkg-descr
new file mode 100644
index 000000000000..3e73d4ff046c
--- /dev/null
+++ b/graphics/pecomato/pkg-descr
@@ -0,0 +1,24 @@
+PECoMaTo stands for Picture-Embedded COntents MAnipulation TOol.
+
+It is designed to display any kind of information embedded in picture files,
+as well as checking, filtering, extracting, removing, adding, and fixing such
+information. In other words, it's a metadata processor.
+
+It supports the following file formats:
+
+ * JPEG/JFIF
+ * Adobe PSD and FFO
+ * raw IPTC
+
+It knows about the following metadata formats:
+
+ * JFIF
+ * IPTC
+ * Exif
+ * Adobe
+ * Fotostation
+
+WWW: http://82.225.188.10/projects/pecomato/
+
+- ehaupt
+ehaupt@critical.ch