aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/bbuname/Makefile25
-rw-r--r--x11/bbuname/distinfo4
-rw-r--r--x11/bbuname/pkg-descr8
-rw-r--r--x11/bbuname/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 2abddf81239e..f1ffa7b60c14 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -17,6 +17,7 @@
SUBDIR += apwal
SUBDIR += aterm
SUBDIR += bbrun
+ SUBDIR += bbuname
SUBDIR += bgrot
SUBDIR += blast
SUBDIR += bricons
diff --git a/x11/bbuname/Makefile b/x11/bbuname/Makefile
new file mode 100644
index 000000000000..2ec8fc9f892b
--- /dev/null
+++ b/x11/bbuname/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: bbuname
+# Date created: 11 February 2004
+# Whom: Nikos "Noth" Ntarmos <ntarmos@ceid.upatras.gr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bbuname
+PORTVERSION= 0.2
+CATEGORIES= x11
+MASTER_SITES= http://spiritisdigital.com/download/linux/bbuname/
+
+PATCH_SITES= ftp://noth.ceid.upatras.gr/pub/FreeBSD/patches/
+PATCHFILES= ${PORTNAME}-${PORTVERSION}.patch1.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= ntarmos@ceid.upatras.gr
+COMMENT= A Flux/Black-box applet displaying system information a la GNU uname
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+.include <bsd.port.mk>
diff --git a/x11/bbuname/distinfo b/x11/bbuname/distinfo
new file mode 100644
index 000000000000..3a77a71da40e
--- /dev/null
+++ b/x11/bbuname/distinfo
@@ -0,0 +1,4 @@
+MD5 (bbuname-0.2.tar.bz2) = dd08ec4fc8f6a3c56a385ae60231db43
+SIZE (bbuname-0.2.tar.bz2) = 56158
+MD5 (bbuname-0.2.patch1.gz) = 3df0c0485a64bfcbd98617fb953aaf20
+SIZE (bbuname-0.2.patch1.gz) = 1010
diff --git a/x11/bbuname/pkg-descr b/x11/bbuname/pkg-descr
new file mode 100644
index 000000000000..c6a1e07b38e2
--- /dev/null
+++ b/x11/bbuname/pkg-descr
@@ -0,0 +1,8 @@
+This is a small Blackbox/Fluxbox tool, "bbuname" which displays the system
+informations, similar to GNU uname. Currenlty only suppots displaying the
+kernel version. More to come soon.
+
+WWW: http://spiritisdigital.com/linux/bbuname/
+
+- Nikos "Noth" Ntarmos
+<ntarmos@ceid.upatras.gr>
diff --git a/x11/bbuname/pkg-plist b/x11/bbuname/pkg-plist
new file mode 100644
index 000000000000..f95af28d2203
--- /dev/null
+++ b/x11/bbuname/pkg-plist
@@ -0,0 +1,5 @@
+bin/bbuname
+share/bbtools/bbuname.conf
+share/bbtools/bbuname.nobb
+share/bbtools/README.bbuname
+@unexec rmdir %D/share/bbtools 2>/dev/null || true