aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/grass7/Makefile2
-rw-r--r--emulators/py-nova/Makefile2
-rw-r--r--games/kajongg/Makefile2
-rw-r--r--graphics/fotoxx/Makefile2
-rw-r--r--math/msieve/Makefile2
-rw-r--r--math/octave-forge-audio/Makefile2
-rw-r--r--math/octave-forge-engine/Makefile2
-rw-r--r--math/octave-forge-fl-core/Makefile2
-rw-r--r--math/octave-forge-pdb/Makefile2
-rw-r--r--net/ntop/Makefile2
-rw-r--r--net/py-libstorj/Makefile2
-rw-r--r--net/py-pcs/Makefile2
-rw-r--r--net/scribe/Makefile2
-rw-r--r--textproc/ots/Makefile2
-rw-r--r--x11-wm/qtile/Makefile2
-rw-r--r--x11/xpra/Makefile2
-rw-r--r--x11/xpyb/Makefile2
17 files changed, 33 insertions, 1 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index e0b981156351..cbcce416895c 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -26,6 +26,8 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL.TXT
BROKEN= fails to package
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2:math/py-numpy@${PY_FLAVOR}
LIB_DEPENDS= libgdal.so:graphics/gdal \
diff --git a/emulators/py-nova/Makefile b/emulators/py-nova/Makefile
index 62b43ea543db..ca404991a925 100644
--- a/emulators/py-nova/Makefile
+++ b/emulators/py-nova/Makefile
@@ -14,6 +14,8 @@ COMMENT= OpenStack compute service
LICENSE= APACHE20
BROKEN= depends on conflicting dependencies
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr@${PY_FLAVOR}
diff --git a/games/kajongg/Makefile b/games/kajongg/Makefile
index ffe571b6e58c..e74676713faf 100644
--- a/games/kajongg/Makefile
+++ b/games/kajongg/Makefile
@@ -1,6 +1,8 @@
# $FreeBSD$
BROKEN= Requires PyQt5 for python3 which is broken at the moment.
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
PORTNAME= kajongg
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
diff --git a/graphics/fotoxx/Makefile b/graphics/fotoxx/Makefile
index 3b14684b5fe6..87e6bc5e703d 100644
--- a/graphics/fotoxx/Makefile
+++ b/graphics/fotoxx/Makefile
@@ -14,6 +14,8 @@ COMMENT= Application to organize and edit image collections
LICENSE= GPLv3
BROKEN= conflicting dependencies dcraw and ufraw
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
RUN_DEPENDS= xdg-open:devel/xdg-utils \
dcraw:graphics/dcraw \
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index eae8a7d8ddec..8dba389578c0 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -12,6 +12,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Fast factorization of big integers using MPQS and GNFS
BROKEN= missing build depends
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
BUILD_DEPENDS= ${LOCALBASE}/lib/libecm.a:math/gmp-ecm
diff --git a/math/octave-forge-audio/Makefile b/math/octave-forge-audio/Makefile
index 9806fb6fbe2d..cc8038d957e7 100644
--- a/math/octave-forge-audio/Makefile
+++ b/math/octave-forge-audio/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= does not build with octave version >= 4.4.0
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
GNU_CONFIGURE= yes
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
diff --git a/math/octave-forge-engine/Makefile b/math/octave-forge-engine/Makefile
index 9dd21831a4fb..c636c80ca2a1 100644
--- a/math/octave-forge-engine/Makefile
+++ b/math/octave-forge-engine/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= does not build with octave version >= 4.4.0
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
GNU_CONFIGURE= yes
CONFIGURE_ENV+= HOME=${WRKSRC}
diff --git a/math/octave-forge-fl-core/Makefile b/math/octave-forge-fl-core/Makefile
index 8557f5323e6a..2a48a2773969 100644
--- a/math/octave-forge-fl-core/Makefile
+++ b/math/octave-forge-fl-core/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
BROKEN= does not build with octave >= 4.4.0
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
diff --git a/math/octave-forge-pdb/Makefile b/math/octave-forge-pdb/Makefile
index 998011de9ca5..3a05b28c36f8 100644
--- a/math/octave-forge-pdb/Makefile
+++ b/math/octave-forge-pdb/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= does not build with octave version >= 4.4.0
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
GNU_CONFIGURE= yes
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 37a3455fa82d..487bab451289 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -14,6 +14,8 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= Makefiles use hacks that don't work with recent automake. Try net/ntopng
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
LIB_DEPENDS= libgdbm.so:databases/gdbm \
libevent.so:devel/libevent
diff --git a/net/py-libstorj/Makefile b/net/py-libstorj/Makefile
index d8591d5dff1b..38c48b29d368 100644
--- a/net/py-libstorj/Makefile
+++ b/net/py-libstorj/Makefile
@@ -12,6 +12,8 @@ COMMENT= Python bindings for libstorj
LICENSE= LGPL21+
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libstorj.so:net/libstorj
diff --git a/net/py-pcs/Makefile b/net/py-pcs/Makefile
index 36dbffb05814..c6871795f6ca 100644
--- a/net/py-pcs/Makefile
+++ b/net/py-pcs/Makefile
@@ -15,6 +15,8 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
BROKEN= fails to build with cython 0.28
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
PORTDOCS= pcs.pdf
PORTEXAMPLES= *
diff --git a/net/scribe/Makefile b/net/scribe/Makefile
index e6da415b4564..117812f770e6 100644
--- a/net/scribe/Makefile
+++ b/net/scribe/Makefile
@@ -12,6 +12,8 @@ COMMENT= Aggregating log data streamed in real time
LICENSE= APACHE20
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
BUILD_DEPENDS= fb303>0:devel/fb303 \
thrift:devel/thrift
diff --git a/textproc/ots/Makefile b/textproc/ots/Makefile
index 7da76d8c386f..cb0296d60fdb 100644
--- a/textproc/ots/Makefile
+++ b/textproc/ots/Makefile
@@ -14,6 +14,8 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= unfetchable
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
LIB_DEPENDS= libpopt.so:devel/popt
diff --git a/x11-wm/qtile/Makefile b/x11-wm/qtile/Makefile
index 8c490165a725..55f2a2037bf9 100644
--- a/x11-wm/qtile/Makefile
+++ b/x11-wm/qtile/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= does not run
-EXPIRATION_DATE= 2018-12-31
+EXPIRATION_DATE= 2018-12-19
BROKEN= does not run
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xpyb>0:x11/xpyb@${PY_FLAVOR} \
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index b5f5a3f8ef35..68a8f846af12 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -13,6 +13,8 @@ COMMENT= Xpra gives you persistent remote applications for X
LICENSE= GPLv2
BROKEN= fails to build with cython 0.28
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>2:x11-toolkits/py-gtk2@${PY_FLAVOR} \
${PYNUMPY}
diff --git a/x11/xpyb/Makefile b/x11/xpyb/Makefile
index f540eeeab107..2d0a447af4ae 100644
--- a/x11/xpyb/Makefile
+++ b/x11/xpyb/Makefile
@@ -12,6 +12,8 @@ MAINTAINER= ashish@FreeBSD.org
COMMENT= Python bindings to access X Window System protocol via libxcb
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-12-19
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-proto.pc:x11/xcb-proto \
xcb-proto>=1.7.1:x11/xcb-proto