aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/belle-sip/Makefile21
-rw-r--r--net/belle-sip/distinfo4
-rw-r--r--net/belle-sip/files/patch-configure16
-rw-r--r--net/belle-sip/files/patch-src-belle_sip_headers_impl.c35
-rw-r--r--net/belle-sip/files/patch-src_dns.c2
-rw-r--r--net/belle-sip/pkg-plist1
-rw-r--r--net/linphone/Makefile19
-rw-r--r--net/linphone/distinfo4
-rw-r--r--net/linphone/files/patch-configure20
-rw-r--r--net/linphone/files/patch-coreapi__presence.c15
-rw-r--r--net/linphone/pkg-plist13
-rw-r--r--net/mediastreamer/Makefile17
-rw-r--r--net/mediastreamer/distinfo4
-rw-r--r--net/mediastreamer/files/patch-src-base-msfactory.c11
-rw-r--r--net/mediastreamer/files/patch-src__audiofilters__oss.c24
-rw-r--r--net/mediastreamer/files/patch-src__base__mscommon.c11
-rw-r--r--net/mediastreamer/pkg-descr18
-rw-r--r--net/mediastreamer/pkg-plist25
-rw-r--r--net/ortp/Makefile9
-rw-r--r--net/ortp/distinfo4
-rw-r--r--net/ortp/files/patch-configure10
-rw-r--r--net/ortp/files/patch-ortp.pc.in6
-rw-r--r--net/ortp/pkg-plist4
23 files changed, 172 insertions, 121 deletions
diff --git a/net/belle-sip/Makefile b/net/belle-sip/Makefile
index d2ced60f79c1..76d9f16d7bc2 100644
--- a/net/belle-sip/Makefile
+++ b/net/belle-sip/Makefile
@@ -1,14 +1,13 @@
# $FreeBSD$
PORTNAME= belle-sip
-PORTVERSION= 1.3.0
-PORTREVISION= 2
+PORTVERSION= 1.4.0
CATEGORIES= net java
MASTER_SITES= SAVANNAH/linphone/${PORTNAME}/:source1 \
http://www.antlr3.org/download/:source2
-DISTFILES= belle-sip-1.3.0.tar.gz:source1 \
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:source1 \
antlr-3.4-complete.jar:source2
-EXTRACT_ONLY= belle-sip-1.3.0.tar.gz
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= bofh@FreeBSD.org
COMMENT= Belle-sip is a SIP (RFC3261) implementation written in C
@@ -21,7 +20,8 @@ LIB_DEPENDS= libantlr3c.so:${PORTSDIR}/devel/libantlr3c
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --disable-tests
+CONFIGURE_ARGS= --disable-silent-rules --disable-strict --disable-tests \
+ --with-antlr=${LOCALBASE}
INSTALL_TARGET= install-strip
USES= compiler:c11 gmake libtool pathfix
USE_JAVA= yes
@@ -33,20 +33,13 @@ OPTIONS_DEFINE= POLARSSL
OPTIONS_DEFAULT=POLARSSL
POLARSSL_CONFIGURE_ENABLE= tls
-POLARSSL_LIB_DEPENDS= libpolarssl.so:${PORTSDIR}/security/polarssl
+POLARSSL_LIB_DEPENDS= libpolarssl.so.8:${PORTSDIR}/security/polarssl13
post-extract:
@${CP} ${DISTDIR}/antlr-3.4-complete.jar ${WRKDIR}/antlr-complete.jar
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|%%WRKDIR%%|${WRKDIR}|' -e 's|-lrt||' \
${WRKSRC}/configure
-.if ${CHOSEN_COMPILER_TYPE} == clang && (${OSVERSION} < 902512 || (${OSVERSION} >= 1000000 && ${OSVERSION} < 1000707))
- @${REINPLACE_CMD} 's, -fms-extensions,,' ${WRKSRC}/configure
-.endif
- @${REINPLACE_CMD} -e 's|-timezone||' \
- ${WRKSRC}/src/belle_sip_headers_impl.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/belle-sip/distinfo b/net/belle-sip/distinfo
index 65601a0f7299..5ba1e89427fe 100644
--- a/net/belle-sip/distinfo
+++ b/net/belle-sip/distinfo
@@ -1,4 +1,4 @@
-SHA256 (belle-sip-1.3.0.tar.gz) = 50f0106903bdf67fcbc674dd6b3ec2930d5a5e735d9ba70dbe21f4bc76f08091
-SIZE (belle-sip-1.3.0.tar.gz) = 665281
+SHA256 (belle-sip-1.4.0.tar.gz) = fffae80a4376125c17e77c2451ff8b01e28fedcc3219c7dd027051b6f9769dd3
+SIZE (belle-sip-1.4.0.tar.gz) = 742966
SHA256 (antlr-3.4-complete.jar) = 9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7
SIZE (antlr-3.4-complete.jar) = 2388361
diff --git a/net/belle-sip/files/patch-configure b/net/belle-sip/files/patch-configure
index 629d481f1937..1ccfa2118654 100644
--- a/net/belle-sip/files/patch-configure
+++ b/net/belle-sip/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig
+--- configure.orig 2015-03-11 16:44:12 UTC
+++ configure
-@@ -15655,10 +15655,10 @@
+@@ -16787,10 +16787,10 @@ libresolv_have_res_get_servers=no
resolv_h_hav_res_ndestroy=no
LIBS_save=$LIBS
@@ -12,17 +12,17 @@
#include <resolv.h>
int
main ()
-@@ -15683,7 +15683,8 @@
+@@ -16814,7 +16814,8 @@ fi
+ rm -f core conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
- ac_fn_c_check_decl "$LINENO" "res_ndestroy
-- " "ac_cv_have_decl_res_ndestroy___" "#include <resolv.h>
-+ " "ac_cv_have_decl_res_ndestroy___" "#include <netinet/in.h>
+-ac_fn_c_check_decl "$LINENO" "res_ndestroy" "ac_cv_have_decl_res_ndestroy" "#include <resolv.h>
++ac_fn_c_check_decl "$LINENO" "res_ndestroy" "ac_cv_have_decl_res_ndestroy" "#include <netinet/in.h>
+#include <resolv.h>
"
- if test "x$ac_cv_have_decl_res_ndestroy___" = xyes; then :
+ if test "x$ac_cv_have_decl_res_ndestroy" = xyes; then :
resolv_h_hav_res_ndestroy=yes
-@@ -15748,17 +15749,11 @@
+@@ -16877,17 +16878,11 @@ fi
if test $ANTLR = "no" ; then
diff --git a/net/belle-sip/files/patch-src-belle_sip_headers_impl.c b/net/belle-sip/files/patch-src-belle_sip_headers_impl.c
new file mode 100644
index 000000000000..c71bb9a5e56f
--- /dev/null
+++ b/net/belle-sip/files/patch-src-belle_sip_headers_impl.c
@@ -0,0 +1,35 @@
+--- src/belle_sip_headers_impl.c.orig 2015-01-20 10:39:04 UTC
++++ src/belle_sip_headers_impl.c
+@@ -1663,7 +1663,6 @@ BELLESIP_EXPORT time_t belle_sip_header_
+ char tmp2[16] ={0};
+ int i,j;
+ time_t seconds;
+- time_t adjust_timezone;
+
+
+ /* time headers are in GMT as spec says */
+@@ -1685,22 +1684,12 @@ BELLESIP_EXPORT time_t belle_sip_header_
+ return (time_t)-1;
+ success:
+ ret.tm_isdst=0;
+-
+-#if TARGET_IPHONE_SIMULATOR
+- /* 'timezone' is buggy on iOS simulator, use the timegm() function to convert to UTC timestamp
+- and discard the adjust timezone value */
+ seconds = timegm(&ret);
+- adjust_timezone = 0;
+-#else
+- seconds = mktime(&ret);
+- adjust_timezone = timezone;
+-#endif
+-
+ if (seconds==(time_t)-1){
+- belle_sip_error("mktime() failed: %s",strerror(errno));
++ belle_sip_error("timegm() failed: %s",strerror(errno));
+ return (time_t)-1;
+ }
+- return seconds-adjust_timezone;
++ return seconds;
+ }
+
+ BELLESIP_EXPORT void belle_sip_header_date_set_time(belle_sip_header_date_t *obj, const time_t *utc_time){
diff --git a/net/belle-sip/files/patch-src_dns.c b/net/belle-sip/files/patch-src_dns.c
index 3b05417a1059..1d489299c5cd 100644
--- a/net/belle-sip/files/patch-src_dns.c
+++ b/net/belle-sip/files/patch-src_dns.c
@@ -4,7 +4,7 @@
union res_sockaddr_union addresses[3];
int i,error;
-+ bzero(&res, sizeof(res));
++ memset(&res, 0, sizeof(res));
if ((error = res_ninit(&res))) {
return error;
}
diff --git a/net/belle-sip/pkg-plist b/net/belle-sip/pkg-plist
index eb1faa980b68..e00d8f5519bb 100644
--- a/net/belle-sip/pkg-plist
+++ b/net/belle-sip/pkg-plist
@@ -1,6 +1,7 @@
include/belle-sip/auth-helper.h
include/belle-sip/belle-sdp.h
include/belle-sip/belle-sip.h
+include/belle-sip/bodyhandler.h
include/belle-sip/defs.h
include/belle-sip/dialog.h
include/belle-sip/dict.h
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index 187d7fa4f05f..7e9ed0adcf5a 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -1,11 +1,10 @@
# $FreeBSD$
PORTNAME= linphone
-PORTVERSION= 3.7.0
-PORTREVISION= 3
+PORTVERSION= 3.8.1
PORTEPOCH= 1
CATEGORIES= net
-MASTER_SITES= SAVANNAH/linphone/3.7.x/sources
+MASTER_SITES= SAVANNAH/linphone/3.8.x/sources
MAINTAINER= tijl@FreeBSD.org
COMMENT= SIP client supporting voice/video calls and text messaging
@@ -13,28 +12,30 @@ COMMENT= SIP client supporting voice/video calls and text messaging
LIB_DEPENDS= libbellesip.so:${PORTSDIR}/net/belle-sip \
libmediastreamer_base.so:${PORTSDIR}/net/mediastreamer \
libortp.so:${PORTSDIR}/net/ortp \
+ libpolarssl.so.8:${PORTSDIR}/security/polarssl13 \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
CONFLICTS_INSTALL= linphone-base-[0-9]*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-deplibs-link --disable-speex --disable-strict \
- --disable-tutorials \
+CONFIGURE_ARGS= --disable-deplibs-link --disable-silent-rules \
+ --disable-speex --disable-strict --disable-tutorials \
--enable-external-mediastreamer --enable-external-ortp \
+ --enable-lime --with-polarssl=${LOCALBASE} \
--with-readline=${LOCALBASE}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
USES= gmake libtool pathfix pkgconfig readline:port
USE_GNOME= gtk20 intltool libxml2
USE_LDCONFIG= yes
-OPTIONS_DEFINE= IPV6 NLS NOTIFY UPNP VIDEO
+OPTIONS_DEFINE= NLS NOTIFY UPNP VIDEO
OPTIONS_DEFAULT=NOTIFY UPNP VIDEO
OPTIONS_SUB= yes
-IPV6_CONFIGURE_ENABLE= ipv6
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
@@ -51,10 +52,6 @@ CONFIGURE_ARGS+=--enable-debug
.endif
post-patch:
- @${REINPLACE_CMD} '/linphonec_LDADD =/s/=/= $$(MEDIASTREAMER_LIBS)/' \
- ${WRKSRC}/console/Makefile.in
- @${REINPLACE_CMD} '/linphone_LDADD =/s/=/= $$(MEDIASTREAMER_LIBS)/' \
- ${WRKSRC}/gtk/Makefile.in
.for l in C fr it ja
@${REINPLACE_CMD} '/^install-data-local:/,/^$$/d' \
${WRKSRC}/share/$l/Makefile.in
diff --git a/net/linphone/distinfo b/net/linphone/distinfo
index e85094e3cded..3fcec6661048 100644
--- a/net/linphone/distinfo
+++ b/net/linphone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (linphone-3.7.0.tar.gz) = ff792b1cfc132fc4a54ae6c861c99d4139ec6f4b8ff4092ea2ce1e19d44c151c
-SIZE (linphone-3.7.0.tar.gz) = 12090691
+SHA256 (linphone-3.8.1.tar.gz) = 8d45bc9ec9a795a29bfdbf60c665bdfa81b46f3c83e870d50ad7c3f25156bca7
+SIZE (linphone-3.8.1.tar.gz) = 15327283
diff --git a/net/linphone/files/patch-configure b/net/linphone/files/patch-configure
index d97d2dd4c993..a92ea8b43140 100644
--- a/net/linphone/files/patch-configure
+++ b/net/linphone/files/patch-configure
@@ -1,8 +1,8 @@
---- configure.orig
+--- configure.orig 2015-04-02 09:04:58 UTC
+++ configure
-@@ -19486,12 +19486,6 @@
- ;;
- esac
+@@ -20382,12 +20382,6 @@ $as_echo "#define HAVE_NOTIFY1 1" >>conf
+ fi
+ fi
-case "$host_os" in
- *freebsd*)
@@ -13,12 +13,12 @@
case "$host_cpu" in
*arm*)
-@@ -20993,7 +20987,7 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
+@@ -22149,7 +22143,7 @@ fi
+ fi
+ if test "$found_sqlite" = "yes"; then
- SQLITE3_CFLAGS+="-DMSG_STORAGE_ENABLED"
+ SQLITE3_CFLAGS="$SQLITE3_CFLAGS -DMSG_STORAGE_ENABLED"
-
-
- enable_msg_storage=true
+ if test "$build_macos" = "yes" -o "$ios_found" = "yes"; then
+ SQLITE3_LIBS+=" -liconv"
+ fi
diff --git a/net/linphone/files/patch-coreapi__presence.c b/net/linphone/files/patch-coreapi__presence.c
index 95829fe4a610..e685d5bb6028 100644
--- a/net/linphone/files/patch-coreapi__presence.c
+++ b/net/linphone/files/patch-coreapi__presence.c
@@ -1,11 +1,18 @@
---- coreapi/presence.c.orig
+--- coreapi/presence.c.orig 2015-04-02 09:04:01 UTC
+++ coreapi/presence.c
-@@ -167,7 +167,7 @@
- ms_error("mktime() failed: %s", strerror(errno));
+@@ -164,12 +164,12 @@ static time_t parse_timestamp(const char
+ ret.tm_mon--;
+ ret.tm_year -= 1900;
+ ret.tm_isdst = 0;
+- seconds = mktime(&ret);
++ seconds = timegm(&ret);
+ if (seconds == (time_t)-1) {
+- ms_error("mktime() failed: %s", strerror(errno));
++ ms_error("timegm() failed: %s", strerror(errno));
return (time_t)-1;
}
- return seconds - timezone;
+ return seconds;
}
- static char * timestamp_to_string(time_t timestamp) {
+ char * linphone_timestamp_to_rfc3339_string(time_t timestamp) {
diff --git a/net/linphone/pkg-plist b/net/linphone/pkg-plist
index fda482996e91..6e73229b8e4f 100644
--- a/net/linphone/pkg-plist
+++ b/net/linphone/pkg-plist
@@ -1,10 +1,16 @@
+bin/auto_answer
bin/linphone
bin/linphonec
bin/linphonecsh
bin/lp-gen-wrappers
bin/lpc2xml_test
bin/xml2lpc_test
+include/linphone/buffer.h
+include/linphone/call_log.h
+include/linphone/call_params.h
+include/linphone/content.h
include/linphone/event.h
+include/linphone/linphone_tunnel.h
include/linphone/linphonecore.h
include/linphone/linphonecore_utils.h
include/linphone/linphonefriend.h
@@ -24,9 +30,13 @@ man/man1/linphone.1.gz
man/man1/linphonec.1.gz
man/man1/linphonecsh.1.gz
man/man1/sipomatic.1.gz
+share/appdata/linphone.appdata.xml
+share/applications/audio-assistant.desktop
share/applications/linphone.desktop
+share/icons/hicolor/48x48/apps/linphone.png
%%DATADIR%%/COPYING
%%DATADIR%%/about.ui
+%%DATADIR%%/audio_assistant.ui
%%DATADIR%%/buddylookup.ui
%%DATADIR%%/call_logs.ui
%%DATADIR%%/call_statistics.ui
@@ -45,6 +55,7 @@ share/applications/linphone.desktop
%%DATADIR%%/stock_people.png
%%DATADIR%%/tunnel_config.ui
%%DATADIR%%/waiting.ui
+%%NLS%%share/locale/ar/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/cs/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/de/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/es/LC_MESSAGES/linphone.mo
@@ -60,6 +71,7 @@ share/applications/linphone.desktop
%%NLS%%share/locale/ru/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/sr/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/sv/LC_MESSAGES/linphone.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/linphone.mo
share/pixmaps/linphone/active_chat.png
@@ -99,6 +111,7 @@ share/pixmaps/linphone/stopcall-red.png
share/pixmaps/linphone/stopcall-small.png
share/sounds/linphone/hello16000.wav
share/sounds/linphone/hello8000.wav
+share/sounds/linphone/incoming_chat.wav
share/sounds/linphone/ringback.wav
share/sounds/linphone/rings/bigben.wav
share/sounds/linphone/rings/oldphone-mono-30s.caf
diff --git a/net/mediastreamer/Makefile b/net/mediastreamer/Makefile
index c80f82cfc692..876d285217f3 100644
--- a/net/mediastreamer/Makefile
+++ b/net/mediastreamer/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mediastreamer
-PORTVERSION= 2.10.0
-PORTREVISION= 8
+PORTVERSION= 2.11.1
CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/mediastreamer
@@ -13,14 +12,18 @@ COMMENT= Real-time audio and video streaming and processing
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libortp.so:${PORTSDIR}/net/ortp
+LIB_DEPENDS= libortp.so:${PORTSDIR}/net/ortp \
+ libsrtp.so:${PORTSDIR}/net/libsrtp \
+ libbzrtp.so:${PORTSDIR}/security/libbzrtp \
+ libpolarssl.so.8:${PORTSDIR}/security/polarssl13
CONFLICTS_INSTALL= linphone-base-[0-9]*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-alsa --disable-pulseaudio \
+CONFIGURE_ARGS= --disable-alsa --disable-matroska --disable-pulseaudio \
--disable-silent-rules --disable-strict \
- --with-gsm=${LOCALBASE} xxd_found=yes
+ --with-gsm=${LOCALBASE} --with-srtp=${LOCALBASE} \
+ --with-polarssl=${LOCALBASE} xxd_found=yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
@@ -28,7 +31,7 @@ USES= gettext-tools gmake libtool pathfix pkgconfig
USE_GNOME= intlhack
USE_LDCONFIG= yes
-OPTIONS_DEFINE= IPV6 NLS UPNP VIDEO
+OPTIONS_DEFINE= NLS UPNP VIDEO
OPTIONS_GROUP= AUDIOOPT VIDEOOPT
OPTIONS_GROUP_AUDIOOPT= GSM OPUS SPANDSP SPEEX
OPTIONS_GROUP_VIDEOOPT= FFMPEG GLX THEORA V4L VPX XVIDEO
@@ -48,8 +51,6 @@ GLX_USE= GL=glew
GSM_CONFIGURE_ENABLE= gsm
GSM_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
-IPV6_CONFIGURE_ENABLE= ipv6
-
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
diff --git a/net/mediastreamer/distinfo b/net/mediastreamer/distinfo
index 3a712513ff2f..7efc2884354d 100644
--- a/net/mediastreamer/distinfo
+++ b/net/mediastreamer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mediastreamer-2.10.0.tar.gz) = 808d87c47b7e4c79698765894cbde74575011059b33a76280aa567f099dce1ea
-SIZE (mediastreamer-2.10.0.tar.gz) = 3604794
+SHA256 (mediastreamer-2.11.1.tar.gz) = eda29f98f8fa73f9a7da48e3ab00e1d3015b6bcffac98e06c27e7b9dc524db3d
+SIZE (mediastreamer-2.11.1.tar.gz) = 6347710
diff --git a/net/mediastreamer/files/patch-src-base-msfactory.c b/net/mediastreamer/files/patch-src-base-msfactory.c
new file mode 100644
index 000000000000..f69a79abb241
--- /dev/null
+++ b/net/mediastreamer/files/patch-src-base-msfactory.c
@@ -0,0 +1,11 @@
+--- src/base/msfactory.c.orig 2015-03-02 11:36:25 UTC
++++ src/base/msfactory.c
+@@ -157,7 +157,7 @@ void ms_factory_init(MSFactory *obj){
+ GetNativeSystemInfo( &sysinfo );
+
+ num_cpu = sysinfo.dwNumberOfProcessors;
+-#elif __APPLE__ || __linux
++#elif __APPLE__ || __linux || __DragonFly__ || __FreeBSD__
+ num_cpu = sysconf( _SC_NPROCESSORS_CONF); /*check the number of processors configured, not just the one that are currently active.*/
+ #elif __QNX__
+ num_cpu = _syspage_ptr->num_cpu;
diff --git a/net/mediastreamer/files/patch-src__audiofilters__oss.c b/net/mediastreamer/files/patch-src__audiofilters__oss.c
index 5fea0a3a6f61..be2241878ab5 100644
--- a/net/mediastreamer/files/patch-src__audiofilters__oss.c
+++ b/net/mediastreamer/files/patch-src__audiofilters__oss.c
@@ -1,22 +1,21 @@
---- src/audiofilters/oss.c.orig
+--- src/audiofilters/oss.c.orig 2015-01-30 09:36:13 UTC
+++ src/audiofilters/oss.c
-@@ -41,7 +41,7 @@
+@@ -41,7 +41,7 @@ static int configure_fd(int fd, int bits
{
int p=0,cond=0;
int i=0;
- int min_size=0,blocksize=512;
+ int min_size=0, blocksize=0;
int err;
-
+
//g_message("opening sound device");
-@@ -77,54 +77,18 @@
- if (err<0){
+@@ -78,54 +78,17 @@ static int configure_fd(int fd, int bits
ms_warning("oss_open: can't set mono/stereo mode:%s.",strerror(errno));
}
--
+
- if (rate==16000) blocksize=4096; /* oss emulation is not very good at 16khz */
- else blocksize=blocksize*(rate/8000);
-
+-
ioctl(fd, SNDCTL_DSP_GETBLKSIZE, &min_size);
- /**
@@ -24,8 +23,9 @@
- */
- if (min_size>blocksize) {
- int size_selector=0;
+- int frag;
- while ((blocksize >> size_selector) != 1)size_selector++; /*compute selector blocksize = 1<< size_selector*/
-- int frag = (2 << 16) | (size_selector);
+- frag = (2 << 16) | (size_selector);
- if (ioctl(fd, SNDCTL_DSP_SETFRAGMENT, &frag) == -1) {
- ms_warning("This OSS driver does not support trying SNDCTL_DSP_SETFRAGMENT");
- ioctl(fd, SNDCTL_DSP_GETBLKSIZE, &min_size);
@@ -68,19 +68,19 @@
ms_message("/dev/dsp opened: rate=%i,bits=%i,stereo=%i blocksize=%i.",
- rate,bits,stereo,min_size);
+ rate,bits,stereo,blocksize);
-
+
/* start recording !!! Alex */
{
-@@ -134,7 +98,7 @@
+@@ -135,7 +98,7 @@ static int configure_fd(int fd, int bits
res=ioctl(fd, SNDCTL_DSP_SETTRIGGER, &fl);
if (res<0) ms_warning("OSS_TRIGGER: %s",strerror(errno));
- }
+ }
- *minsz=min_size;
+ *minsz=blocksize;
return fd;
}
-@@ -364,7 +328,11 @@
+@@ -365,7 +328,11 @@ static void * oss_thread(void *p){
}
}
if (d->pcmfd_write>=0){
diff --git a/net/mediastreamer/files/patch-src__base__mscommon.c b/net/mediastreamer/files/patch-src__base__mscommon.c
deleted file mode 100644
index 220de8e3c9f9..000000000000
--- a/net/mediastreamer/files/patch-src__base__mscommon.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/base/mscommon.c.orig 2014-02-19 12:07:16.569961000 +0100
-+++ src/base/mscommon.c 2014-07-11 10:07:30.000000000 +0200
-@@ -512,7 +512,7 @@
- GetSystemInfo( &sysinfo );
-
- num_cpu = sysinfo.dwNumberOfProcessors;
--#elif __APPLE__ || __linux
-+#elif __APPLE__ || __linux || __FreeBSD__
- num_cpu = sysconf( _SC_NPROCESSORS_ONLN );
- #elif __QNX__
- num_cpu = _syspage_ptr->num_cpu;
diff --git a/net/mediastreamer/pkg-descr b/net/mediastreamer/pkg-descr
index d8d26429960b..0da0db88d421 100644
--- a/net/mediastreamer/pkg-descr
+++ b/net/mediastreamer/pkg-descr
@@ -9,20 +9,26 @@ Features:
* Capture and playback from various platform dependent sound architectures
* Send and receive RTP streams
-* Encode and decode the following audio formats: speex, G711, GSM, iLBC,
+* Encode and decode the following audio formats: OPUS, speex, G711, GSM, iLBC,
AMR, AMR-WB, G722, SILK, G729, and video formats H263, theora, MPEG4,
H264 and VP8
+* RTP/AVPF support: RTCP control messages for video error recovery: PLI, SLI,
+ RPSI, FIR
+* Audio conferencing
+* Supports SRTP and ZRTP (encryption of voice and video)
+* Supports any webcam, based on OS's camera API: quicktime, directshow,
+ video4linux, android.camera
+* Acoustic echo cancellation using the speex echo canceler or webrtc AECm
* Read and write .wav files
-* Read YUV pictures from a camera based on platform dependents APIs
-* Optimized rendering of YUV pictures
+* Optimized rendering of YUV pictures, using OpenGL, DrawDib, X11/Xv
* Dual tones generation
* Custom tone detector
-* Echo cancelation, based on speex library or webrtc AEC on android
-* Audio conferencing
* Audio parametric equalizer
* Volume control, automatic gain control
-* ICE for optimized NAT traversal
+* ICE for optimized NAT traversal (RFC5246) to allow peer to peer audio and
+ video connections without media relay server
* Adaptive bitrate control algorithm: for automatic adaption of encoder
bitrate based on received RTCP feedback
+* Can use plugins to add new codecs, new sound input/output backends,...
WWW: http://www.linphone.org/eng/documentation/dev/mediastreamer2.html
diff --git a/net/mediastreamer/pkg-plist b/net/mediastreamer/pkg-plist
index 18f5a434fdfe..6f471465bd99 100644
--- a/net/mediastreamer/pkg-plist
+++ b/net/mediastreamer/pkg-plist
@@ -1,10 +1,16 @@
bin/mediastream
+bin/msaudiocmp
include/mediastreamer2/allfilters.h
include/mediastreamer2/bitratecontrol.h
+include/mediastreamer2/bits_rw.h
include/mediastreamer2/dsptools.h
+include/mediastreamer2/dtls_srtp.h
include/mediastreamer2/dtmfgen.h
+include/mediastreamer2/flowcontrol.h
+include/mediastreamer2/formats.h
include/mediastreamer2/ice.h
include/mediastreamer2/mediastream.h
+include/mediastreamer2/ms_srtp.h
include/mediastreamer2/msaudiomixer.h
include/mediastreamer2/mschanadapter.h
include/mediastreamer2/mscodecutils.h
@@ -13,33 +19,43 @@ include/mediastreamer2/msconference.h
include/mediastreamer2/msequalizer.h
include/mediastreamer2/mseventqueue.h
include/mediastreamer2/msextdisplay.h
+include/mediastreamer2/msfactory.h
include/mediastreamer2/msfileplayer.h
include/mediastreamer2/msfilerec.h
include/mediastreamer2/msfilter.h
+include/mediastreamer2/msgenericplc.h
include/mediastreamer2/msinterfaces.h
include/mediastreamer2/msitc.h
include/mediastreamer2/msjava.h
include/mediastreamer2/msjpegwriter.h
+include/mediastreamer2/msmediaplayer.h
include/mediastreamer2/msqueue.h
include/mediastreamer2/msrtp.h
include/mediastreamer2/mssndcard.h
+include/mediastreamer2/msutils.h
include/mediastreamer2/mstee.h
include/mediastreamer2/msticker.h
include/mediastreamer2/mstonedetector.h
include/mediastreamer2/msv4l.h
+include/mediastreamer2/msvaddtx.h
include/mediastreamer2/msvideo.h
include/mediastreamer2/msvideoout.h
include/mediastreamer2/msvolume.h
include/mediastreamer2/mswebcam.h
include/mediastreamer2/qualityindicator.h
include/mediastreamer2/rfc3984.h
+include/mediastreamer2/stun.h
+include/mediastreamer2/stun_udp.h
include/mediastreamer2/upnp_igd.h
+include/mediastreamer2/videostarter.h
+include/mediastreamer2/x11_helper.h
+include/mediastreamer2/zrtp.h
lib/libmediastreamer_base.so
-lib/libmediastreamer_base.so.3
-lib/libmediastreamer_base.so.3.0.0
+lib/libmediastreamer_base.so.4
+lib/libmediastreamer_base.so.4.0.0
lib/libmediastreamer_voip.so
-lib/libmediastreamer_voip.so.3
-lib/libmediastreamer_voip.so.3.0.0
+lib/libmediastreamer_voip.so.4
+lib/libmediastreamer_voip.so.4.0.0
libdata/pkgconfig/mediastreamer.pc
share/images/nowebcamCIF.jpg
%%NLS%%share/locale/cs/LC_MESSAGES/mediastreamer.mo
@@ -55,3 +71,4 @@ share/images/nowebcamCIF.jpg
%%NLS%%share/locale/ru/LC_MESSAGES/mediastreamer.mo
%%NLS%%share/locale/sv/LC_MESSAGES/mediastreamer.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/mediastreamer.mo
+@dir lib/mediastreamer/plugins
diff --git a/net/ortp/Makefile b/net/ortp/Makefile
index 4ced62b13772..0dc38819d3a2 100644
--- a/net/ortp/Makefile
+++ b/net/ortp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ortp
-PORTVERSION= 0.23.0
-PORTREVISION= 2
+PORTVERSION= 0.24.1
CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/ortp/sources
@@ -13,14 +12,10 @@ COMMENT= Real-time Transport Protocol (RTP) library
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libsrtp.so:${PORTSDIR}/net/libsrtp \
- libzrtpcppcore.so:${PORTSDIR}/security/libzrtpcppcore
-
CONFLICTS_INSTALL= linphone-base-[0-9]*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules --disable-strict \
- --enable-zrtp --with-srtp
+CONFIGURE_ARGS= --disable-silent-rules --disable-strict
INSTALL_TARGET= install-strip
USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
diff --git a/net/ortp/distinfo b/net/ortp/distinfo
index 880f7708417e..d94d8985a894 100644
--- a/net/ortp/distinfo
+++ b/net/ortp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ortp-0.23.0.tar.gz) = 91a5ada15f62ce5f08beceef4d0adb65469211e2f208bd96e493a8df9f84fcdb
-SIZE (ortp-0.23.0.tar.gz) = 540135
+SHA256 (ortp-0.24.1.tar.gz) = d1ecce20bed145186f727914f10f500d0594e30c2a234a276e7e12dcd8814cd5
+SIZE (ortp-0.24.1.tar.gz) = 557772
diff --git a/net/ortp/files/patch-configure b/net/ortp/files/patch-configure
index 54c11eafe26a..3b0ffc952588 100644
--- a/net/ortp/files/patch-configure
+++ b/net/ortp/files/patch-configure
@@ -8,13 +8,3 @@
;;
*mingw32ce)
CFLAGS="$CFLAGS -D_WIN32_WCE -D_WIN32_WINNT=0x0501 -DORTP_STATIC"
-@@ -12211,7 +12210,8 @@ if test "${srtp_prefix}" != "none" ; the
- SRTP_CFLAGS="-I${srtp_prefix}/include -I${srtp_prefix}/include/srtp"
- SRTP_LIBS="-L${srtp_prefix}/lib"
- fi
-- SRTP_LIBS="$SRTP_LIBS -lsrtp"
-+ SRTP_CFLAGS="$(pkg-config --cflags libsrtp)"
-+ SRTP_LIBS="$(pkg-config --libs libsrtp)"
-
- have_srtp=no
- CPPFLAGS_save=$CPPFLAGS
diff --git a/net/ortp/files/patch-ortp.pc.in b/net/ortp/files/patch-ortp.pc.in
index 3e96164d7d8a..27f75c97dd82 100644
--- a/net/ortp/files/patch-ortp.pc.in
+++ b/net/ortp/files/patch-ortp.pc.in
@@ -1,9 +1,9 @@
---- ortp.pc.in.orig 2010-02-08 14:38:31 UTC
+--- ortp.pc.in.orig 2015-01-30 09:36:41 UTC
+++ ortp.pc.in
@@ -6,5 +6,6 @@ includedir=@includedir@
Name: oRTP
- Description: Implement the RFC3550 (RTP) with a easy to use API with high and low level access.
- Version: @ORTP_PKGCONFIG_VERSION@
+ Description: Implement the RFC3550 (RTP) with a easy to use API with high and low level access.
+ Version: @ORTP_PKGCONFIG_VERSION@
-Libs: -L@libdir@ -lortp @ORTPDEPS_LIBS@
+Libs: -L@libdir@ -lortp
+Libs.private: @ORTPDEPS_LIBS@
diff --git a/net/ortp/pkg-plist b/net/ortp/pkg-plist
index f387e860eefa..90ffd7bb47ec 100644
--- a/net/ortp/pkg-plist
+++ b/net/ortp/pkg-plist
@@ -2,7 +2,6 @@ include/ortp/b64.h
include/ortp/event.h
include/ortp/logging.h
include/ortp/ortp.h
-include/ortp/ortp_srtp.h
include/ortp/payloadtype.h
include/ortp/port.h
include/ortp/rtcp.h
@@ -12,10 +11,7 @@ include/ortp/rtpsession.h
include/ortp/rtpsignaltable.h
include/ortp/sessionset.h
include/ortp/str_utils.h
-include/ortp/stun.h
-include/ortp/stun_udp.h
include/ortp/telephonyevents.h
-include/ortp/zrtp.h
lib/libortp.so
lib/libortp.so.9
lib/libortp.so.9.0.0