aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/iscsi-target/Makefile3
-rw-r--r--net/iscsi-target/files/patch-iscsiutil23
-rw-r--r--net/iscsi-target/pkg-message3
3 files changed, 28 insertions, 1 deletions
diff --git a/net/iscsi-target/Makefile b/net/iscsi-target/Makefile
index 05ed2cffcf74..8eedaa448195 100644
--- a/net/iscsi-target/Makefile
+++ b/net/iscsi-target/Makefile
@@ -7,7 +7,7 @@
PORTNAME= iscsi
PORTVERSION= 20080207
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.netbsd.org/pub/pkgsrc/distfiles/ \
http://www.magnesium.net/~mdf/distfiles/
@@ -55,3 +55,4 @@ post-install:
.endfor
.include <bsd.port.mk>
+ @${CAT} ${PKGMESSAGE}
diff --git a/net/iscsi-target/files/patch-iscsiutil b/net/iscsi-target/files/patch-iscsiutil
new file mode 100644
index 000000000000..05cc0e961104
--- /dev/null
+++ b/net/iscsi-target/files/patch-iscsiutil
@@ -0,0 +1,23 @@
+--- ../include/iscsiutil.h 2007-11-12 15:25:40.000000000 -0800
++++ ../include/iscsiutil.h 2008-04-18 21:31:18.000000000 -0700
+@@ -77,16 +77,20 @@
+ #define ISCSI_HTONLL6(x) (uint64_t) \
+ ( ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x0000ff0000000000uLL) >> 40)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x000000ff00000000uLL) >> 24)) \
++ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0xffffffffffff0000uLL) >> 16)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x00000000ff000000uLL) >> 8)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x0000000000ff0000uLL) << 8)) \
++ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x0000ffffffffffffuLL) << 16)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x000000000000ff00uLL) << 24)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x00000000000000ffuLL) << 40)))
+
+ #define ISCSI_NTOHLL6(x) (uint64_t) \
+ ( ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x0000ff0000000000uLL) >> 40)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x000000ff00000000uLL) >> 24)) \
++ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0xffffffffffff0000uLL) >> 16)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x00000000ff000000uLL) >> 8)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x0000000000ff0000uLL) << 8)) \
++ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x0000ffffffffffffuLL) << 16)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x000000000000ff00uLL) << 24)) \
+ | ((uint64_t)( ((uint64_t)(x) & (uint64_t)0x00000000000000ffuLL) << 40)))
+
diff --git a/net/iscsi-target/pkg-message b/net/iscsi-target/pkg-message
new file mode 100644
index 000000000000..688a30069ebb
--- /dev/null
+++ b/net/iscsi-target/pkg-message
@@ -0,0 +1,3 @@
+To run iscsi-target server from startup, add iscsi_target_enable="YES"
+to /etc/rc.conf. Extra options can be found in startup script.
+