aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/ocs-unix-agent/Makefile34
-rw-r--r--net-mgmt/ocs-unix-agent/distinfo3
-rw-r--r--net-mgmt/ocs-unix-agent/files/patch-Makefile.in11
-rw-r--r--net-mgmt/ocs-unix-agent/pkg-descr5
5 files changed, 54 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index af06ff554d12..f229bbd6965a 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -137,6 +137,7 @@
SUBDIR += nsca
SUBDIR += nsca-client
SUBDIR += nstreams
+ SUBDIR += ocs-unix-agent
SUBDIR += openvmps
SUBDIR += oproute
SUBDIR += ourmon
diff --git a/net-mgmt/ocs-unix-agent/Makefile b/net-mgmt/ocs-unix-agent/Makefile
new file mode 100644
index 000000000000..676887c7565c
--- /dev/null
+++ b/net-mgmt/ocs-unix-agent/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ocs-unix-agent
+# Date created: 8 May 2007
+# Whom: Dennis Cabooter
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocs-unix-agent
+PORTVERSION= 0.7
+CATEGORIES= net-mgmt
+MASTER_SITES= http://bfleisch.free.fr/ocs-solaris-client/
+
+MAINTAINER= freebsd@rootxs.org
+COMMENT= Keep track of the computers configuration and software
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= libxml2
+
+#NOTES: that's not a mistake it's a bug in configure.
+#Author will fix this with next uptream release.
+CONFIGURE_ARGS= --with-zlib=${PREFIW}/usr
+
+PLIST_SUB= RELEASE=${RELEASE}
+PLIST_FILES= bin/ocs-agent-freebsd-%%RELEASE%% \
+ bin/ocs-agent-freebsd-%%RELEASE%%.1007
+
+.include <bsd.port.pre.mk>
+
+RELEASE!= /usr/bin/uname -r
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/ocs-unix-agent/distinfo b/net-mgmt/ocs-unix-agent/distinfo
new file mode 100644
index 000000000000..31ac46990bf3
--- /dev/null
+++ b/net-mgmt/ocs-unix-agent/distinfo
@@ -0,0 +1,3 @@
+MD5 (ocs-unix-agent-0.7.tar.gz) = 7404c4d957d87007240df2340a4f9a69
+SHA256 (ocs-unix-agent-0.7.tar.gz) = e560c2d06abfe212f60ed8df5d98d08f9ecef3b93697d689398ebced9464689b
+SIZE (ocs-unix-agent-0.7.tar.gz) = 95497
diff --git a/net-mgmt/ocs-unix-agent/files/patch-Makefile.in b/net-mgmt/ocs-unix-agent/files/patch-Makefile.in
new file mode 100644
index 000000000000..b74f39993228
--- /dev/null
+++ b/net-mgmt/ocs-unix-agent/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Tue Mar 27 08:32:24 2007
++++ Makefile.in Tue Jun 5 14:34:09 2007
+@@ -732,7 +732,7 @@
+ install-exec-local:
+ ${INSTALL_PROGRAM} agent $(DESTDIR)/@bindir@/@AGENT_NAME@.@AGENT_VERSION_REV@
+ ${LN_S} @AGENT_NAME@.@AGENT_VERSION_REV@ $(DESTDIR)/@bindir@/@AGENT_NAME@
+- ${INSTALL_PROGRAM} -d $(DESTDIR)/@sysconfdir@
++ install -o root -g wheel -m 755 -d $(DESTDIR)/@sysconfdir@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/net-mgmt/ocs-unix-agent/pkg-descr b/net-mgmt/ocs-unix-agent/pkg-descr
new file mode 100644
index 000000000000..2157af66868c
--- /dev/null
+++ b/net-mgmt/ocs-unix-agent/pkg-descr
@@ -0,0 +1,5 @@
+Open Computer and Software Inventory Next Generation is an application designed
+to help a network or system administrator keep track of the computers
+configuration and software that are installed on the network
+
+WWW: http://www.ocsinventory-ng.org/