aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/cadubi/Makefile29
-rw-r--r--graphics/cadubi/distinfo1
-rw-r--r--graphics/cadubi/files/patch-CADUBI_pl32
-rw-r--r--graphics/cadubi/files/patch-cadubi9
-rw-r--r--graphics/cadubi/pkg-comment1
-rw-r--r--graphics/cadubi/pkg-descr9
-rw-r--r--graphics/cadubi/pkg-plist4
8 files changed, 86 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9fea1a7e8be8..225a01360834 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -16,6 +16,7 @@
SUBDIR += avifile
SUBDIR += backfract
SUBDIR += blender
+ SUBDIR += cadubi
SUBDIR += camediaplay
SUBDIR += camserv
SUBDIR += chbg
diff --git a/graphics/cadubi/Makefile b/graphics/cadubi/Makefile
new file mode 100644
index 000000000000..b206075b5637
--- /dev/null
+++ b/graphics/cadubi/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: cadubi
+# Date created: 24 Aug 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cadubi
+PORTVERSION= 1.1b1
+CATEGORIES= graphics editors
+MASTER_SITES= ftp://logicallemon.com/pub/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cadubi ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/CADUBI.pl ${PREFIX}/libexec
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/cadubi
+ ${INSTALL_DATA} ${WRKSRC}/CADUBI.help ${PREFIX}/share/doc/cadubi
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/cadubi/distinfo b/graphics/cadubi/distinfo
new file mode 100644
index 000000000000..2df0f64ca91e
--- /dev/null
+++ b/graphics/cadubi/distinfo
@@ -0,0 +1 @@
+MD5 (cadubi_1.1b1.tar.gz) = 1645579fa6db7cfbea5810fc32548622
diff --git a/graphics/cadubi/files/patch-CADUBI_pl b/graphics/cadubi/files/patch-CADUBI_pl
new file mode 100644
index 000000000000..d7bbb51fb3e3
--- /dev/null
+++ b/graphics/cadubi/files/patch-CADUBI_pl
@@ -0,0 +1,32 @@
+--- CADUBI.pl.orig Thu Jan 27 03:54:45 2000
++++ CADUBI.pl Sun Jul 29 01:10:28 2001
+@@ -59,6 +59,7 @@ $AUDIBLE = 1; # beep unless -m, --mute
+ $status_changed = 1; # used with &status so we don't constantly redraw.
+ $current_filename = undef; # name of file we're working with
+ $cadubi_done = 0; # main loop var
++$Helpfile = $Bin . "/../share/doc/cadubi";
+
+ # runtime statements
+ &initKeys(); # setup %controlkeys and %keymap
+@@ -716,10 +717,10 @@ sub HandleKeystroke {
+
+ # help
+ if (ord($key) == $keymap{'^h'}) { #Help
+- if (-e $Bin.'/CADUBI.help') {
++ if (-e $Helpfile.'/CADUBI.help') {
+ my @oldmap = @charmap;
+ my @oldpos = @pos;
+- &readfile($Bin.'/CADUBI.help');
++ &readfile($Helpfile.'/CADUBI.help');
+ &status('Press a key to continue...', 1);
+ my $temp = ReadKey(0);
+ @charmap = @oldmap;
+@@ -729,7 +730,7 @@ sub HandleKeystroke {
+ &status;
+ } else {
+ &beep;
+- &status("'".$Bin."/CADUBI.help' not available");
++ &status("'".$Helpfile."/CADUBI.help' not available");
+ }
+ return 0;
+ }
diff --git a/graphics/cadubi/files/patch-cadubi b/graphics/cadubi/files/patch-cadubi
new file mode 100644
index 000000000000..ec1b8b9f05e0
--- /dev/null
+++ b/graphics/cadubi/files/patch-cadubi
@@ -0,0 +1,9 @@
+--- cadubi.orig Thu Jan 27 03:54:51 2000
++++ cadubi Sun Jul 29 01:10:59 2001
+@@ -32,5 +32,5 @@ use FindBin qw($Bin); use lib "$Bin/../l
+ my $CADUBI_Arguments = undef;
+ $CADUBI_Arguments .= ' --mute' unless $AUDIBLE;
+ $CADUBI_Arguments .= ' '.$ADD_OPS if $ADD_OPS;
+-exec ('perl '.$Bin.'/CADUBI.pl'.$CADUBI_Arguments.' '.join(' ',@ARGV));
++exec ('perl '.$Bin.'/../libexec/CADUBI.pl'.$CADUBI_Arguments.' '.join(' ',@ARGV));
+
diff --git a/graphics/cadubi/pkg-comment b/graphics/cadubi/pkg-comment
new file mode 100644
index 000000000000..dd5fa131d224
--- /dev/null
+++ b/graphics/cadubi/pkg-comment
@@ -0,0 +1 @@
+ASCII drawing utility
diff --git a/graphics/cadubi/pkg-descr b/graphics/cadubi/pkg-descr
new file mode 100644
index 000000000000..0f001a199e3b
--- /dev/null
+++ b/graphics/cadubi/pkg-descr
@@ -0,0 +1,9 @@
+CADUBI is an application written in Perl that allows you to
+draw text-based images that are viewable on typical unix-based
+consoles. Usually the applications that emulate these
+consoles support various text modes, such as background and
+foreground colors, bold, and inverse. This text art, commonly
+called "ASCII art," is used in various places such as online
+BBSes, email and login prompts.
+
+WWW: http://www.logicallemon.com/cadubi/
diff --git a/graphics/cadubi/pkg-plist b/graphics/cadubi/pkg-plist
new file mode 100644
index 000000000000..a2c4e769eac2
--- /dev/null
+++ b/graphics/cadubi/pkg-plist
@@ -0,0 +1,4 @@
+bin/cadubi
+libexec/CADUBI.pl
+%%PORTDOCS%%share/doc/cadubi/CADUBI.help
+%%PORTDOCS%%@dirrm share/doc/cadubi