aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--Mk/bsd.gstreamer.mk4
-rw-r--r--audio/gstreamer-plugins-jack/Makefile17
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common3
4 files changed, 22 insertions, 3 deletions
diff --git a/MOVED b/MOVED
index a4adb96be4fa..378fa192b78f 100644
--- a/MOVED
+++ b/MOVED
@@ -2242,7 +2242,6 @@ sysutils/gstreamer-plugins-cdio|sysutils/gstreamer-plugins-cdio80|2006-04-29|Not
multimedia/gstreamer-plugins-dirac|multimedia/gstreamer-plugins-dirac80|2006-04-29|Not part of gstreamer 0.10 yet
graphics/gstreamer-plugins-gdkpixbuf|graphics/gstreamer-plugins-gdkpixbuf80|2006-04-29|Not part of gstreamer 0.10 yet
graphics/gstreamer-plugins-hermes|graphics/gstreamer-plugins-hermes80|2006-04-29|Not part of gstreamer 0.10 yet
-audio/gstreamer-plugins-jack|audio/gstreamer-plugins-jack80|2006-04-29|Not part of gstreamer 0.10 yet
multimedia/gstreamer-plugins-libfame|multimedia/gstreamer-plugins-libfame80|2006-04-29|Not part of gstreamer 0.10 yet
graphics/gstreamer-plugins-libmng|graphics/gstreamer-plugins-libmng80|2006-04-29|Not part of gstreamer 0.10 yet
audio/gstreamer-plugins-mikmod|audio/gstreamer-plugins-mikmod80|2006-04-29|Not part of gstreamer 0.10 yet
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 76c94a35f1ad..29612a13990a 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -62,8 +62,8 @@ GST80_SHLIB_VERSION= 1
#
_USE_GSTREAMER_ALL= a52dec aalib annodex bad bz2 cairo cdaudio cdparanoia dts \
dv dvd esound faac faad ffmpeg flac gconf gnomevfs \
- gnonlin good gsm hal ivorbis jpeg ladspa lame libcaca \
- libmms libpng libvisual mad mpeg2dec \
+ gnonlin good gsm hal ivorbis jack jpeg ladspa lame \
+ libcaca libmms libpng libvisual mad mpeg2dec \
musepack neon ogg pango pulse python sdl shout2 sidplay \
speex theora ugly vorbis wavpack xvid
_USE_GSTREAMER80_ALL= a52dec aalib artsd audiofile cairo cdaudio cdio cdparanoia \
diff --git a/audio/gstreamer-plugins-jack/Makefile b/audio/gstreamer-plugins-jack/Makefile
new file mode 100644
index 000000000000..d014642c1d0d
--- /dev/null
+++ b/audio/gstreamer-plugins-jack/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-jack
+# Date created: 3 Oct 2004
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= audio
+
+COMMENT= Gstreamer low-latency audio server plugin
+
+GST_PLUGIN= jack
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 3e96b3fc745a..cf902551d98d 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -215,6 +215,9 @@ gst_hal_LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
gst_hal_PLIST_FILES= ${GST_LIB_DIR}/libgsthalelements.a \
${GST_LIB_DIR}/libgsthalelements.la \
${GST_LIB_DIR}/libgsthalelements.so
+# jack
+gst_jack_LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+gst_jack_DIST= bad
# jpeg
gst_jpeg_LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg